Page MenuHomePhabricator
Authored By
zeljkofilipin
Mar 28 2019, 2:21 PM
Size
4 KB
Referenced Files
None
Subscribers
None
~/Documents/gerrit/mediawiki/vagrant/mediawiki$ vagrant ssh
vagrant@vagrant:/vagrant/mediawiki$ node -v
v6.16.0
vagrant@vagrant:/vagrant/mediawiki$ npm -v
2.15.12
vagrant@vagrant:/vagrant/mediawiki$ npm i
npm WARN peerDependencies The peer dependency karma@^0.13.0 || ^1.0.0 included from grunt-karma will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN peerDependencies The peer dependency stylelint@^9.0.0 included from grunt-stylelint will no
npm WARN peerDependencies longer be automatically installed to fulfill the peerDependency
npm WARN peerDependencies in npm 3+. Your application will need to depend on it explicitly.
npm WARN deprecated nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN engine fibers@3.1.1: wanted: {"node":">=8.0.0"} (current: {"node":"6.16.0","npm":"2.15.12"})
npm WARN optional dep failed, continuing fsevents@1.2.7
npm WARN deprecated circular-json@0.5.9: CircularJSON is in maintenance only, flatted is its successor.
> fibers@3.1.1 install /vagrant/mediawiki/node_modules/wdio-mocha-framework/node_modules/wdio-sync/node_modules/fibers
> node build.js || nodejs build.js
make: Entering directory '/vagrant/mediawiki/node_modules/wdio-mocha-framework/node_modules/wdio-sync/node_modules/fibers/build'
CXX(target) Release/obj.target/fibers/src/fibers.o
../src/fibers.cc: In instantiation of ‘void uni::MakeWeak(v8::Isolate*, v8::Persistent<S>&, P*) [with void (* F)(void*) = Fiber::WeakCallback; T = v8::Object; P = void]’:
../src/fibers.cc:440:60: required from here
../src/fibers.cc:44:3: warning: ‘void v8::PersistentBase<T>::SetWeak(P*, typename v8::WeakCallbackData<T, P>::Callback) [with P = void; T = v8::Object; typename v8::WeakCallbackData<T, P>::Callback = void (*)(const v8::WeakCallbackData<v8::Object, void>&)]’ is deprecated: use WeakCallbackInfo version [-Wdeprecated-declarations]
handle.SetWeak(val, WeakCallbackShim<F>);
^~~~~~
In file included from /home/vagrant/.node-gyp/6.16.0/include/node/node.h:42:0,
from ../src/coroutine.h:1,
from ../src/fibers.cc:1:
/home/vagrant/.node-gyp/6.16.0/include/node/v8.h:7654:6: note: declared here
void PersistentBase<T>::SetWeak(
^~~~~~~~~~~~~~~~~
/home/vagrant/.node-gyp/6.16.0/include/node/v8.h: In instantiation of ‘void v8::PersistentBase<T>::SetWeak(P*, typename v8::WeakCallbackData<T, P>::Callback) [with P = void; T = v8::Object; typename v8::WeakCallbackData<T, P>::Callback = void (*)(const v8::WeakCallbackData<v8::Object, void>&)]’:
../src/fibers.cc:44:3: required from ‘void uni::MakeWeak(v8::Isolate*, v8::Persistent<S>&, P*) [with void (* F)(void*) = Fiber::WeakCallback; T = v8::Object; P = void]’
../src/fibers.cc:440:60: required from here
/home/vagrant/.node-gyp/6.16.0/include/node/v8.h:7657:16: warning: ‘void v8::PersistentBase<T>::SetWeak(P*, typename v8::WeakCallbackData<S, P>::Callback) [with S = v8::Object; P = void; T = v8::Object; typename v8::WeakCallbackData<S, P>::Callback = void (*)(const v8::WeakCallbackData<v8::Object, void>&)]’ is deprecated: use WeakCallbackInfo version [-Wdeprecated-declarations]
SetWeak<T, P>(parameter, callback);
~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
/home/vagrant/.node-gyp/6.16.0/include/node/v8.h:7642:6: note: declared here
void PersistentBase<T>::SetWeak(
^~~~~~~~~~~~~~~~~
CXX(target) Release/obj.target/fibers/src/coroutine.o
CC(target) Release/obj.target/fibers/src/libcoro/coro.o
SOLINK_MODULE(target) Release/obj.target/fibers.node
COPY Release/fibers.node
make: Leaving directory '/vagrant/mediawiki/node_modules/wdio-mocha-framework/node_modules/wdio-sync/node_modules/fibers/build'
Installed in `/vagrant/mediawiki/node_modules/wdio-mocha-framework/node_modules/wdio-sync/node_modules/fibers/bin/linux-x64-48-glibc/fibers.node`
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN engine fibers@3.1.1: wanted: {"node":">=8.0.0"} (current: {"node":"6.16.0","npm":"2.15.12"})
|
> sauce-connect-launcher@1.2.5 postinstall /vagrant/mediawiki/node_modules/wdio-sauce-service/node_modules/sauce-connect-launcher
> node scripts/install.js || nodejs scripts/install.js
npm ERR! Linux 4.9.0-8-amd64
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "i"
npm ERR! node v6.16.0
npm ERR! npm v2.15.12
npm ERR! code EPEERINVALID
npm ERR! peerinvalid The package karma@3.1.4 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer grunt-karma@3.0.0 wants karma@^0.13.0 || ^1.0.0
npm ERR! peerinvalid Peer karma-mocha-reporter@2.2.5 wants karma@>=0.13
npm ERR! Please include the following file with any support request:
npm ERR! /vagrant/mediawiki/npm-debug.log

File Metadata

Mime Type
text/plain; charset=utf-8
Storage Engine
blob
Storage Format
Raw Data
Storage Handle
7232571
Default Alt Text
raw.txt (4 KB)

Event Timeline