Page MenuHomePhabricator
Paste P15183

(An Untitled Masterwork)
ActivePublic

Authored by Legoktm on Wed, Apr 7, 12:33 AM.
Apr 07 00:21:00 upgrader-06 libup-celery[619]: $ date
Apr 07 00:21:00 upgrader-06 libup-celery[619]: Wed Apr 7 00:21:00 UTC 2021
Apr 07 00:21:00 upgrader-06 libup-celery[619]: $ git clone file:///srv/git/mediawiki-extensions-UniversalLanguageSelector.git repo --depth=1 -b master
Apr 07 00:21:01 upgrader-06 libup-celery[619]: Cloning into 'repo'...
Apr 07 00:21:01 upgrader-06 libup-celery[619]: $ git config user.name libraryupgrader
Apr 07 00:21:01 upgrader-06 libup-celery[619]: $ git config user.email tools.libraryupgrader@tools.wmflabs.org
Apr 07 00:21:02 upgrader-06 libup-celery[619]: $ git submodule update --init
Apr 07 00:21:02 upgrader-06 libup-celery[619]: $ grr init
Apr 07 00:21:02 upgrader-06 libup-celery[619]: Installed commit-msg hook.
Apr 07 00:21:02 upgrader-06 libup-celery[619]: $ git show-ref refs/heads/master
Apr 07 00:21:02 upgrader-06 libup-celery[619]: 5163fc82e5a3b6844b242e0170b05d9eea3a0004 refs/heads/master
Apr 07 00:21:03 upgrader-06 libup-celery[619]: $ composer install
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Loading composer repositories with package information
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Updating dependencies (including require-dev)
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Package operations: 32 installs, 0 updates, 0 removals
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing composer/installers (v1.10.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing squizlabs/php_codesniffer (3.5.8): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing composer/spdx-licenses (1.5.5): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing composer/semver (3.2.4): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing mediawiki/mediawiki-codesniffer (v35.0.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-php80 (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-mbstring (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-intl-normalizer (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-intl-grapheme (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-ctype (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/string (v5.2.6): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing psr/container (1.1.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/service-contracts (v2.2.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/polyfill-php73 (v1.22.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing symfony/console (v5.2.6): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing psr/log (1.1.3): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing sabre/event (5.1.2): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing netresearch/jsonmapper (v2.1.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing microsoft/tolerant-php-parser (v0.0.23): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing phpdocumentor/reflection-common (2.2.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing webmozart/assert (1.10.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing phpdocumentor/type-resolver (1.4.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing phpdocumentor/reflection-docblock (5.2.2): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing felixfbecker/advanced-json-rpc (v3.2.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing composer/xdebug-handler (1.4.6): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing phan/phan (3.2.6): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing mediawiki/phan-taint-check-plugin (3.2.1): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing mediawiki/mediawiki-phan-config (0.10.6): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing mediawiki/minus-x (1.1.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing php-parallel-lint/php-console-color (v0.3): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing php-parallel-lint/php-console-highlighter (v0.5): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: - Installing php-parallel-lint/php-parallel-lint (v1.2.0): Loading from cache
Apr 07 00:21:10 upgrader-06 libup-celery[619]: symfony/service-contracts suggests installing symfony/service-implementation
Apr 07 00:21:10 upgrader-06 libup-celery[619]: symfony/console suggests installing symfony/event-dispatcher
Apr 07 00:21:10 upgrader-06 libup-celery[619]: symfony/console suggests installing symfony/lock
Apr 07 00:21:10 upgrader-06 libup-celery[619]: symfony/console suggests installing symfony/process
Apr 07 00:21:10 upgrader-06 libup-celery[619]: phan/phan suggests installing ext-ast (Needed for parsing ASTs (unless --use-fallback-parser is used). 1.0.1+ is needed, 1.0.8+ is recommended.)
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Writing lock file
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Generating autoload files
Apr 07 00:21:10 upgrader-06 libup-celery[619]: 13 packages you are using are looking for funding.
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Use the `composer fund` command to find out more!
Apr 07 00:21:10 upgrader-06 libup-celery[619]: Upgrading n:eslint-config-wikimedia from 0.17.0 -> 0.19.0
Apr 07 00:21:10 upgrader-06 libup-celery[619]: $ npm install
Apr 07 00:23:40 upgrader-06 libup-celery[619]: > core-js@3.10.0 postinstall /src/repo/node_modules/core-js
Apr 07 00:23:40 upgrader-06 libup-celery[619]: > node -e "try{require('./postinstall')}catch(e){}"
Apr 07 00:23:40 upgrader-06 libup-celery[619]: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!
Apr 07 00:23:40 upgrader-06 libup-celery[619]: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:
Apr 07 00:23:40 upgrader-06 libup-celery[619]: > https://opencollective.com/core-js
Apr 07 00:23:40 upgrader-06 libup-celery[619]: > https://www.patreon.com/zloirock
Apr 07 00:23:40 upgrader-06 libup-celery[619]: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)
Apr 07 00:23:40 upgrader-06 libup-celery[619]: added 720 packages from 372 contributors and audited 720 packages in 148.495s
Apr 07 00:23:40 upgrader-06 libup-celery[619]: 90 packages are looking for funding
Apr 07 00:23:40 upgrader-06 libup-celery[619]: run `npm fund` for details
Apr 07 00:23:40 upgrader-06 libup-celery[619]: found 0 vulnerabilities
Apr 07 00:23:40 upgrader-06 libup-celery[619]: $ npm update eslint -depth 10
Apr 07 00:25:01 upgrader-06 libup-celery[619]: + eslint@7.23.0
Apr 07 00:25:01 upgrader-06 libup-celery[619]: added 17 packages from 9 contributors, removed 9 packages, updated 17 packages, moved 1 package and audited 728 packages in 69.792s
Apr 07 00:25:01 upgrader-06 libup-celery[619]: 85 packages are looking for funding
Apr 07 00:25:01 upgrader-06 libup-celery[619]: run `npm fund` for details
Apr 07 00:25:01 upgrader-06 libup-celery[619]: found 0 vulnerabilities
Apr 07 00:25:01 upgrader-06 libup-celery[619]: $ npm install grunt-eslint@23.0.0 --save-exact
Apr 07 00:26:13 upgrader-06 libup-celery[619]: + grunt-eslint@23.0.0
Apr 07 00:26:13 upgrader-06 libup-celery[619]: updated 3 packages and audited 728 packages in 71.017s
Apr 07 00:26:13 upgrader-06 libup-celery[619]: 88 packages are looking for funding
Apr 07 00:26:13 upgrader-06 libup-celery[619]: run `npm fund` for details
Apr 07 00:26:13 upgrader-06 libup-celery[619]: found 0 vulnerabilities
Apr 07 00:26:14 upgrader-06 libup-celery[619]: $ ./node_modules/.bin/eslint i18n/bar.json i18n/sd.json i18n/chr.json i18n/ike-cans.json resources/js/ext.uls.inputsettings.js i18n/kk-cyrl.json i18n/arz.json i18n/api/es.json i18n/mnc.json i
Apr 07 00:26:55 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.common.js
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 195:56 error navigator.languages() is not supported in Safari 5.1 compat/compat
Apr 07 00:26:55 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.displaysettings.js
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 120:3 warning Missing JSDoc @return declaration jsdoc/require-returns
Apr 07 00:26:55 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.inputsettings.js
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 276:10 warning 'language' is already declared in the upper scope on line 229 column 14 no-shadow
Apr 07 00:26:55 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.interface.js
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 56:1 warning This line has a length of 114. Maximum allowed is 100 max-len
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 58:1 warning This line has a length of 108. Maximum allowed is 100 max-len
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 60:0 warning The type 'bool' is undefined jsdoc/no-undefined-types
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 64:1 warning This line has a length of 103. Maximum allowed is 100 max-len
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 231:2 warning Missing JSDoc @return declaration jsdoc/require-returns
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 234:0 warning The type 'ULS' is undefined jsdoc/no-undefined-types
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 246:1 warning This line has a length of 116. Maximum allowed is 100 max-len
Apr 07 00:26:55 upgrader-06 libup-celery[619]: 482:1 warning This line has a length of 103. Maximum allowed is 100 max-len
Apr 07 00:26:55 upgrader-06 libup-celery[619]: ✖ 11 problems (1 error, 10 warnings)
Apr 07 00:26:55 upgrader-06 libup-celery[619]: $ ./node_modules/.bin/eslint i18n/bar.json i18n/sd.json i18n/chr.json i18n/ike-cans.json resources/js/ext.uls.inputsettings.js i18n/kk-cyrl.json i18n/arz.json i18n/api/es.json i18n/mnc.json i
Apr 07 00:27:33 upgrader-06 libup-celery[619]: [{"filePath":"/src/repo/Gruntfile.js","messages":[],"errorCount":0,"warningCount":0,"fixableErrorCount":0,"fixableWarningCount":0,"usedDeprecatedRules":[]},{"filePath":"/src/repo/composer.jso
Apr 07 00:27:33 upgrader-06 libup-celery[619]: t":0,"fixableWarningCount":0,"usedDeprecatedRules":[]},{"filePath":"/src/repo/i18n/nl-informal.json","messages":[],"errorCount":0,"warningCount":0,"fixableErrorCount":0,"fixableWarningCount":
Apr 07 00:27:33 upgrader-06 libup-celery[619]: \t\tnewWebfontsEnable = newRegistry.webfontsEnabled;\n\t\t\t\toldWebfontsEnable = oldRegistry.webfontsEnabled;\n\t\t\t\tif ( oldWebfontsEnable === undefined ) {\n\t\t\t\t\toldWebfontsEnable =
Apr 07 00:27:33 upgrader-06 libup-celery[619]: $ npm ci
Apr 07 00:27:43 upgrader-06 libup-celery[619]: npm WARN prepare removing existing node_modules/ before installation
Apr 07 00:27:43 upgrader-06 libup-celery[619]: > core-js@3.10.0 postinstall /src/repo/node_modules/core-js
Apr 07 00:27:43 upgrader-06 libup-celery[619]: > node -e "try{require('./postinstall')}catch(e){}"
Apr 07 00:27:43 upgrader-06 libup-celery[619]: Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript standard library!
Apr 07 00:27:43 upgrader-06 libup-celery[619]: The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:
Apr 07 00:27:43 upgrader-06 libup-celery[619]: > https://opencollective.com/core-js
Apr 07 00:27:43 upgrader-06 libup-celery[619]: > https://www.patreon.com/zloirock
Apr 07 00:27:43 upgrader-06 libup-celery[619]: Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)
Apr 07 00:27:43 upgrader-06 libup-celery[619]: added 728 packages in 8.668s
Apr 07 00:27:43 upgrader-06 libup-celery[619]: $ npm test
Apr 07 00:28:34 upgrader-06 libup-celery[619]: > @ test /src/repo
Apr 07 00:28:34 upgrader-06 libup-celery[619]: > grunt test
Apr 07 00:28:34 upgrader-06 libup-celery[619]: Running "eslint:all" (eslint) task
Apr 07 00:28:34 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.common.js
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 195:56 warning navigator.languages() is not supported in Safari 5.1 compat/compat
Apr 07 00:28:34 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.displaysettings.js
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 120:3 warning Missing JSDoc @return declaration jsdoc/require-returns
Apr 07 00:28:34 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.inputsettings.js
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 276:10 warning 'language' is already declared in the upper scope on line 229 column 14 no-shadow
Apr 07 00:28:34 upgrader-06 libup-celery[619]: /src/repo/resources/js/ext.uls.interface.js
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 56:1 warning This line has a length of 114. Maximum allowed is 100 max-len
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 58:1 warning This line has a length of 108. Maximum allowed is 100 max-len
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 60:0 warning The type 'bool' is undefined jsdoc/no-undefined-types
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 64:1 warning This line has a length of 103. Maximum allowed is 100 max-len
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 231:2 warning Missing JSDoc @return declaration jsdoc/require-returns
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 234:0 warning The type 'ULS' is undefined jsdoc/no-undefined-types
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 246:1 warning This line has a length of 116. Maximum allowed is 100 max-len
Apr 07 00:28:34 upgrader-06 libup-celery[619]: 482:1 warning This line has a length of 103. Maximum allowed is 100 max-len
Apr 07 00:28:34 upgrader-06 libup-celery[619]: ✖ 11 problems (0 errors, 11 warnings)
Apr 07 00:28:34 upgrader-06 libup-celery[619]: Running "stylelint:src" (stylelint) task
Apr 07 00:28:34 upgrader-06 libup-celery[619]: >> Linted 15 files without errors
Apr 07 00:28:34 upgrader-06 libup-celery[619]: Running "banana:UniversalLanguageSelector" (banana) task
Apr 07 00:28:34 upgrader-06 libup-celery[619]: >> 2 message directories checked.
Apr 07 00:28:34 upgrader-06 libup-celery[619]: Done.
Apr 07 00:28:34 upgrader-06 libup-celery[619]: Upgrading c:mediawiki/minus-x from 1.1.0 -> 1.1.1
Apr 07 00:28:34 upgrader-06 libup-celery[619]: $ composer update
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Loading composer repositories with package information
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Updating dependencies (including require-dev)
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Package operations: 0 installs, 1 update, 0 removals
Apr 07 00:28:41 upgrader-06 libup-celery[619]: - Updating mediawiki/minus-x (1.1.0 => 1.1.1): Loading from cache
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Writing lock file
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Generating autoload files
Apr 07 00:28:41 upgrader-06 libup-celery[619]: 13 packages you are using are looking for funding.
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Use the `composer fund` command to find out more!
Apr 07 00:28:41 upgrader-06 libup-celery[619]: $ composer install
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Loading composer repositories with package information
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Installing dependencies (including require-dev) from lock file
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Nothing to install or update
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Generating autoload files
Apr 07 00:28:41 upgrader-06 libup-celery[619]: 13 packages you are using are looking for funding.
Apr 07 00:28:41 upgrader-06 libup-celery[619]: Use the `composer fund` command to find out more!
Apr 07 00:28:41 upgrader-06 libup-celery[619]: $ composer test
Apr 07 00:28:42 upgrader-06 libup-celery[619]: > parallel-lint . --exclude vendor --exclude node_modules
Apr 07 00:28:42 upgrader-06 libup-celery[619]: PHP 7.3.19 | 10 parallel jobs
Apr 07 00:28:42 upgrader-06 libup-celery[619]: .................... 20/20 (100 %)
Apr 07 00:28:42 upgrader-06 libup-celery[619]: Checked 20 files in 0.1 seconds
Apr 07 00:28:42 upgrader-06 libup-celery[619]: No syntax error found
Apr 07 00:28:42 upgrader-06 libup-celery[619]: > phpcs -p -s
Apr 07 00:28:42 upgrader-06 libup-celery[619]: ................... 19 / 19 (100%)
Apr 07 00:28:42 upgrader-06 libup-celery[619]: Time: 953ms; Memory: 12MB
Apr 07 00:28:42 upgrader-06 libup-celery[619]: > minus-x check .
Apr 07 00:28:42 upgrader-06 libup-celery[619]: MinusX
Apr 07 00:28:42 upgrader-06 libup-celery[619]: ======
Apr 07 00:28:42 upgrader-06 libup-celery[619]: Processing /src/repo...
Apr 07 00:28:42 upgrader-06 libup-celery[619]: .............................................................
Apr 07 00:28:42 upgrader-06 libup-celery[619]: ...............................................
Apr 07 00:28:42 upgrader-06 libup-celery[619]: All good!
Apr 07 00:28:44 upgrader-06 libup-celery[619]: $ git add .
Apr 07 00:28:49 upgrader-06 libup-celery[619]: $ git commit -F /tmp/tmpn46fdtuo
Apr 07 00:28:49 upgrader-06 libup-celery[619]: [master 9473d72] build: Updating dependencies
Apr 07 00:28:49 upgrader-06 libup-celery[619]: 8 files changed, 6613 insertions(+), 6094 deletions(-)
Apr 07 00:28:49 upgrader-06 libup-celery[619]: rewrite data/langsamples.json (98%)
Apr 07 00:28:49 upgrader-06 libup-celery[619]: rewrite package-lock.json (98%)
Apr 07 00:28:49 upgrader-06 libup-celery[619]: $ git format-patch HEAD~1 --stdout
Apr 07 00:28:49 upgrader-06 libup-celery[619]: From 9473d72f1467b4f85a61676ec87eb3dd074b7037 Mon Sep 17 00:00:00 2001
Apr 07 00:28:49 upgrader-06 libup-celery[619]: From: libraryupgrader <tools.libraryupgrader@tools.wmflabs.org>
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Date: Wed, 7 Apr 2021 00:28:49 +0000
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Subject: [PATCH] build: Updating dependencies
Apr 07 00:28:49 upgrader-06 libup-celery[619]: MIME-Version: 1.0
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Content-Type: text/plain; charset=UTF-8
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Content-Transfer-Encoding: 8bit
Apr 07 00:28:49 upgrader-06 libup-celery[619]: composer:
Apr 07 00:28:49 upgrader-06 libup-celery[619]: * mediawiki/minus-x: 1.1.0 → 1.1.1
Apr 07 00:28:49 upgrader-06 libup-celery[619]: npm:
Apr 07 00:28:49 upgrader-06 libup-celery[619]: * eslint-config-wikimedia: 0.17.0 → 0.19.0
Apr 07 00:28:49 upgrader-06 libup-celery[619]: The following rules are failing and were disabled:
Apr 07 00:28:49 upgrader-06 libup-celery[619]: * compat/compat
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Additional changes:
Apr 07 00:28:49 upgrader-06 libup-celery[619]: * Added the "composer phan" command to conveniently run phan.
Apr 07 00:28:49 upgrader-06 libup-celery[619]: * eslint: Renamed `wikimedia/client` profile to `client-es5` (T277085).
Apr 07 00:28:49 upgrader-06 libup-celery[619]: Change-Id: Ic738650359f2222653fd0708b6c00e9e06136206
Apr 07 00:28:49 upgrader-06 libup-celery[619]: ---
Apr 07 00:28:49 upgrader-06 libup-celery[619]: .eslintrc.json | 5 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: composer.json | 5 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: data/langsamples.json | 240 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: i18n/en.json | 2 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: package-lock.json | 12441 +++++++++++++------------
Apr 07 00:28:49 upgrader-06 libup-celery[619]: package.json | 2 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: resources/js/ext.uls.compactlinks.js | 2 +-
Apr 07 00:28:49 upgrader-06 libup-celery[619]: resources/js/ext.uls.interface.js | 2 +
Apr 07 00:28:49 upgrader-06 libup-celery[619]: 8 files changed, 6609 insertions(+), 6090 deletions(-)
Apr 07 00:28:49 upgrader-06 libup-celery[619]: diff --git a/.eslintrc.json b/.eslintrc.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: index 61854bb..dc89fd8 100644
Apr 07 00:28:49 upgrader-06 libup-celery[619]: --- a/.eslintrc.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: +++ b/.eslintrc.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: @@ -1,13 +1,14 @@
Apr 07 00:28:49 upgrader-06 libup-celery[619]: {
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "root": true,
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "extends": [
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "wikimedia/client",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + "wikimedia/client-es5",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "wikimedia/jquery",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "wikimedia/mediawiki"
Apr 07 00:28:49 upgrader-06 libup-celery[619]: ],
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "rules": {
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "no-jquery/no-global-selector": "off",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "mediawiki/class-doc": "warn",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "no-shadow": "warn"
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + "no-shadow": "warn",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + "compat/compat": "warn"
Apr 07 00:28:49 upgrader-06 libup-celery[619]: }
Apr 07 00:28:49 upgrader-06 libup-celery[619]: }
Apr 07 00:28:49 upgrader-06 libup-celery[619]: diff --git a/composer.json b/composer.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: index 1f49280..424420e 100644
Apr 07 00:28:49 upgrader-06 libup-celery[619]: --- a/composer.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: +++ b/composer.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: @@ -27,7 +27,7 @@
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "require-dev": {
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "mediawiki/mediawiki-codesniffer": "35.0.0",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "mediawiki/mediawiki-phan-config": "0.10.6",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "mediawiki/minus-x": "1.1.0",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + "mediawiki/minus-x": "1.1.1",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "php-parallel-lint/php-console-highlighter": "0.5.0",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "php-parallel-lint/php-parallel-lint": "1.2.0"
Apr 07 00:28:49 upgrader-06 libup-celery[619]: },
Apr 07 00:28:49 upgrader-06 libup-celery[619]: @@ -40,6 +40,7 @@
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "parallel-lint . --exclude vendor --exclude node_modules",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "phpcs -p -s",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: "minus-x check ."
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - ]
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + ],
Apr 07 00:28:49 upgrader-06 libup-celery[619]: + "phan": "phan -d . --long-progress-bar"
Apr 07 00:28:49 upgrader-06 libup-celery[619]: }
Apr 07 00:28:49 upgrader-06 libup-celery[619]: }
Apr 07 00:28:49 upgrader-06 libup-celery[619]: diff --git a/data/langsamples.json b/data/langsamples.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: index 4d98535..ac6121a 100644
Apr 07 00:28:49 upgrader-06 libup-celery[619]: --- a/data/langsamples.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: +++ b/data/langsamples.json
Apr 07 00:28:49 upgrader-06 libup-celery[619]: @@ -1,122 +1,122 @@
Apr 07 00:28:49 upgrader-06 libup-celery[619]: {
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "adx": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "af": " Verander wagwoord Vee bladsye uit Daar is geen bladsye wat skakel na hierdie lêer nie. Sinhala Verskuiwing het geslaag Gereedskap Medewerkers Die bestemming bestaan nie Vlak 2-op
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "ahr": " भाषा: $1 भाषा: भाषा: भाषा",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "akk": "𒀝𒂵𒌈",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "am": " MediaWiki የስፓም ማፅዳት በዚሁ ዊኪ መግቢያ ቃል መቀይር አልተቻለም የአባልነት መዝገብ (user log) ይዞታውን ሁሉ (ከነውይይት ገጾች) ለመፈለግ ይህን ገጽ ሰርዝ አዲስ ገጽ የፋይሎች መዝገብ የ1 አባል ማዕረግ ለማስተዳደር የአባል ገጾች የሚቀጥለው ገጽ → የውስጥ ስህተት:
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "ang": " Þīn þafungword sceal wesan ungelīc þīnum brūcendes naman. Nīwe þafungword: Manigfeald sēcung ← Ieldre adihtung [URL is tō lang] Warnung: Se tramet þe þū wilt forlēosan hafaþ stǣ
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "ar": " لا يمكن إجراء هذا الفعل على هذه الصفحة. غير متأثر بحدود المعدل تدوير الصورة {{PLURAL:$1||درجة واحدة|درجتان|$1 درجات|$1 درجة}} باتجاه عقارب الساعة صفحات تصنيف «$1» مضمن الأولوية مح
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "arb": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "arc": " ܚܪܘܡ ܡܦܠܚܢܐ ܗܢܐ ܫܢܝܬܐ ܕܗܢܐ ܠܦܦܐ ܛܪ ܠܗܕܐ ܦܐܬܐ ܙܠ $1 {{PLURAL:$1|ܒܐܝܛ|ܒܐܝܛ̈ܐ}} ܐܣܘܪ̈ܐ ܐܚܪ̈ܢܐ {{GENDER:$1|ܡܦܠܚܢܐ ܡܫܪܪܐ ܝܬܐܝܬ|ܡܦܠܚܢܬܐ ܡܫܪܪܬܐ ܝܬܐܝܬ}} ܠܝܬܝܟ ܥܠܝܠܐ ܒܨܝ ܒܚܩܠܬ̈ܐ: ܪܟܝܟܐ ܚܒܝܫܬ̈
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "as": " শুদ্ধ শিৰোনাম প্ৰদৰ্শন কৰক কিটিপ: টেব্<U+200C> তালিকাত থকা টেবসমূহৰ মাজত বিচৰণ কৰিবলৈ সোঁ আৰু বাঁও কাঁড়চিনৰ কী টিপিব পাৰে। হয়, পৃষ্ঠাটো বিলোপ কৰক এই সদস্যনাম আৰু গুপ্তশব্দৰ ব্যৱহাৰ নিষিদ্ধ কৰা হৈছে
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bbc": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bh": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bho": " बहुत ढेर खर्चीला पार्सर फंक्शन काल वाला पन्ना सभ क्षमा करीं, ई समय सर्वर पर बहुत ज्यादा लोड बढ़ गईल बा।\nई पन्ना के बहुते प्रयोगकर्ता लोग देखे के कोशिश कर रहल बानी।\nई पन्ना के फिर से देखे से पहिले कृपया कुछ
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bk": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bn": " রোলব্যাকের পরে পার্থক্য দেখিও না মেয়াদোত্তীর্ণ সময় অবৈধ। দল যা আপনি পরিবর্তন করতে পারেন আসল নাম (ঐচ্ছিক) এটি যাচাইকৃত রিভিশনের তালিকা। GPS গ্রাহকের দ্রুতি মঙ্গলবার এই পাতার বিষয়বস্তুর মডেল পরি
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bo": " $1 རང་འགུལ་འཕྲུལ་ཆས། ཡིག་ཆ་ཡར་འཇུག་ལས་ནང་འདྲེན་བྱེད་པའི་ཤོག་ངོས། \"$1\" ཤོག་ངོས་འདིར་བསྐྱར་བཅོས་གསར་སྐྲུན་བྱེད་ཐུབ་མ་སོང། ཤོག་ངོས་ཚང་མ་བལྟས་ཟིན་དུ་རྟགས་རྒྱོབ། མཐའ་མ། གནས་སྐབས་ལམ་ཡིག ངོས་མ་ཟིན་པའི་དྲ་འབུ། ཁྱེད་ལ་འཕྲིན་གསར་$1
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bod": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bpy": " আটলান্টিক মহাসাগর ফাইল আপলোড কর আগস্ট বারোইতুকর একাউন্টহান হঙকরানি ইল [[User:$1|$1]]-রে এরে চিঙনাঙর পাতা হঙকরানিত্ত থেত করিয়া থনা ইসে। কারণ: $2। ইরে তরতা একাউন্টহান নেই থাং? $1 পতানি
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "btk": "",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "bug": " Leppa Indoë Mapadécéŋ $1 Leppa papaké Link risaliweŋ (jangan lupa awalan http:// ) Kamisi' Accalinruŋi Judul dek essa (sininna) Pranala permanen pakitaï/tapo' Ita leppa panginri
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "ca": " La base de dades està temporalment bloquejada a noves entrades i altres tasques de manteniment, segurament per tasques rutinàries de manteniment, després de les quals es tornarà
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "cdo": " 敆擴展監視單單臺中顯示所有其更改,伓啻最近其更改 1點鐘:1 hour,1 日:1 day,1禮拜:1 week,2禮拜:2 weeks,1間月日:1 month,3間月日:3 months,6間月日:6 months,1年:1 year,永遠:infinite 敆
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "ckb": " تایلەندی دەتوانیت دەق و مێژووی دەستکاریی پەڕەیەکی دەستنیشان کراو یان کۆمەڵێک پەڕە کە ناو پەڕگەیەکی XML دا پێچراونەتەوە، هەناردە بکەیت.\nدەکرێت ئەمە لە ویکییەکی دیکەدا ھاوردە بکر
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "cr": " ᓃᔥᑕᒻᐹᔅᑌᒋᓂᑲᓐ ᓃᔥᑕᒻᐹᔅᑌᒋᓂᑲᓐ",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "cu": "Хрⷭ҇то́съ воскре́се и҆з̾ ме́ртвыхъ, сме́ртїю сме́рть попра́въ, и҆ сꙋ́щымъ во гробѣ́хъ живо́тъ дарова́въ.",
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "cy": " Dyma'r tocyn cudd i borthiant gwe eich rhestr wylio.\nBydd unrhyw un sy'n gwybod hwn yn gallu darllen eich rhestr wylio, felly peidiwch a'i roi i neb.\n[[Special:ResetTokens|Clic
Apr 07 00:28:49 upgrader-06 libup-celery[619]: - "da": " Følgende tekst udløste vores spamfilter: $1 '''Kunne ikke ændre logsynligheden.'''\n$1 Syntaksen i signaturen er ugyldig; kontroller venligst den brugte HTML. RSS-feed for denne
..........