Page MenuHomePhabricator
Paste P17288

mind-blown
ArchivedPublic

Authored by TheReadOnly on Sep 16 2021, 10:34 PM.
root@55ed657955c7:/home/puppet# git diff
diff --git a/modules/elasticsearch/manifests/log/hot_threads.pp b/modules/elasticsearch/manifests/log/hot_threads.pp
index 59253b1d79..c4674911df 100644
--- a/modules/elasticsearch/manifests/log/hot_threads.pp
+++ b/modules/elasticsearch/manifests/log/hot_threads.pp
@@ -37,7 +37,7 @@ class elasticsearch::log::hot_threads {
}
systemd::timer::job { 'elasticsearch-hot-threads-log':
- command => "${script}",
+ command => $script,
description => 'Archive exceptions logs of hot threads cluster',
user => 'elasticsearch',
monitoring_enabled => false,
root@55ed657955c7:/home/puppet# rbenv exec bundle exec rake test
diff --git a/modules/elasticsearch/manifests/log/hot_threads.pp b/modules/elasticsearch/manifests/log/hot_threads.pp
index 59253b1d79..c4674911df 100644
--- a/modules/elasticsearch/manifests/log/hot_threads.pp
+++ b/modules/elasticsearch/manifests/log/hot_threads.pp
@@ -37,7 +37,7 @@ class elasticsearch::log::hot_threads {
}
systemd::timer::job { 'elasticsearch-hot-threads-log':
- command => "${script}",
+ command => /usr/local/bin/elasticsearch_hot_threads_logger.py,
description => 'Archive exceptions logs of hot threads cluster',
user => 'elasticsearch',
monitoring_enabled => false,
root@55ed657955c7:/home/puppet# rbenv exec bundle exec rake test
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/util.rb:461: warning: URI.escape is obsolete
hint: Pulling without specifying how to reconcile divergent branches is
hint: discouraged. You can squelch this message by running one of the following
hint: commands sometime before your next pull:
hint:
hint: git config pull.rebase false # merge (the default strategy)
hint: git config pull.rebase true # rebase
hint: git config pull.ff only # fast-forward only
hint:
hint: You can replace "git config" with "git config --global" to set a default
hint: preference for all repositories. You can also pass --rebase, --no-rebase,
hint: or --ff-only on the command line to override the configured default per
hint: invocation.
/home/puppet/vendor/bundle/ruby/2.7.0/gems/git-1.3.0/lib/git/diff.rb:130: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/git-1.3.0/lib/git/lib.rb:862: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/git-1.3.0/lib/git/diff.rb:130: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/git-1.3.0/lib/git/lib.rb:862: warning: Using the last argument as keyword parameters is deprecated
---> syntax:manifests
hint: Pulling without specifying how to reconcile divergent branches is
hint: discouraged. You can squelch this message by running one of the following
hint: commands sometime before your next pull:
hint:
hint: git config pull.rebase false # merge (the default strategy)
hint: git config pull.rebase true # rebase
hint: git config pull.ff only # fast-forward only
hint:
hint: You can replace "git config" with "git config --global" to set a default
hint: preference for all repositories. You can also pass --rebase, --no-rebase,
hint: or --ff-only on the command line to override the configured default per
hint: invocation.
No typo found.
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/file_system/file_impl.rb:80: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/file_system/file_impl.rb:80: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/file_system/file_impl.rb:80: warning: Using the last argument as keyword parameters is deprecated
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/util.rb:461: warning: URI.escape is obsolete
/home/puppet/vendor/bundle/ruby/2.7.0/gems/puppet-5.5.10/lib/puppet/file_system/file_impl.rb:80: warning: Using the last argument as keyword parameters is deprecated
Could not parse for environment *root*: Syntax error at 'local' (file: /home/puppet/modules/elasticsearch/manifests/log/hot_threads.pp, line: 40, column: 36)
root@55ed657955c7:/home/puppet# commit-message installed: commit-message-validator==0.7.0
commit-message run-test-pre: PYTHONHASHSEED='2772542411'
commit-message run-test: commands[0] | commit-message-validator
commit-message-validator v0.7.0
Using GerritMessageValidator to check the commit message
Commit message is formatted properly! Keep up the good work!
____________________________________________________________ summary _____________________________________________________________
commit-message: commands succeeded
congratulations :)
^C

Event Timeline