Paste P6481

Dependency hell between Composer librairies used in MediaWiki extensions and skins
ActivePublic

Authored by Seb35 on Dec 18 2017, 2:34 PM.
$ # 854 extensions and 46 skins in master versions mostly from Gerrit and some from GitHub (up-to-date) in a MediaWiki master (up-to-date) as of today (2017-12-18), for a total of 784 composer.json (1 from MediaWiki, 740 from extensions, 43 from skins)
$ # Added in root composer.json "extra": { "merge-plugin": { "include": [ "composer.local.json", "extensions/*/composer.json", "skins/*/composer.json" ], "merge-dev": false } }
$ # No issue with the subset of the extensions/skins included by default in the tarball (it only installs composer/installers and symfony/process in addition of the MediaWiki’s default librairies)
$ # ------------------------
$ composer update --no-dev
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Package operations: 25 installs, 0 updates, 0 removals
- Installing wikimedia/composer-merge-plugin (v1.4.1) Loading from cache
- Installing composer/semver (1.4.2) Loading from cache
- Installing cssjanus/cssjanus (v1.2.0) Loading from cache
- Installing liuggio/statsd-php-client (v1.0.18) Loading from cache
- Installing mediawiki/at-ease (v1.1.0) Loading from cache
- Installing oojs/oojs-ui (v0.24.3) Loading from cache
- Installing oyejorge/less.php (v1.7.0.14) Loading from cache
- Installing wikimedia/assert (v0.2.2) Loading from cache
- Installing wikimedia/base-convert (v1.0.1) Loading from cache
- Installing wikimedia/cdb (1.4.1) Loading from cache
- Installing wikimedia/cldr-plural-rule-parser (v1.0.0) Loading from cache
- Installing wikimedia/html-formatter (1.0.1) Loading from cache
- Installing wikimedia/ip-set (1.1.0) Loading from cache
- Installing psr/log (1.0.2) Loading from cache
- Installing wikimedia/php-session-serializer (v1.0.4) Loading from cache
- Installing wikimedia/purtle (v1.0.6) Loading from cache
- Installing wikimedia/relpath (2.0.0) Loading from cache
- Installing wikimedia/utfnormal (v1.1.0) Loading from cache
- Installing wikimedia/remex-html (1.0.1) Loading from cache
- Installing wikimedia/running-stat (v1.1.0) Loading from cache
- Installing wikimedia/scoped-callback (v1.0.0) Loading from cache
- Installing wikimedia/timestamp (v1.0.0) Loading from cache
- Installing wikimedia/wait-condition-loop (v1.0.1) Loading from cache
- Installing wikimedia/wrappedstring (v2.2.0) Loading from cache
- Installing zordius/lightncandy (v0.23) Loading from cache
Writing lock file
Generating optimized autoload files
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- The requested package oojs/oojs-ui 0.4.* is satisfiable by oojs/oojs-ui[v0.4.0] but these conflict with your requirements or minimum-stability.
Problem 2
- The requested package pimple/pimple ~2.1 is satisfiable by pimple/pimple[v2.1.0, v2.1.1] but these conflict with your requirements or minimum-stability.
Problem 3
- The requested package symfony/process ~3.3 is satisfiable by symfony/process[3.3.x-dev, 3.4.x-dev, v3.3.0, v3.3.0-BETA1, v3.3.0-RC1, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.2] but these conflict with your requirements or minimum-stability.
Problem 4
- The requested package param-processor/param-processor ~1.0.0 is satisfiable by param-processor/param-processor[1.0, 1.0.1, 1.0.2] but these conflict with your requirements or minimum-stability.
Problem 5
- Installation request for sami/sami ~2.0 -> satisfiable by sami/sami[v2.0.0].
- sami/sami v2.0.0 requires pimple/pimple 2.* -> satisfiable by pimple/pimple[v2.0.0, v2.1.0, v2.1.1] but these conflict with your requirements or minimum-stability.
Problem 6
- Installation request for param-processor/param-processor 1.2.2 -> satisfiable by param-processor/param-processor[1.2.2].
- param-processor/param-processor 1.2.2 requires data-values/interfaces ~0.1.4 -> satisfiable by data-values/interfaces[0.1.4, 0.1.5] but these conflict with your requirements or minimum-stability.
Problem 7
- Installation request for ext-geoip 1.1.1 -> satisfiable by ext-geoip[1.1.1].
- geoip/geoip v1.17 conflicts with ext-geoip[1.1.1].
- Installation request for geoip/geoip 1.17 -> satisfiable by geoip/geoip[v1.17].
To enable extensions, verify that they are enabled in your .ini files:
- /etc/php/7.0/cli/php.ini
- /etc/php/7.0/cli/conf.d/10-mysqlnd.ini
- /etc/php/7.0/cli/conf.d/10-opcache.ini
- /etc/php/7.0/cli/conf.d/10-pdo.ini
- /etc/php/7.0/cli/conf.d/15-xml.ini
- /etc/php/7.0/cli/conf.d/20-apcu.ini
- /etc/php/7.0/cli/conf.d/20-bz2.ini
- /etc/php/7.0/cli/conf.d/20-calendar.ini
- /etc/php/7.0/cli/conf.d/20-ctype.ini
- /etc/php/7.0/cli/conf.d/20-curl.ini
- /etc/php/7.0/cli/conf.d/20-dom.ini
- /etc/php/7.0/cli/conf.d/20-exif.ini
- /etc/php/7.0/cli/conf.d/20-fileinfo.ini
- /etc/php/7.0/cli/conf.d/20-ftp.ini
- /etc/php/7.0/cli/conf.d/20-gd.ini
- /etc/php/7.0/cli/conf.d/20-geoip.ini
- /etc/php/7.0/cli/conf.d/20-gettext.ini
- /etc/php/7.0/cli/conf.d/20-gmp.ini
- /etc/php/7.0/cli/conf.d/20-iconv.ini
- /etc/php/7.0/cli/conf.d/20-igbinary.ini
- /etc/php/7.0/cli/conf.d/20-intl.ini
- /etc/php/7.0/cli/conf.d/20-json.ini
- /etc/php/7.0/cli/conf.d/20-mbstring.ini
- /etc/php/7.0/cli/conf.d/20-msgpack.ini
- /etc/php/7.0/cli/conf.d/20-mysqli.ini
- /etc/php/7.0/cli/conf.d/20-pdo_mysql.ini
- /etc/php/7.0/cli/conf.d/20-pdo_sqlite.ini
- /etc/php/7.0/cli/conf.d/20-phar.ini
- /etc/php/7.0/cli/conf.d/20-posix.ini
- /etc/php/7.0/cli/conf.d/20-readline.ini
- /etc/php/7.0/cli/conf.d/20-shmop.ini
- /etc/php/7.0/cli/conf.d/20-simplexml.ini
- /etc/php/7.0/cli/conf.d/20-sockets.ini
- /etc/php/7.0/cli/conf.d/20-sqlite3.ini
- /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
- /etc/php/7.0/cli/conf.d/20-sysvsem.ini
- /etc/php/7.0/cli/conf.d/20-sysvshm.ini
- /etc/php/7.0/cli/conf.d/20-tideways.ini
- /etc/php/7.0/cli/conf.d/20-tidy.ini
- /etc/php/7.0/cli/conf.d/20-tokenizer.ini
- /etc/php/7.0/cli/conf.d/20-wddx.ini
- /etc/php/7.0/cli/conf.d/20-xdebug.ini
- /etc/php/7.0/cli/conf.d/20-xmlreader.ini
- /etc/php/7.0/cli/conf.d/20-xmlwriter.ini
- /etc/php/7.0/cli/conf.d/20-xsl.ini
- /etc/php/7.0/cli/conf.d/25-memcached.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 7 (semel) is caused by SecureSessions
$ # Problems 1, 2, 5 (semel) are caused by OOUIPlayground
$ # Problem 3 (semel) is caused by SyntaxHighlight_GeSHi - a patch is proposed by Legoktm, see T181771
$ # Problem 4 (semel) is caused by skin Material
$ # Problem 6 (semel) is caused by SideBarMenu
$ # ------------------------
$ # When these dependencies are removed (which is not a solution, except to check dependency hells), the four following executions of composer update --no-dev show the four following issues:
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- wikimedia/gpglib 0.2.1 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0] but these conflict with your requirements or minimum-stability.
- wikimedia/gpglib 0.2.0 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0] but these conflict with your requirements or minimum-stability.
- Installation request for wikimedia/gpglib 0.2.* -> satisfiable by wikimedia/gpglib[0.2.0, 0.2.1].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (bis) is caused by GPGMail - this was fixed by bd808 in https://github.com/wikimedia/php-gpglib/pull/5 and is only awaiting a new stable version of wikimedia/gpglib
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- google/apiclient v2.2.1 requires guzzlehttp/guzzle ~5.3.1|~6.0 -> satisfiable by guzzlehttp/guzzle[5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.2.0 requires guzzlehttp/guzzle ~5.3.1|~6.0 -> satisfiable by guzzlehttp/guzzle[5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.1.3 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.1.2 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.1.1 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.1.0 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.3 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.2 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.1 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC8 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC7 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC6 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC5 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC4 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC3 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC2 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0-RC1 requires guzzlehttp/guzzle 5.2.* -> satisfiable by guzzlehttp/guzzle[5.2.0] but these conflict with your requirements or minimum-stability.
- google/apiclient v2.0.0 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
- Installation request for google/apiclient ^2.0.0@RC -> satisfiable by google/apiclient[v2.0.0, v2.0.0-RC1, v2.0.0-RC2, v2.0.0-RC3, v2.0.0-RC4, v2.0.0-RC5, v2.0.0-RC6, v2.0.0-RC7, v2.0.0-RC8, v2.0.1, v2.0.2, v2.0.3, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.2.0, v2.2.1].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (ter) is caused by GoogleAnalyticsTopPages and GoogleLogin
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- microsoft/windowsazure v0.5.7 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.6 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.5 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.4 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.3 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.2 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.1 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.5.0 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.4.4 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
- microsoft/azure-storage v0.10.2 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/azure-storage v0.10.1 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/azure-storage v0.10.0 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.4.3 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.4.2 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
- microsoft/windowsazure v0.4.1 requires pear-pear2.php.net/http_request2 * -> no matching package found.
- microsoft/windowsazure v0.4.0 requires pear-pear/http_request2 * -> no matching package found.
- microsoft/windowsazure v0.4.5 requires microsoft/azure-storage ^0.10 -> satisfiable by microsoft/azure-storage[v0.10.0, v0.10.1, v0.10.2].
- Installation request for microsoft/windowsazure * -> satisfiable by microsoft/windowsazure[v0.4.0, v0.4.1, v0.4.2, v0.4.3, v0.4.4, v0.4.5, v0.5.0, v0.5.1, v0.5.2, v0.5.3, v0.5.4, v0.5.5, v0.5.6, v0.5.7].
Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (quater) is caused by WindowsAzureStorage
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
[Composer\DependencyResolver\SolverProblemsException]
Problem 1
- The requested package monolog/monolog ~1.18.2 exists as monolog/monolog[1.22.1] but these are rejected by your constraint.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
$ # Problem 1 (quinquies) is caused by DonationInterface
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Package operations: 108 installs, 0 updates, 0 removals
- Installing composer/installers (v1.4.0) Loading from cache
- Installing mediawiki/semantic-forms (3.7) Downloading: 100%
- Installing firebase/php-jwt (v4.0.0) Downloading: 100%
- Installing psr/cache (1.0.1) Downloading: 100%
- Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Downloading: 100%
- Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
- Installing pimple/pimple (v3.0.2) Downloading: 100%
- Installing bordercloud/sparql (1.2.1) Downloading: 100%
- Installing php-http/discovery (v0.8.0) Downloading: 100%
- Installing php-http/promise (v1.0.0) Downloading: 100%
- Installing psr/http-message (1.0.1) Downloading: 100%
- Installing php-http/httplug (v1.1.0) Downloading: 100%
- Installing guzzlehttp/psr7 (1.4.2) Downloading: 100%
- Installing mailgun/mailgun-php (v2.0) Downloading: 100%
- Installing openid/php-openid (2.3.0) Downloading: 100%
- Installing netbrain/highcharts-js (3.0.9) Downloading: 100%
- Installing sentry/sentry (0.12.1) Downloading: 100%
- Installing wikimedia/css-sanitizer (v1.0.2) Downloading: 100%
- Installing mustangostang/spyc (0.6.2) Downloading: 100%
- Installing mediawiki/universal-language-selector (2017.10) Downloading: 100%
- Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
- Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
- Installing mediawiki/article-placeholder (dev-master 57c6a29) Cloning 57c6a291b4
- Installing wikibase/wikimedia-badges (dev-master 52617c5) Cloning 52617c5723
- Installing wikibase/wikidata.org (dev-master 812681b) Cloning 812681b863
[RuntimeException]
Failed to execute git clone --no-checkout 'https://gerrit.wikimedia.org/r/mediawiki/extensions/Wikidata.org' 'extensions/Wikidata.org/' && cd 'extensions/Wikidata.org/' && git remote add composer 'https:
//gerrit.wikimedia.org/r/mediawiki/extensions/Wikidata.org' && git fetch composer
fatal: destination path 'extensions/Wikidata.org' already exists and is not an empty directory.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
$ # Problem 1 (sexies) is caused by Wikidata extension -> the extension Wikidata.org is unusually named (with a point and an uppercase letter), not sure how composer/installers reacts (contrary to what is said in this error message, there were no "extensions/Wikidata.org" directory), I first removed entirely the extension Wikidata, re-ran composer, IT WORKED! and installed 101 libraries
$ # UPDATE [after initial post]: This issue and the very last issue of this paste are linked to the Wikidata extension where there are "sub-extensions" (whose Wikidata.org and Wikibase), which is unusual from the point of view of the root composer.json.
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Package operations: 101 installs, 0 updates, 0 removals
- Installing composer/installers (v1.4.0) Loading from cache
- Installing mediawiki/semantic-forms (3.7) Loading from cache
- Installing firebase/php-jwt (v4.0.0) Loading from cache
- Installing psr/cache (1.0.1) Loading from cache
- Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Loading from cache
- Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
- Installing pimple/pimple (v3.0.2) Loading from cache
- Installing bordercloud/sparql (1.2.1) Loading from cache
- Installing php-http/discovery (v0.8.0) Loading from cache
- Installing php-http/promise (v1.0.0) Loading from cache
- Installing psr/http-message (1.0.1) Loading from cache
- Installing php-http/httplug (v1.1.0) Loading from cache
- Installing guzzlehttp/psr7 (1.4.2) Loading from cache
- Installing mailgun/mailgun-php (v2.0) Loading from cache
- Installing openid/php-openid (2.3.0) Loading from cache
- Installing netbrain/highcharts-js (3.0.9) Loading from cache
- Installing sentry/sentry (0.12.1) Loading from cache
- Installing wikimedia/css-sanitizer (v1.0.2) Loading from cache
- Installing mustangostang/spyc (0.6.2) Loading from cache
- Installing mediawiki/universal-language-selector (2017.10) Loading from cache
- Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
- Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
- Installing stil/gd-text (v1.0.0) Downloading: 100%
- Installing monolog/monolog (1.22.1) Loading from cache
- Installing symfony/yaml (v2.8.32) Downloading: 100%
- Installing phpdocumentor/reflection-docblock (2.0.5) Downloading: 100%
- Installing symfony/polyfill-mbstring (v1.6.0) Loading from cache
- Installing wikimedia/textcat (1.2.0) Loading from cache
- Installing onoi/tesa (0.1.0) Loading from cache
- Installing onoi/callback-container (2.0.0) Loading from cache
- Installing onoi/event-dispatcher (1.0.0) Loading from cache
- Installing diff/diff (2.2.0) Downloading: 100%
- Installing data-values/data-values (1.1.1) Loading from cache
- Installing wikibase/data-model (7.3.0) Downloading: 100%
- Installing wikibase/data-model-services (3.8.0) Downloading: 100%
- Installing wikimedia/equivset (1.2.0) Downloading: 100%
- Installing tecnickcom/tcpdf (6.2.13) Downloading: 100%
- Installing spipu/html2pdf (v4.6.1) Downloading: 100%
- Installing elasticsearch/elasticsearch (5.3.0) Downloading: 100%
- Installing ruflin/elastica (5.3.0) Downloading: 100%
- Installing data-values/interfaces (0.2.5) Loading from cache
- Installing data-values/validators (0.1.2) Loading from cache
- Installing symfony/css-selector (v3.4.2) Loading from cache
- Installing onoi/shared-resources (0.4.3) Loading from cache
- Installing onoi/cache (1.2.0) Loading from cache
- Installing onoi/http-request (1.3.1) Loading from cache
- Installing onoi/blob-store (1.2.1) Loading from cache
- Installing onoi/message-reporter (1.3.0) Loading from cache
- Installing serialization/serialization (3.2.2) Loading from cache
- Installing data-values/common (0.4.1) Loading from cache
- Installing param-processor/param-processor (1.3.3) Loading from cache
- Installing mediawiki/parser-hooks (1.5.0) Loading from cache
- Installing mediawiki/validator (2.2.1) Downloading: 100%
- Installing mediawiki/semantic-media-wiki (2.5.x-dev 03828c6) Cloning 03828c61c1
- Installing mediawiki/semantic-extra-special-properties (1.5.0) Downloading: 100%
- Installing nicmart/tree (v0.2.7) Loading from cache
- Installing data-values/geo (2.1.1) Loading from cache
- Installing mediawiki/semantic-result-formats (2.5.4) Loading from cache
- Installing respect/validation (1.1.14) Downloading: 100%
- Installing composer/ca-bundle (1.1.0) Downloading: 100%
- Installing maxmind/web-service-common (v0.4.0) Downloading: 100%
- Installing maxmind-db/reader (v1.2.0) Downloading: 100%
- Installing geoip2/geoip2 (v2.7.0) Downloading: 100%
- Installing maxmind/minfraud (v1.5.0) Downloading: 100%
- Installing neitanod/forceutf8 (v2.0.1) Downloading: 100%
- Installing corneltek/getoptionkit (2.6.0) Downloading: 100%
- Installing amzn/login-and-pay-with-amazon-sdk-php (dev-master 198cc8c) Cloning 198cc8ccab
- Installing ircmaxell/password-compat (v1.0.4) Downloading: 100%
- Installing symfony/polyfill-php55 (v1.6.0) Downloading: 100%
- Installing symfony/polyfill-php54 (v1.6.0) Downloading: 100%
- Installing symfony/http-foundation (v2.8.32) Downloading: 100%
- Installing symfony/event-dispatcher (v2.8.32) Downloading: 100%
- Installing predis/predis (v1.1.1) Downloading: 100%
- Installing phpmailer/phpmailer (v5.2.26) Downloading: 100%
- Installing clio/clio (0.1.8) Downloading: 100%
- Installing coderkungfu/php-queue (1.0.0) Downloading: 100%
- Installing wikimedia/smash-pig (v0.5.1) Cloning 268799f492
- Installing twig/twig (v1.35.0) Downloading: 100%
- Installing jstayton/google-maps-geocoder (v2.4.0) Downloading: 100%
- Installing mediawiki/page-forms (4.2) Loading from cache
- Installing masterminds/html5 (2.3.0) Downloading: 100%
- Installing querypath/querypath (3.0.5) Downloading: 100%
- Installing justinrainbow/json-schema (5.2.6) Downloading: 100%
- Installing mediawiki/bootstrap (1.2.3) Loading from cache
- Installing mbostock/d3 (v3.5.17) Downloading: 100%
- Installing symfony/process (v2.8.32) Downloading: 100%
- Installing mediawiki/oauthclient (0.1.2) Downloading: 100%
- Installing werdnum/simple-lightncandy (0.5.0) Downloading: 100%
- Installing phpseclib/phpseclib (2.0.1) Downloading: 100%
- Installing jumbojett/openid-connect-php (dev-master 0d52339) Cloning 0d52339b01
- Installing neutron/sphinxsearch-api (2.0.8) Downloading: 100%
- Installing swiftmailer/swiftmailer (v5.2.2) Downloading: 100%
- Installing james-heinrich/getid3 (v1.9.15) Downloading: 100%
- Installing guzzlehttp/guzzle (v3.8.1) Downloading: 100%
- Installing data-values/number (0.9.1) Downloading: 100%
- Installing data-values/time (0.8.6) Downloading: 100%
- Installing data-values/serialization (1.2.2) Downloading: 100%
- Installing wikibase/data-model-serialization (2.6.0) Downloading: 100%
- Installing wikibase/internal-serialization (2.7.0) Downloading: 100%
- Installing net/http (1.1.0) Downloading: 100%
- Installing droidwiki/xenforo-bd-client (0.1.1) Downloading: 100%
Writing lock file
Generating optimized autoload files
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\anyType2anyTypeMap" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\entry" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Amount" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\ServiceException" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Error" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Type" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
> ComposerVendorHtaccessCreator::onEvent
> ComposerVendorHtaccessCreator::onEvent
$ # Then I re-added the extension Wikidata and removed the faulty dependency, re-ran composer and no more worked…
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- don't install mediawiki/semantic-media-wiki 2.5.x-dev|remove mediawiki/core dev-master
- Installation request for mediawiki/semantic-media-wiki 2.5.x-dev -> satisfiable by mediawiki/semantic-media-wiki[2.5.x-dev].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (septies) is caused by SemanticExpressiveness
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.4 -> satisfiable by mediawiki/semantic-media-wiki[2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (octies) is caused by BlueSpiceSMWConnector, SemanticImageAnnotator, and SemanticPageMaker
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.3 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (nonies) is caused by BlueSpiceSMWConnector, SemanticImageAnnotator, and SemanticPageMaker
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.3 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (decies) is caused by SemanticExtraSpecialProperties
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.3|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (undecies) is caused by SemanticFormsSelect
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.4|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (duodecies) is caused by SemanticNotifications and SemanticScribunto
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.5|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (terdecies) is caused by SemanticNotifications and SemanticScribunto
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.5|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (quaterdecies) is caused by SemanticNotifications and SemanticScribunto
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.
Problem 1
- don't install mediawiki/semantic-media-wiki 2.1.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.1.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.1.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.1.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.2.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.2.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.2.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.2.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
- don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
- mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
- Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
- Installation request for mediawiki/semantic-media-wiki ~2.1 -> satisfiable by mediawiki/semantic-media-wiki[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
> ComposerVendorHtaccessCreator::onEvent
$ # Problem 1 (quindecies) is caused by SemanticNotifications and SemanticScribunto
$ # I became tired to count in Latin hence I set minimum-stability = dev since it seems SMW (and others?) was installed in dev stability; <-- although I’m pretty sure I added minimum-stability = dev here, I do not understand why dev-master were downloaded earlier, the experiment should perhaps be re-checked
$ # ------------------------
$ composer update --no-dev
[MediaWiki core composer.json…]
> ComposerHookHandler::onPreUpdate
Loading composer repositories with package information
Updating dependencies
Package operations: 107 installs, 0 updates, 0 removals
- Installing composer/installers (dev-master 93af14c) Cloning 93af14c3ef
- Installing wikimedia/textcat (1.2.0) Loading from cache
- Installing firebase/php-jwt (v4.0.0) Loading from cache
- Installing psr/cache (dev-master 78c5a01) Cloning 78c5a01ddb
- Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Loading from cache
- Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
- Installing pimple/pimple (v3.0.2) Loading from cache
- Installing bordercloud/sparql (1.2.1) Loading from cache
- Installing php-http/discovery (v0.8.0) Loading from cache
- Installing psr/http-message (dev-master f6561bf) Cloning f6561bf28d
- Installing php-http/promise (dev-master 1cc44dc) Cloning 1cc44dc014
- Installing php-http/httplug (dev-master afa7b21) Cloning afa7b21632
- Installing guzzlehttp/psr7 (dev-master d2537c8) Cloning d2537c86fa
- Installing mailgun/mailgun-php (v2.0) Loading from cache
- Installing openid/php-openid (2.3.0) Loading from cache
- Installing netbrain/highcharts-js (3.0.9) Loading from cache
- Installing sentry/sentry (0.12.1) Loading from cache
- Installing wikimedia/css-sanitizer (v1.0.2) Loading from cache
- Installing mustangostang/spyc (0.6.2) Loading from cache
- Installing mediawiki/universal-language-selector (dev-master 36364f2) Cloning 36364f244d
- Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
- Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
- Installing mediawiki/article-placeholder (dev-master 57c6a29) Cloning 57c6a291b4
- Installing wikibase/wikimedia-badges (dev-master 52617c5) Cloning 52617c5723
- Installing stil/gd-text (v1.0.0) Loading from cache
- Installing symfony/yaml (2.8.x-dev 968ef42) Cloning 968ef42161
- Installing phpdocumentor/reflection-docblock (2.0.5) Loading from cache
- Installing symfony/polyfill-mbstring (dev-master 2ec8b39) Cloning 2ec8b39c38
- Installing mediawiki/semantic-forms (3.7) Loading from cache
- Installing wikimedia/equivset (1.2.0) Loading from cache
- Installing tecnickcom/tcpdf (6.2.13) Loading from cache
- Installing spipu/html2pdf (v4.6.1) Loading from cache
- Installing elasticsearch/elasticsearch (5.3.0) Loading from cache
- Installing ruflin/elastica (5.3.0) Loading from cache
- Installing data-values/interfaces (0.2.5) Loading from cache
- Installing data-values/data-values (1.1.1) Loading from cache
- Installing data-values/common (0.4.x-dev 7b11237) Cloning 7b11237246
- Installing data-values/validators (dev-master 6a5157b) Cloning 6a5157b16a
- Installing param-processor/param-processor (dev-master 22204d8) Cloning 22204d8436
- Installing symfony/css-selector (3.4.x-dev eac760b) Cloning eac760b414
- Installing onoi/callback-container (dev-master cf2f4dd) Cloning cf2f4dda1b
- Installing onoi/shared-resources (0.4.3) Loading from cache
- Installing onoi/tesa (0.1.0) Loading from cache
- Installing onoi/cache (dev-master c736c78) Cloning c736c78b1a
- Installing onoi/blob-store (dev-master c8d59d5) Cloning c8d59d580f
- Installing onoi/http-request (dev-master a7cf33b) Cloning a7cf33bae8
- Installing mediawiki/parser-hooks (dev-master 2336fef) Cloning 2336fef261
- Installing mediawiki/validator (dev-master 96beb6d) Cloning 96beb6d514
- Installing onoi/event-dispatcher (dev-master 2ab3958) Cloning 2ab3958a7c
- Installing onoi/message-reporter (dev-master 1e47351) Cloning 1e4735168d
- Installing serialization/serialization (3.2.2) Loading from cache
- Installing mediawiki/semantic-media-wiki (dev-master 333a0b7) Cloning 333a0b70dd
- Installing mediawiki/semantic-extra-special-properties (dev-master 298114d) Cloning 298114d442
- Installing nicmart/tree (v0.2.7) Loading from cache
- Installing data-values/geo (dev-master 4260aa1) Cloning 4260aa1551
- Installing mediawiki/semantic-result-formats (dev-master 04b9aab) Cloning 04b9aab08e
- Installing respect/validation (1.1.x-dev 22f1f14) Cloning 22f1f14430
- Installing composer/ca-bundle (dev-master 134242f) Cloning 134242fce6
- Installing maxmind/web-service-common (v0.4.0) Loading from cache
- Installing maxmind-db/reader (v1.2.0) Loading from cache
- Installing geoip2/geoip2 (v2.7.0) Loading from cache
- Installing maxmind/minfraud (v1.5.0) Loading from cache
- Installing neitanod/forceutf8 (v2.x-dev 47c883a) Cloning 47c883ab27
- Installing corneltek/getoptionkit (dev-master 9f21944) Cloning 9f219446ba
- Installing amzn/login-and-pay-with-amazon-sdk-php (dev-master 198cc8c) Cloning 198cc8ccab
- Installing ircmaxell/password-compat (1.0.x-dev 9b99377) Cloning 9b99377557
- Installing symfony/polyfill-php55 (dev-master b64e7f0) Cloning b64e7f0c37
- Installing symfony/polyfill-php54 (dev-master d7810a1) Cloning d7810a14b2
- Installing symfony/http-foundation (2.8.x-dev 138b0d6) Cloning 138b0d6f10
- Installing symfony/event-dispatcher (2.8.x-dev 45abf96) Cloning 45abf96cdc
- Installing predis/predis (v1.1.x-dev 111d100) Cloning 111d100ee3
- Installing phpmailer/phpmailer (v5.2.26) Loading from cache
- Installing clio/clio (0.1.8) Loading from cache
- Installing monolog/monolog (1.22.1) Loading from cache
- Installing coderkungfu/php-queue (dev-master a9baeb0) Cloning a9baeb0ae3
- Installing wikimedia/smash-pig (v0.5.1) Cloning 268799f492
- Installing twig/twig (1.x-dev b36e3eb) Cloning b36e3eb452
- Installing jstayton/google-maps-geocoder (v2.4.0) Loading from cache
- Installing mediawiki/page-forms (dev-master 538b2fe) Cloning 538b2fe4bd
- Installing masterminds/html5 (2.x-dev 441fb2b) Cloning 441fb2bc82
- Installing querypath/querypath (dev-master 82fcee6) Cloning 82fcee6e68
- Installing justinrainbow/json-schema (5.x-dev d283e11) Cloning d283e11b6e
- Installing mediawiki/bootstrap (dev-master cdb1d58) Cloning cdb1d58cee
- Installing mbostock/d3 (v3.5.17) Loading from cache
- Installing symfony/process (2.8.x-dev 6778bb0) Cloning 6778bb0851
- Installing mediawiki/oauthclient (0.1.2) Loading from cache
- Installing werdnum/simple-lightncandy (0.5.0) Loading from cache
- Installing phpseclib/phpseclib (2.0.1) Loading from cache
- Installing jumbojett/openid-connect-php (dev-master 0d52339) Cloning 0d52339b01
- Installing wikibase/data-model (7.x-dev 1c26274) Cloning 1c2627481b
- Installing diff/diff (2.x-dev f49b885) Cloning f49b8850a9
- Installing wikibase/data-model-services (dev-master 16bc1d2) Cloning 16bc1d2dec
- Installing neutron/sphinxsearch-api (dev-master a108fda) Cloning a108fda835
- Installing swiftmailer/swiftmailer (v5.2.2) Loading from cache
- Installing james-heinrich/getid3 (v1.9.15) Loading from cache
- Installing guzzlehttp/guzzle (v3.8.1) Loading from cache
- Installing data-values/time (dev-master acdda51) Cloning acdda5122e
- Installing data-values/serialization (dev-master 364f375) Cloning 364f375770
- Installing wikibase/data-model-serialization (dev-master c68907a) Cloning c68907a490
- Installing wikibase/internal-serialization (dev-master 47766c2) Cloning 47766c2e41
- Installing propertysuggester/property-suggester (dev-master 2433e61) Cloning 2433e61bfb
- Installing data-values/number (0.9.1) Loading from cache
- Installing wikibase/wikibase (dev-master ebb1f7d) Cloning ebb1f7d145
[RuntimeException]
Failed to execute git clone --no-checkout 'https://gerrit.wikimedia.org/r/mediawiki/extensions/Wikibase' 'extensions/Wikibase/' && cd 'extensions/Wikibase/' && git remote add composer 'https://gerrit.wik
imedia.org/r/mediawiki/extensions/Wikibase' && git fetch composer
fatal: destination path 'extensions/Wikibase' already exists and is not an empty directory.
update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
$ # Contrary to what is said in this error message, there were no "extensions/Wikibase" directory), then I abandonned here…