Paste P6481

Dependency hell between Composer librairies used in MediaWiki extensions and skins
ActivePublic

Authored by Seb35 on Dec 18 2017, 2:34 PM.
1$ # 854 extensions and 46 skins in master versions mostly from Gerrit and some from GitHub (up-to-date) in a MediaWiki master (up-to-date) as of today (2017-12-18), for a total of 784 composer.json (1 from MediaWiki, 740 from extensions, 43 from skins)
2$ # Added in root composer.json "extra": { "merge-plugin": { "include": [ "composer.local.json", "extensions/*/composer.json", "skins/*/composer.json" ], "merge-dev": false } }
3$ # No issue with the subset of the extensions/skins included by default in the tarball (it only installs composer/installers and symfony/process in addition of the MediaWiki’s default librairies)
4$ # ------------------------
5$ composer update --no-dev
6> ComposerHookHandler::onPreUpdate
7Loading composer repositories with package information
8Updating dependencies
9Package operations: 25 installs, 0 updates, 0 removals
10 - Installing wikimedia/composer-merge-plugin (v1.4.1) Loading from cache
11 - Installing composer/semver (1.4.2) Loading from cache
12 - Installing cssjanus/cssjanus (v1.2.0) Loading from cache
13 - Installing liuggio/statsd-php-client (v1.0.18) Loading from cache
14 - Installing mediawiki/at-ease (v1.1.0) Loading from cache
15 - Installing oojs/oojs-ui (v0.24.3) Loading from cache
16 - Installing oyejorge/less.php (v1.7.0.14) Loading from cache
17 - Installing wikimedia/assert (v0.2.2) Loading from cache
18 - Installing wikimedia/base-convert (v1.0.1) Loading from cache
19 - Installing wikimedia/cdb (1.4.1) Loading from cache
20 - Installing wikimedia/cldr-plural-rule-parser (v1.0.0) Loading from cache
21 - Installing wikimedia/html-formatter (1.0.1) Loading from cache
22 - Installing wikimedia/ip-set (1.1.0) Loading from cache
23 - Installing psr/log (1.0.2) Loading from cache
24 - Installing wikimedia/php-session-serializer (v1.0.4) Loading from cache
25 - Installing wikimedia/purtle (v1.0.6) Loading from cache
26 - Installing wikimedia/relpath (2.0.0) Loading from cache
27 - Installing wikimedia/utfnormal (v1.1.0) Loading from cache
28 - Installing wikimedia/remex-html (1.0.1) Loading from cache
29 - Installing wikimedia/running-stat (v1.1.0) Loading from cache
30 - Installing wikimedia/scoped-callback (v1.0.0) Loading from cache
31 - Installing wikimedia/timestamp (v1.0.0) Loading from cache
32 - Installing wikimedia/wait-condition-loop (v1.0.1) Loading from cache
33 - Installing wikimedia/wrappedstring (v2.2.0) Loading from cache
34 - Installing zordius/lightncandy (v0.23) Loading from cache
35Writing lock file
36Generating optimized autoload files
37> ComposerHookHandler::onPreUpdate
38Loading composer repositories with package information
39Updating dependencies
40Your requirements could not be resolved to an installable set of packages.
41
42 Problem 1
43 - The requested package oojs/oojs-ui 0.4.* is satisfiable by oojs/oojs-ui[v0.4.0] but these conflict with your requirements or minimum-stability.
44 Problem 2
45 - The requested package pimple/pimple ~2.1 is satisfiable by pimple/pimple[v2.1.0, v2.1.1] but these conflict with your requirements or minimum-stability.
46 Problem 3
47 - The requested package symfony/process ~3.3 is satisfiable by symfony/process[3.3.x-dev, 3.4.x-dev, v3.3.0, v3.3.0-BETA1, v3.3.0-RC1, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.14, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9, v3.4.0, v3.4.0-BETA1, v3.4.0-BETA2, v3.4.0-BETA3, v3.4.0-BETA4, v3.4.0-RC1, v3.4.0-RC2, v3.4.1, v3.4.2] but these conflict with your requirements or minimum-stability.
48 Problem 4
49 - The requested package param-processor/param-processor ~1.0.0 is satisfiable by param-processor/param-processor[1.0, 1.0.1, 1.0.2] but these conflict with your requirements or minimum-stability.
50 Problem 5
51 - Installation request for sami/sami ~2.0 -> satisfiable by sami/sami[v2.0.0].
52 - sami/sami v2.0.0 requires pimple/pimple 2.* -> satisfiable by pimple/pimple[v2.0.0, v2.1.0, v2.1.1] but these conflict with your requirements or minimum-stability.
53 Problem 6
54 - Installation request for param-processor/param-processor 1.2.2 -> satisfiable by param-processor/param-processor[1.2.2].
55 - param-processor/param-processor 1.2.2 requires data-values/interfaces ~0.1.4 -> satisfiable by data-values/interfaces[0.1.4, 0.1.5] but these conflict with your requirements or minimum-stability.
56 Problem 7
57 - Installation request for ext-geoip 1.1.1 -> satisfiable by ext-geoip[1.1.1].
58 - geoip/geoip v1.17 conflicts with ext-geoip[1.1.1].
59 - Installation request for geoip/geoip 1.17 -> satisfiable by geoip/geoip[v1.17].
60
61 To enable extensions, verify that they are enabled in your .ini files:
62 - /etc/php/7.0/cli/php.ini
63 - /etc/php/7.0/cli/conf.d/10-mysqlnd.ini
64 - /etc/php/7.0/cli/conf.d/10-opcache.ini
65 - /etc/php/7.0/cli/conf.d/10-pdo.ini
66 - /etc/php/7.0/cli/conf.d/15-xml.ini
67 - /etc/php/7.0/cli/conf.d/20-apcu.ini
68 - /etc/php/7.0/cli/conf.d/20-bz2.ini
69 - /etc/php/7.0/cli/conf.d/20-calendar.ini
70 - /etc/php/7.0/cli/conf.d/20-ctype.ini
71 - /etc/php/7.0/cli/conf.d/20-curl.ini
72 - /etc/php/7.0/cli/conf.d/20-dom.ini
73 - /etc/php/7.0/cli/conf.d/20-exif.ini
74 - /etc/php/7.0/cli/conf.d/20-fileinfo.ini
75 - /etc/php/7.0/cli/conf.d/20-ftp.ini
76 - /etc/php/7.0/cli/conf.d/20-gd.ini
77 - /etc/php/7.0/cli/conf.d/20-geoip.ini
78 - /etc/php/7.0/cli/conf.d/20-gettext.ini
79 - /etc/php/7.0/cli/conf.d/20-gmp.ini
80 - /etc/php/7.0/cli/conf.d/20-iconv.ini
81 - /etc/php/7.0/cli/conf.d/20-igbinary.ini
82 - /etc/php/7.0/cli/conf.d/20-intl.ini
83 - /etc/php/7.0/cli/conf.d/20-json.ini
84 - /etc/php/7.0/cli/conf.d/20-mbstring.ini
85 - /etc/php/7.0/cli/conf.d/20-msgpack.ini
86 - /etc/php/7.0/cli/conf.d/20-mysqli.ini
87 - /etc/php/7.0/cli/conf.d/20-pdo_mysql.ini
88 - /etc/php/7.0/cli/conf.d/20-pdo_sqlite.ini
89 - /etc/php/7.0/cli/conf.d/20-phar.ini
90 - /etc/php/7.0/cli/conf.d/20-posix.ini
91 - /etc/php/7.0/cli/conf.d/20-readline.ini
92 - /etc/php/7.0/cli/conf.d/20-shmop.ini
93 - /etc/php/7.0/cli/conf.d/20-simplexml.ini
94 - /etc/php/7.0/cli/conf.d/20-sockets.ini
95 - /etc/php/7.0/cli/conf.d/20-sqlite3.ini
96 - /etc/php/7.0/cli/conf.d/20-sysvmsg.ini
97 - /etc/php/7.0/cli/conf.d/20-sysvsem.ini
98 - /etc/php/7.0/cli/conf.d/20-sysvshm.ini
99 - /etc/php/7.0/cli/conf.d/20-tideways.ini
100 - /etc/php/7.0/cli/conf.d/20-tidy.ini
101 - /etc/php/7.0/cli/conf.d/20-tokenizer.ini
102 - /etc/php/7.0/cli/conf.d/20-wddx.ini
103 - /etc/php/7.0/cli/conf.d/20-xdebug.ini
104 - /etc/php/7.0/cli/conf.d/20-xmlreader.ini
105 - /etc/php/7.0/cli/conf.d/20-xmlwriter.ini
106 - /etc/php/7.0/cli/conf.d/20-xsl.ini
107 - /etc/php/7.0/cli/conf.d/25-memcached.ini
108 You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.
109> ComposerVendorHtaccessCreator::onEvent
110$ # Problem 7 (semel) is caused by SecureSessions
111$ # Problems 1, 2, 5 (semel) are caused by OOUIPlayground
112$ # Problem 3 (semel) is caused by SyntaxHighlight_GeSHi - a patch is proposed by Legoktm, see T181771
113$ # Problem 4 (semel) is caused by skin Material
114$ # Problem 6 (semel) is caused by SideBarMenu
115$ # ------------------------
116$ # When these dependencies are removed (which is not a solution, except to check dependency hells), the four following executions of composer update --no-dev show the four following issues:
117$ composer update --no-dev
118[MediaWiki core composer.json…]
119> ComposerHookHandler::onPreUpdate
120Loading composer repositories with package information
121Updating dependencies
122Your requirements could not be resolved to an installable set of packages.
123
124 Problem 1
125 - wikimedia/gpglib 0.2.1 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0] but these conflict with your requirements or minimum-stability.
126 - wikimedia/gpglib 0.2.0 requires psr/log 1.0.0 -> satisfiable by psr/log[1.0.0] but these conflict with your requirements or minimum-stability.
127 - Installation request for wikimedia/gpglib 0.2.* -> satisfiable by wikimedia/gpglib[0.2.0, 0.2.1].
128
129> ComposerVendorHtaccessCreator::onEvent
130$ # Problem 1 (bis) is caused by GPGMail - this was fixed by bd808 in https://github.com/wikimedia/php-gpglib/pull/5 and is only awaiting a new stable version of wikimedia/gpglib
131$ # ------------------------
132$ composer update --no-dev
133[MediaWiki core composer.json…]
134> ComposerHookHandler::onPreUpdate
135Loading composer repositories with package information
136Updating dependencies
137Your requirements could not be resolved to an installable set of packages.
138
139 Problem 1
140 - google/apiclient v2.2.1 requires guzzlehttp/guzzle ~5.3.1|~6.0 -> satisfiable by guzzlehttp/guzzle[5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
141 - google/apiclient v2.2.0 requires guzzlehttp/guzzle ~5.3.1|~6.0 -> satisfiable by guzzlehttp/guzzle[5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
142 - google/apiclient v2.1.3 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
143 - google/apiclient v2.1.2 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
144 - google/apiclient v2.1.1 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
145 - google/apiclient v2.1.0 requires guzzlehttp/guzzle ~5.2|~6.0 -> satisfiable by guzzlehttp/guzzle[5.2.0, 5.3.0, 5.3.1, 5.3.x-dev, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
146 - google/apiclient v2.0.3 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
147 - google/apiclient v2.0.2 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
148 - google/apiclient v2.0.1 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
149 - google/apiclient v2.0.0-RC8 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
150 - google/apiclient v2.0.0-RC7 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
151 - google/apiclient v2.0.0-RC6 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
152 - google/apiclient v2.0.0-RC5 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
153 - google/apiclient v2.0.0-RC4 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
154 - google/apiclient v2.0.0-RC3 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
155 - google/apiclient v2.0.0-RC2 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
156 - google/apiclient v2.0.0-RC1 requires guzzlehttp/guzzle 5.2.* -> satisfiable by guzzlehttp/guzzle[5.2.0] but these conflict with your requirements or minimum-stability.
157 - google/apiclient v2.0.0 requires firebase/php-jwt ~2.0|~3.0 -> satisfiable by firebase/php-jwt[2.0.0, v2.1.0, v2.2.0, v3.0.0] but these conflict with your requirements or minimum-stability.
158 - Installation request for google/apiclient ^2.0.0@RC -> satisfiable by google/apiclient[v2.0.0, v2.0.0-RC1, v2.0.0-RC2, v2.0.0-RC3, v2.0.0-RC4, v2.0.0-RC5, v2.0.0-RC6, v2.0.0-RC7, v2.0.0-RC8, v2.0.1, v2.0.2, v2.0.3, v2.1.0, v2.1.1, v2.1.2, v2.1.3, v2.2.0, v2.2.1].
159
160> ComposerVendorHtaccessCreator::onEvent
161$ # Problem 1 (ter) is caused by GoogleAnalyticsTopPages and GoogleLogin
162$ # ------------------------
163$ composer update --no-dev
164[MediaWiki core composer.json…]
165> ComposerHookHandler::onPreUpdate
166Loading composer repositories with package information
167Updating dependencies
168Your requirements could not be resolved to an installable set of packages.
169
170 Problem 1
171 - microsoft/windowsazure v0.5.7 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
172 - microsoft/windowsazure v0.5.6 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
173 - microsoft/windowsazure v0.5.5 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
174 - microsoft/windowsazure v0.5.4 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
175 - microsoft/windowsazure v0.5.3 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
176 - microsoft/windowsazure v0.5.2 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
177 - microsoft/windowsazure v0.5.1 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
178 - microsoft/windowsazure v0.5.0 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
179 - microsoft/windowsazure v0.4.4 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
180 - microsoft/azure-storage v0.10.2 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
181 - microsoft/azure-storage v0.10.1 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
182 - microsoft/azure-storage v0.10.0 requires guzzlehttp/guzzle ~6.0 -> satisfiable by guzzlehttp/guzzle[6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.3.0, 6.2.x-dev] but these conflict with your requirements or minimum-stability.
183 - microsoft/windowsazure v0.4.3 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
184 - microsoft/windowsazure v0.4.2 requires firebase/php-jwt ^3.0 -> satisfiable by firebase/php-jwt[v3.0.0] but these conflict with your requirements or minimum-stability.
185 - microsoft/windowsazure v0.4.1 requires pear-pear2.php.net/http_request2 * -> no matching package found.
186 - microsoft/windowsazure v0.4.0 requires pear-pear/http_request2 * -> no matching package found.
187 - microsoft/windowsazure v0.4.5 requires microsoft/azure-storage ^0.10 -> satisfiable by microsoft/azure-storage[v0.10.0, v0.10.1, v0.10.2].
188 - Installation request for microsoft/windowsazure * -> satisfiable by microsoft/windowsazure[v0.4.0, v0.4.1, v0.4.2, v0.4.3, v0.4.4, v0.4.5, v0.5.0, v0.5.1, v0.5.2, v0.5.3, v0.5.4, v0.5.5, v0.5.6, v0.5.7].
189
190Potential causes:
191 - A typo in the package name
192 - The package is not available in a stable-enough version according to your minimum-stability setting
193 see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
194
195Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
196> ComposerVendorHtaccessCreator::onEvent
197$ # Problem 1 (quater) is caused by WindowsAzureStorage
198$ # ------------------------
199$ composer update --no-dev
200[MediaWiki core composer.json…]
201> ComposerHookHandler::onPreUpdate
202Loading composer repositories with package information
203Updating dependencies
204
205
206 [Composer\DependencyResolver\SolverProblemsException]
207 Problem 1
208 - The requested package monolog/monolog ~1.18.2 exists as monolog/monolog[1.22.1] but these are rejected by your constraint.
209
210
211update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
212$ # Problem 1 (quinquies) is caused by DonationInterface
213$ # ------------------------
214$ composer update --no-dev
215[MediaWiki core composer.json…]
216> ComposerHookHandler::onPreUpdate
217Loading composer repositories with package information
218Updating dependencies
219Package operations: 108 installs, 0 updates, 0 removals
220 - Installing composer/installers (v1.4.0) Loading from cache
221 - Installing mediawiki/semantic-forms (3.7) Downloading: 100%
222 - Installing firebase/php-jwt (v4.0.0) Downloading: 100%
223 - Installing psr/cache (1.0.1) Downloading: 100%
224 - Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Downloading: 100%
225 - Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
226 - Installing pimple/pimple (v3.0.2) Downloading: 100%
227 - Installing bordercloud/sparql (1.2.1) Downloading: 100%
228 - Installing php-http/discovery (v0.8.0) Downloading: 100%
229 - Installing php-http/promise (v1.0.0) Downloading: 100%
230 - Installing psr/http-message (1.0.1) Downloading: 100%
231 - Installing php-http/httplug (v1.1.0) Downloading: 100%
232 - Installing guzzlehttp/psr7 (1.4.2) Downloading: 100%
233 - Installing mailgun/mailgun-php (v2.0) Downloading: 100%
234 - Installing openid/php-openid (2.3.0) Downloading: 100%
235 - Installing netbrain/highcharts-js (3.0.9) Downloading: 100%
236 - Installing sentry/sentry (0.12.1) Downloading: 100%
237 - Installing wikimedia/css-sanitizer (v1.0.2) Downloading: 100%
238 - Installing mustangostang/spyc (0.6.2) Downloading: 100%
239 - Installing mediawiki/universal-language-selector (2017.10) Downloading: 100%
240 - Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
241 - Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
242 - Installing mediawiki/article-placeholder (dev-master 57c6a29) Cloning 57c6a291b4
243 - Installing wikibase/wikimedia-badges (dev-master 52617c5) Cloning 52617c5723
244 - Installing wikibase/wikidata.org (dev-master 812681b) Cloning 812681b863
245
246
247 [RuntimeException]
248 Failed to execute git clone --no-checkout 'https://gerrit.wikimedia.org/r/mediawiki/extensions/Wikidata.org' 'extensions/Wikidata.org/' && cd 'extensions/Wikidata.org/' && git remote add composer 'https:
249 //gerrit.wikimedia.org/r/mediawiki/extensions/Wikidata.org' && git fetch composer
250 fatal: destination path 'extensions/Wikidata.org' already exists and is not an empty directory.
251
252
253update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
254$ # Problem 1 (sexies) is caused by Wikidata extension -> the extension Wikidata.org is unusually named (with a point and an uppercase letter), not sure how composer/installers reacts (contrary to what is said in this error message, there were no "extensions/Wikidata.org" directory), I first removed entirely the extension Wikidata, re-ran composer, IT WORKED! and installed 101 libraries
255$ # UPDATE [after initial post]: This issue and the very last issue of this paste are linked to the Wikidata extension where there are "sub-extensions" (whose Wikidata.org and Wikibase), which is unusual from the point of view of the root composer.json.
256$ # ------------------------
257$ composer update --no-dev
258[MediaWiki core composer.json…]
259> ComposerHookHandler::onPreUpdate
260Loading composer repositories with package information
261Updating dependencies
262Package operations: 101 installs, 0 updates, 0 removals
263 - Installing composer/installers (v1.4.0) Loading from cache
264 - Installing mediawiki/semantic-forms (3.7) Loading from cache
265 - Installing firebase/php-jwt (v4.0.0) Loading from cache
266 - Installing psr/cache (1.0.1) Loading from cache
267 - Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Loading from cache
268 - Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
269 - Installing pimple/pimple (v3.0.2) Loading from cache
270 - Installing bordercloud/sparql (1.2.1) Loading from cache
271 - Installing php-http/discovery (v0.8.0) Loading from cache
272 - Installing php-http/promise (v1.0.0) Loading from cache
273 - Installing psr/http-message (1.0.1) Loading from cache
274 - Installing php-http/httplug (v1.1.0) Loading from cache
275 - Installing guzzlehttp/psr7 (1.4.2) Loading from cache
276 - Installing mailgun/mailgun-php (v2.0) Loading from cache
277 - Installing openid/php-openid (2.3.0) Loading from cache
278 - Installing netbrain/highcharts-js (3.0.9) Loading from cache
279 - Installing sentry/sentry (0.12.1) Loading from cache
280 - Installing wikimedia/css-sanitizer (v1.0.2) Loading from cache
281 - Installing mustangostang/spyc (0.6.2) Loading from cache
282 - Installing mediawiki/universal-language-selector (2017.10) Loading from cache
283 - Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
284 - Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
285 - Installing stil/gd-text (v1.0.0) Downloading: 100%
286 - Installing monolog/monolog (1.22.1) Loading from cache
287 - Installing symfony/yaml (v2.8.32) Downloading: 100%
288 - Installing phpdocumentor/reflection-docblock (2.0.5) Downloading: 100%
289 - Installing symfony/polyfill-mbstring (v1.6.0) Loading from cache
290 - Installing wikimedia/textcat (1.2.0) Loading from cache
291 - Installing onoi/tesa (0.1.0) Loading from cache
292 - Installing onoi/callback-container (2.0.0) Loading from cache
293 - Installing onoi/event-dispatcher (1.0.0) Loading from cache
294 - Installing diff/diff (2.2.0) Downloading: 100%
295 - Installing data-values/data-values (1.1.1) Loading from cache
296 - Installing wikibase/data-model (7.3.0) Downloading: 100%
297 - Installing wikibase/data-model-services (3.8.0) Downloading: 100%
298 - Installing wikimedia/equivset (1.2.0) Downloading: 100%
299 - Installing tecnickcom/tcpdf (6.2.13) Downloading: 100%
300 - Installing spipu/html2pdf (v4.6.1) Downloading: 100%
301 - Installing elasticsearch/elasticsearch (5.3.0) Downloading: 100%
302 - Installing ruflin/elastica (5.3.0) Downloading: 100%
303 - Installing data-values/interfaces (0.2.5) Loading from cache
304 - Installing data-values/validators (0.1.2) Loading from cache
305 - Installing symfony/css-selector (v3.4.2) Loading from cache
306 - Installing onoi/shared-resources (0.4.3) Loading from cache
307 - Installing onoi/cache (1.2.0) Loading from cache
308 - Installing onoi/http-request (1.3.1) Loading from cache
309 - Installing onoi/blob-store (1.2.1) Loading from cache
310 - Installing onoi/message-reporter (1.3.0) Loading from cache
311 - Installing serialization/serialization (3.2.2) Loading from cache
312 - Installing data-values/common (0.4.1) Loading from cache
313 - Installing param-processor/param-processor (1.3.3) Loading from cache
314 - Installing mediawiki/parser-hooks (1.5.0) Loading from cache
315 - Installing mediawiki/validator (2.2.1) Downloading: 100%
316 - Installing mediawiki/semantic-media-wiki (2.5.x-dev 03828c6) Cloning 03828c61c1
317 - Installing mediawiki/semantic-extra-special-properties (1.5.0) Downloading: 100%
318 - Installing nicmart/tree (v0.2.7) Loading from cache
319 - Installing data-values/geo (2.1.1) Loading from cache
320 - Installing mediawiki/semantic-result-formats (2.5.4) Loading from cache
321 - Installing respect/validation (1.1.14) Downloading: 100%
322 - Installing composer/ca-bundle (1.1.0) Downloading: 100%
323 - Installing maxmind/web-service-common (v0.4.0) Downloading: 100%
324 - Installing maxmind-db/reader (v1.2.0) Downloading: 100%
325 - Installing geoip2/geoip2 (v2.7.0) Downloading: 100%
326 - Installing maxmind/minfraud (v1.5.0) Downloading: 100%
327 - Installing neitanod/forceutf8 (v2.0.1) Downloading: 100%
328 - Installing corneltek/getoptionkit (2.6.0) Downloading: 100%
329 - Installing amzn/login-and-pay-with-amazon-sdk-php (dev-master 198cc8c) Cloning 198cc8ccab
330 - Installing ircmaxell/password-compat (v1.0.4) Downloading: 100%
331 - Installing symfony/polyfill-php55 (v1.6.0) Downloading: 100%
332 - Installing symfony/polyfill-php54 (v1.6.0) Downloading: 100%
333 - Installing symfony/http-foundation (v2.8.32) Downloading: 100%
334 - Installing symfony/event-dispatcher (v2.8.32) Downloading: 100%
335 - Installing predis/predis (v1.1.1) Downloading: 100%
336 - Installing phpmailer/phpmailer (v5.2.26) Downloading: 100%
337 - Installing clio/clio (0.1.8) Downloading: 100%
338 - Installing coderkungfu/php-queue (1.0.0) Downloading: 100%
339 - Installing wikimedia/smash-pig (v0.5.1) Cloning 268799f492
340 - Installing twig/twig (v1.35.0) Downloading: 100%
341 - Installing jstayton/google-maps-geocoder (v2.4.0) Downloading: 100%
342 - Installing mediawiki/page-forms (4.2) Loading from cache
343 - Installing masterminds/html5 (2.3.0) Downloading: 100%
344 - Installing querypath/querypath (3.0.5) Downloading: 100%
345 - Installing justinrainbow/json-schema (5.2.6) Downloading: 100%
346 - Installing mediawiki/bootstrap (1.2.3) Loading from cache
347 - Installing mbostock/d3 (v3.5.17) Downloading: 100%
348 - Installing symfony/process (v2.8.32) Downloading: 100%
349 - Installing mediawiki/oauthclient (0.1.2) Downloading: 100%
350 - Installing werdnum/simple-lightncandy (0.5.0) Downloading: 100%
351 - Installing phpseclib/phpseclib (2.0.1) Downloading: 100%
352 - Installing jumbojett/openid-connect-php (dev-master 0d52339) Cloning 0d52339b01
353 - Installing neutron/sphinxsearch-api (2.0.8) Downloading: 100%
354 - Installing swiftmailer/swiftmailer (v5.2.2) Downloading: 100%
355 - Installing james-heinrich/getid3 (v1.9.15) Downloading: 100%
356 - Installing guzzlehttp/guzzle (v3.8.1) Downloading: 100%
357 - Installing data-values/number (0.9.1) Downloading: 100%
358 - Installing data-values/time (0.8.6) Downloading: 100%
359 - Installing data-values/serialization (1.2.2) Downloading: 100%
360 - Installing wikibase/data-model-serialization (2.6.0) Downloading: 100%
361 - Installing wikibase/internal-serialization (2.7.0) Downloading: 100%
362 - Installing net/http (1.1.0) Downloading: 100%
363 - Installing droidwiki/xenforo-bd-client (0.1.1) Downloading: 100%
364Writing lock file
365Generating optimized autoload files
366Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\anyType2anyTypeMap" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
367Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\entry" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
368Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Amount" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
369Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\ServiceException" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
370Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Error" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
371Warning: Ambiguous class resolution, "SmashPig\PaymentProviders\Adyen\WSDL\Type" was found in both "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Payment.php" and "/mediawiki/master/vendor/wikimedia/smash-pig/PaymentProviders/Adyen/WSDL/Notification.php", the first will be used.
372> ComposerVendorHtaccessCreator::onEvent
373> ComposerVendorHtaccessCreator::onEvent
374$ # Then I re-added the extension Wikidata and removed the faulty dependency, re-ran composer and no more worked…
375$ # ------------------------
376$ composer update --no-dev
377[MediaWiki core composer.json…]
378> ComposerHookHandler::onPreUpdate
379Loading composer repositories with package information
380Updating dependencies
381Your requirements could not be resolved to an installable set of packages.
382
383 Problem 1
384 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
385 - don't install mediawiki/semantic-media-wiki 2.5.x-dev|remove mediawiki/core dev-master
386 - Installation request for mediawiki/semantic-media-wiki 2.5.x-dev -> satisfiable by mediawiki/semantic-media-wiki[2.5.x-dev].
387
388> ComposerVendorHtaccessCreator::onEvent
389$ # Problem 1 (septies) is caused by SemanticExpressiveness
390$ # ------------------------
391$ composer update --no-dev
392[MediaWiki core composer.json…]
393> ComposerHookHandler::onPreUpdate
394Loading composer repositories with package information
395Updating dependencies
396Your requirements could not be resolved to an installable set of packages.
397
398 Problem 1
399 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
400 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
401 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
402 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
403 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
404 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
405 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
406 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
407 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
408 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
409 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
410 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
411 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
412 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
413 - Installation request for mediawiki/semantic-media-wiki ~2.4 -> satisfiable by mediawiki/semantic-media-wiki[2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
414
415> ComposerVendorHtaccessCreator::onEvent
416$ # Problem 1 (octies) is caused by BlueSpiceSMWConnector, SemanticImageAnnotator, and SemanticPageMaker
417$ # ------------------------
418$ composer update --no-dev
419[MediaWiki core composer.json…]
420> ComposerHookHandler::onPreUpdate
421Loading composer repositories with package information
422Updating dependencies
423Your requirements could not be resolved to an installable set of packages.
424
425 Problem 1
426 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
427 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
428 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
429 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
430 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
431 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
432 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
433 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
434 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
435 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
436 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
437 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
438 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
439 - mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
440 - mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
441 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
442 - Installation request for mediawiki/semantic-media-wiki ~2.3 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
443
444> ComposerVendorHtaccessCreator::onEvent
445$ # Problem 1 (nonies) is caused by BlueSpiceSMWConnector, SemanticImageAnnotator, and SemanticPageMaker
446$ # ------------------------
447$ composer update --no-dev
448[MediaWiki core composer.json…]
449> ComposerHookHandler::onPreUpdate
450Loading composer repositories with package information
451Updating dependencies
452Your requirements could not be resolved to an installable set of packages.
453
454 Problem 1
455 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
456 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
457 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
458 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
459 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
460 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
461 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
462 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
463 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
464 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
465 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
466 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
467 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
468 - mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
469 - mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
470 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
471 - Installation request for mediawiki/semantic-media-wiki ~2.3 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
472
473> ComposerVendorHtaccessCreator::onEvent
474$ # Problem 1 (decies) is caused by SemanticExtraSpecialProperties
475$ # ------------------------
476$ composer update --no-dev
477[MediaWiki core composer.json…]
478> ComposerHookHandler::onPreUpdate
479Loading composer repositories with package information
480Updating dependencies
481Your requirements could not be resolved to an installable set of packages.
482
483 Problem 1
484 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
485 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
486 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
487 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
488 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
489 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
490 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
491 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
492 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
493 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
494 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
495 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
496 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
497 - mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
498 - mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
499 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
500 - Installation request for mediawiki/semantic-media-wiki ~2.3|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
501
502> ComposerVendorHtaccessCreator::onEvent
503$ # Problem 1 (undecies) is caused by SemanticFormsSelect
504$ # ------------------------
505$ composer update --no-dev
506[MediaWiki core composer.json…]
507> ComposerHookHandler::onPreUpdate
508Loading composer repositories with package information
509Updating dependencies
510Your requirements could not be resolved to an installable set of packages.
511
512 Problem 1
513 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
514 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
515 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
516 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
517 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
518 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
519 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
520 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
521 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
522 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
523 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
524 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
525 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
526 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
527 - Installation request for mediawiki/semantic-media-wiki ~2.4|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
528
529> ComposerVendorHtaccessCreator::onEvent
530$ # Problem 1 (duodecies) is caused by SemanticNotifications and SemanticScribunto
531$ # ------------------------
532$ composer update --no-dev
533[MediaWiki core composer.json…]
534> ComposerHookHandler::onPreUpdate
535Loading composer repositories with package information
536Updating dependencies
537Your requirements could not be resolved to an installable set of packages.
538
539 Problem 1
540 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
541 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
542 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
543 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
544 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
545 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
546 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
547 - Installation request for mediawiki/semantic-media-wiki ~2.5|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
548
549> ComposerVendorHtaccessCreator::onEvent
550$ # Problem 1 (terdecies) is caused by SemanticNotifications and SemanticScribunto
551$ # ------------------------
552$ composer update --no-dev
553[MediaWiki core composer.json…]
554> ComposerHookHandler::onPreUpdate
555Loading composer repositories with package information
556Updating dependencies
557Your requirements could not be resolved to an installable set of packages.
558
559 Problem 1
560 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
561 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
562 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
563 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
564 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
565 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
566 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
567 - Installation request for mediawiki/semantic-media-wiki ~2.5|~3.0 -> satisfiable by mediawiki/semantic-media-wiki[2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
568
569> ComposerVendorHtaccessCreator::onEvent
570$ # Problem 1 (quaterdecies) is caused by SemanticNotifications and SemanticScribunto
571$ # ------------------------
572$ composer update --no-dev
573[MediaWiki core composer.json…]
574> ComposerHookHandler::onPreUpdate
575Loading composer repositories with package information
576Updating dependencies
577Your requirements could not be resolved to an installable set of packages.
578
579 Problem 1
580 - don't install mediawiki/semantic-media-wiki 2.1.0|remove mediawiki/core dev-master
581 - don't install mediawiki/semantic-media-wiki 2.1.1|remove mediawiki/core dev-master
582 - don't install mediawiki/semantic-media-wiki 2.1.2|remove mediawiki/core dev-master
583 - don't install mediawiki/semantic-media-wiki 2.1.3|remove mediawiki/core dev-master
584 - don't install mediawiki/semantic-media-wiki 2.2.0|remove mediawiki/core dev-master
585 - don't install mediawiki/semantic-media-wiki 2.2.1|remove mediawiki/core dev-master
586 - don't install mediawiki/semantic-media-wiki 2.2.2|remove mediawiki/core dev-master
587 - don't install mediawiki/semantic-media-wiki 2.2.3|remove mediawiki/core dev-master
588 - don't install mediawiki/semantic-media-wiki 2.5.0|remove mediawiki/core dev-master
589 - don't install mediawiki/semantic-media-wiki 2.5.1|remove mediawiki/core dev-master
590 - don't install mediawiki/semantic-media-wiki 2.5.2|remove mediawiki/core dev-master
591 - don't install mediawiki/semantic-media-wiki 2.5.3|remove mediawiki/core dev-master
592 - don't install mediawiki/semantic-media-wiki 2.5.4|remove mediawiki/core dev-master
593 - don't install mediawiki/semantic-media-wiki 2.5.5|remove mediawiki/core dev-master
594 - mediawiki/semantic-media-wiki 2.4.6 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
595 - mediawiki/semantic-media-wiki 2.4.5 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
596 - mediawiki/semantic-media-wiki 2.4.4 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
597 - mediawiki/semantic-media-wiki 2.4.3 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
598 - mediawiki/semantic-media-wiki 2.4.2 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
599 - mediawiki/semantic-media-wiki 2.4.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
600 - mediawiki/semantic-media-wiki 2.4.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
601 - mediawiki/semantic-media-wiki 2.3.1 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
602 - mediawiki/semantic-media-wiki 2.3.0 requires onoi/callback-container ~1.0 -> satisfiable by onoi/callback-container[1.0.0, 1.1.0] but these conflict with your requirements or minimum-stability.
603 - Installation request for mediawiki/core dev-master -> satisfiable by mediawiki/core[dev-master].
604 - Installation request for mediawiki/semantic-media-wiki ~2.1 -> satisfiable by mediawiki/semantic-media-wiki[2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5, 2.4.6, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.5.4, 2.5.5].
605
606> ComposerVendorHtaccessCreator::onEvent
607$ # Problem 1 (quindecies) is caused by SemanticNotifications and SemanticScribunto
608$ # I became tired to count in Latin hence I set minimum-stability = dev since it seems SMW (and others?) was installed in dev stability; <-- although I’m pretty sure I added minimum-stability = dev here, I do not understand why dev-master were downloaded earlier, the experiment should perhaps be re-checked
609$ # ------------------------
610$ composer update --no-dev
611[MediaWiki core composer.json…]
612> ComposerHookHandler::onPreUpdate
613Loading composer repositories with package information
614Updating dependencies
615Package operations: 107 installs, 0 updates, 0 removals
616 - Installing composer/installers (dev-master 93af14c) Cloning 93af14c3ef
617 - Installing wikimedia/textcat (1.2.0) Loading from cache
618 - Installing firebase/php-jwt (v4.0.0) Loading from cache
619 - Installing psr/cache (dev-master 78c5a01) Cloning 78c5a01ddb
620 - Installing addshore/psr-6-mediawiki-bagostuff-adapter (0.1) Loading from cache
621 - Installing dan-coulter/phpflickr (dev-master bc4f209) Cloning bc4f2092b1
622 - Installing pimple/pimple (v3.0.2) Loading from cache
623 - Installing bordercloud/sparql (1.2.1) Loading from cache
624 - Installing php-http/discovery (v0.8.0) Loading from cache
625 - Installing psr/http-message (dev-master f6561bf) Cloning f6561bf28d
626 - Installing php-http/promise (dev-master 1cc44dc) Cloning 1cc44dc014
627 - Installing php-http/httplug (dev-master afa7b21) Cloning afa7b21632
628 - Installing guzzlehttp/psr7 (dev-master d2537c8) Cloning d2537c86fa
629 - Installing mailgun/mailgun-php (v2.0) Loading from cache
630 - Installing openid/php-openid (2.3.0) Loading from cache
631 - Installing netbrain/highcharts-js (3.0.9) Loading from cache
632 - Installing sentry/sentry (0.12.1) Loading from cache
633 - Installing wikimedia/css-sanitizer (v1.0.2) Loading from cache
634 - Installing mustangostang/spyc (0.6.2) Loading from cache
635 - Installing mediawiki/universal-language-selector (dev-master 36364f2) Cloning 36364f244d
636 - Installing mediawiki/translate (dev-master 6504ba8) Cloning 6504ba8508
637 - Installing wmde/php-vuejs-templating (dev-master d4c1508) Cloning d4c1508ed2
638 - Installing mediawiki/article-placeholder (dev-master 57c6a29) Cloning 57c6a291b4
639 - Installing wikibase/wikimedia-badges (dev-master 52617c5) Cloning 52617c5723
640 - Installing stil/gd-text (v1.0.0) Loading from cache
641 - Installing symfony/yaml (2.8.x-dev 968ef42) Cloning 968ef42161
642 - Installing phpdocumentor/reflection-docblock (2.0.5) Loading from cache
643 - Installing symfony/polyfill-mbstring (dev-master 2ec8b39) Cloning 2ec8b39c38
644 - Installing mediawiki/semantic-forms (3.7) Loading from cache
645 - Installing wikimedia/equivset (1.2.0) Loading from cache
646 - Installing tecnickcom/tcpdf (6.2.13) Loading from cache
647 - Installing spipu/html2pdf (v4.6.1) Loading from cache
648 - Installing elasticsearch/elasticsearch (5.3.0) Loading from cache
649 - Installing ruflin/elastica (5.3.0) Loading from cache
650 - Installing data-values/interfaces (0.2.5) Loading from cache
651 - Installing data-values/data-values (1.1.1) Loading from cache
652 - Installing data-values/common (0.4.x-dev 7b11237) Cloning 7b11237246
653 - Installing data-values/validators (dev-master 6a5157b) Cloning 6a5157b16a
654 - Installing param-processor/param-processor (dev-master 22204d8) Cloning 22204d8436
655 - Installing symfony/css-selector (3.4.x-dev eac760b) Cloning eac760b414
656 - Installing onoi/callback-container (dev-master cf2f4dd) Cloning cf2f4dda1b
657 - Installing onoi/shared-resources (0.4.3) Loading from cache
658 - Installing onoi/tesa (0.1.0) Loading from cache
659 - Installing onoi/cache (dev-master c736c78) Cloning c736c78b1a
660 - Installing onoi/blob-store (dev-master c8d59d5) Cloning c8d59d580f
661 - Installing onoi/http-request (dev-master a7cf33b) Cloning a7cf33bae8
662 - Installing mediawiki/parser-hooks (dev-master 2336fef) Cloning 2336fef261
663 - Installing mediawiki/validator (dev-master 96beb6d) Cloning 96beb6d514
664 - Installing onoi/event-dispatcher (dev-master 2ab3958) Cloning 2ab3958a7c
665 - Installing onoi/message-reporter (dev-master 1e47351) Cloning 1e4735168d
666 - Installing serialization/serialization (3.2.2) Loading from cache
667 - Installing mediawiki/semantic-media-wiki (dev-master 333a0b7) Cloning 333a0b70dd
668 - Installing mediawiki/semantic-extra-special-properties (dev-master 298114d) Cloning 298114d442
669 - Installing nicmart/tree (v0.2.7) Loading from cache
670 - Installing data-values/geo (dev-master 4260aa1) Cloning 4260aa1551
671 - Installing mediawiki/semantic-result-formats (dev-master 04b9aab) Cloning 04b9aab08e
672 - Installing respect/validation (1.1.x-dev 22f1f14) Cloning 22f1f14430
673 - Installing composer/ca-bundle (dev-master 134242f) Cloning 134242fce6
674 - Installing maxmind/web-service-common (v0.4.0) Loading from cache
675 - Installing maxmind-db/reader (v1.2.0) Loading from cache
676 - Installing geoip2/geoip2 (v2.7.0) Loading from cache
677 - Installing maxmind/minfraud (v1.5.0) Loading from cache
678 - Installing neitanod/forceutf8 (v2.x-dev 47c883a) Cloning 47c883ab27
679 - Installing corneltek/getoptionkit (dev-master 9f21944) Cloning 9f219446ba
680 - Installing amzn/login-and-pay-with-amazon-sdk-php (dev-master 198cc8c) Cloning 198cc8ccab
681 - Installing ircmaxell/password-compat (1.0.x-dev 9b99377) Cloning 9b99377557
682 - Installing symfony/polyfill-php55 (dev-master b64e7f0) Cloning b64e7f0c37
683 - Installing symfony/polyfill-php54 (dev-master d7810a1) Cloning d7810a14b2
684 - Installing symfony/http-foundation (2.8.x-dev 138b0d6) Cloning 138b0d6f10
685 - Installing symfony/event-dispatcher (2.8.x-dev 45abf96) Cloning 45abf96cdc
686 - Installing predis/predis (v1.1.x-dev 111d100) Cloning 111d100ee3
687 - Installing phpmailer/phpmailer (v5.2.26) Loading from cache
688 - Installing clio/clio (0.1.8) Loading from cache
689 - Installing monolog/monolog (1.22.1) Loading from cache
690 - Installing coderkungfu/php-queue (dev-master a9baeb0) Cloning a9baeb0ae3
691 - Installing wikimedia/smash-pig (v0.5.1) Cloning 268799f492
692 - Installing twig/twig (1.x-dev b36e3eb) Cloning b36e3eb452
693 - Installing jstayton/google-maps-geocoder (v2.4.0) Loading from cache
694 - Installing mediawiki/page-forms (dev-master 538b2fe) Cloning 538b2fe4bd
695 - Installing masterminds/html5 (2.x-dev 441fb2b) Cloning 441fb2bc82
696 - Installing querypath/querypath (dev-master 82fcee6) Cloning 82fcee6e68
697 - Installing justinrainbow/json-schema (5.x-dev d283e11) Cloning d283e11b6e
698 - Installing mediawiki/bootstrap (dev-master cdb1d58) Cloning cdb1d58cee
699 - Installing mbostock/d3 (v3.5.17) Loading from cache
700 - Installing symfony/process (2.8.x-dev 6778bb0) Cloning 6778bb0851
701 - Installing mediawiki/oauthclient (0.1.2) Loading from cache
702 - Installing werdnum/simple-lightncandy (0.5.0) Loading from cache
703 - Installing phpseclib/phpseclib (2.0.1) Loading from cache
704 - Installing jumbojett/openid-connect-php (dev-master 0d52339) Cloning 0d52339b01
705 - Installing wikibase/data-model (7.x-dev 1c26274) Cloning 1c2627481b
706 - Installing diff/diff (2.x-dev f49b885) Cloning f49b8850a9
707 - Installing wikibase/data-model-services (dev-master 16bc1d2) Cloning 16bc1d2dec
708 - Installing neutron/sphinxsearch-api (dev-master a108fda) Cloning a108fda835
709 - Installing swiftmailer/swiftmailer (v5.2.2) Loading from cache
710 - Installing james-heinrich/getid3 (v1.9.15) Loading from cache
711 - Installing guzzlehttp/guzzle (v3.8.1) Loading from cache
712 - Installing data-values/time (dev-master acdda51) Cloning acdda5122e
713 - Installing data-values/serialization (dev-master 364f375) Cloning 364f375770
714 - Installing wikibase/data-model-serialization (dev-master c68907a) Cloning c68907a490
715 - Installing wikibase/internal-serialization (dev-master 47766c2) Cloning 47766c2e41
716 - Installing propertysuggester/property-suggester (dev-master 2433e61) Cloning 2433e61bfb
717 - Installing data-values/number (0.9.1) Loading from cache
718 - Installing wikibase/wikibase (dev-master ebb1f7d) Cloning ebb1f7d145
719
720
721 [RuntimeException]
722 Failed to execute git clone --no-checkout 'https://gerrit.wikimedia.org/r/mediawiki/extensions/Wikibase' 'extensions/Wikibase/' && cd 'extensions/Wikibase/' && git remote add composer 'https://gerrit.wik
723 imedia.org/r/mediawiki/extensions/Wikibase' && git fetch composer
724 fatal: destination path 'extensions/Wikibase' already exists and is not an empty directory.
725
726
727update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...
728$ # Contrary to what is said in this error message, there were no "extensions/Wikibase" directory), then I abandonned here…