Paste P7977

scandium npm
ActivePublic

Authored by Dzahn on Fri, Jan 11, 10:52 PM.
root@scandium:/etc/apt/preferences.d# puppet agent -tv
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for scandium.eqiad.wmnet
Notice: /Stage[main]/Base::Environment/Tidy[/var/tmp/core]: Tidying 0 files
Info: Applying configuration version '1547247008'
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install npm' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
npm : Depends: node-abbrev (>= 1.1.1~) but 1.0.9-1 is to be installed
Depends: node-ansi-regex (>= 3.0~) but 2.0.0-1 is to be installed
Depends: node-cacache (>= 10.0.4~) but it is not going to be installed
Depends: node-config-chain (>= 1.1.11~) but it is not going to be installed
Depends: node-glob (>= 7.1.2~) but 7.1.1-1 is to be installed
Depends: node-hosted-git-info (>= 2.6~) but 2.1.5-1 is to be installed
Depends: node-ini (>= 1.3.5~) but 1.1.0-1 is to be installed
Depends: node-npm-package-arg but it is not going to be installed
Depends: node-jsonstream (>= 1.3.2~) but 1.0.3-4 is to be installed
Depends: node-libnpx (>= 10.0.1~) but it is not going to be installed
Depends: node-lockfile (>= 1.0.3~) but 0.4.1-1 is to be installed
Depends: node-lru-cache (>= 4.1.1~) but 4.0.2-1 is to be installed
Depends: node-move-concurrently (>= 1.0.1~) but it is not going to be installed
Depends: node-normalize-package-data (>= 2.4~) but 2.3.5-2 is to be installed
Depends: node-gyp (>= 3.6.2~) but 3.4.0-1 is to be installed
Depends: node-resolve-from (>= 4.0~) but 2.0.0-1 is to be installed
Depends: node-npmlog (>= 4.1.2~) but 0.0.4-1 is to be installed
Depends: node-osenv (>= 0.1.5~) but 0.1.0-1 is to be installed
Depends: node-read-package-json (>= 2.0.13~) but 1.2.4-1 is to be installed
Depends: node-request (>= 2.83~) but 2.26.1-1 is to be installed
Depends: node-retry (>= 0.10.1~) but 0.6.0-1 is to be installed
Depends: node-rimraf (>= 2.6.2~) but 2.5.4-2 is to be installed
Depends: node-semver (>= 5.5~) but 5.3.0-1 is to be installed
Depends: node-sha (>= 2.0.1~) but 1.2.3-1 is to be installed
Depends: node-slide (>= 1.1.6~) but 1.1.4-1 is to be installed
Depends: node-strip-ansi (>= 4.0~) but 3.0.1-1 is to be installed
Depends: node-tar (>= 4.4~) but 2.2.1-1 is to be installed
Depends: node-boxen (>= 1.2.1~) but it is not going to be installed
Depends: node-which (>= 1.3~) but 1.2.11-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Packages::Npm/Package[npm]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install npm' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
npm : Depends: node-abbrev (>= 1.1.1~) but 1.0.9-1 is to be installed
Depends: node-ansi-regex (>= 3.0~) but 2.0.0-1 is to be installed
Depends: node-cacache (>= 10.0.4~) but it is not going to be installed
Depends: node-config-chain (>= 1.1.11~) but it is not going to be installed
Depends: node-glob (>= 7.1.2~) but 7.1.1-1 is to be installed
Depends: node-hosted-git-info (>= 2.6~) but 2.1.5-1 is to be installed
Depends: node-ini (>= 1.3.5~) but 1.1.0-1 is to be installed
Depends: node-npm-package-arg but it is not going to be installed
Depends: node-jsonstream (>= 1.3.2~) but 1.0.3-4 is to be installed
Depends: node-libnpx (>= 10.0.1~) but it is not going to be installed
Depends: node-lockfile (>= 1.0.3~) but 0.4.1-1 is to be installed
Depends: node-lru-cache (>= 4.1.1~) but 4.0.2-1 is to be installed
Depends: node-move-concurrently (>= 1.0.1~) but it is not going to be installed
Depends: node-normalize-package-data (>= 2.4~) but 2.3.5-2 is to be installed
Depends: node-gyp (>= 3.6.2~) but 3.4.0-1 is to be installed
Depends: node-resolve-from (>= 4.0~) but 2.0.0-1 is to be installed
Depends: node-npmlog (>= 4.1.2~) but 0.0.4-1 is to be installed
Depends: node-osenv (>= 0.1.5~) but 0.1.0-1 is to be installed
Depends: node-read-package-json (>= 2.0.13~) but 1.2.4-1 is to be installed
Depends: node-request (>= 2.83~) but 2.26.1-1 is to be installed
Depends: node-retry (>= 0.10.1~) but 0.6.0-1 is to be installed
Depends: node-rimraf (>= 2.6.2~) but 2.5.4-2 is to be installed
Depends: node-semver (>= 5.5~) but 5.3.0-1 is to be installed
Depends: node-sha (>= 2.0.1~) but 1.2.3-1 is to be installed
Depends: node-slide (>= 1.1.6~) but 1.1.4-1 is to be installed
Depends: node-strip-ansi (>= 4.0~) but 3.0.1-1 is to be installed
Depends: node-tar (>= 4.4~) but 2.2.1-1 is to be installed
Depends: node-boxen (>= 1.2.1~) but it is not going to be installed
Depends: node-which (>= 1.3~) but 1.2.11-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Notice: /Stage[main]/Visualdiff/Group[visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/Group[visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/User[visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/User[visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/File[/var/log/visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/File[/var/log/visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/File[/etc/visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/File[/etc/visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/Group[testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/Group[testreduce]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/User[testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/User[testreduce]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/File[/var/log/testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/File[/var/log/testreduce]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/File[/etc/testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/File[/etc/testreduce]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Diffserver/Visualdiff::Server[diffserver]/File[/etc/visualdiff/diffserver.config.js]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Diffserver/Visualdiff::Server[diffserver]/File[/etc/visualdiff/diffserver.config.js]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Diffserver/Visualdiff::Server[diffserver]/Service[diffserver]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Diffserver/Visualdiff::Server[diffserver]/Service[diffserver]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/Apt::Pin[stretch-backports]/File[/etc/apt/preferences.d/stretch_backports.pref]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/Apt::Pin[stretch-backports]/File[/etc/apt/preferences.d/stretch_backports.pref]: Skipping because of failed dependencies
Notice: /Stage[main]/Apt/Exec[apt-get update]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Apt/Exec[apt-get update]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Rt_server/Testreduce::Server[parsoid-rt]/File[/etc/testreduce/parsoid-rt.settings.js]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Rt_server/Testreduce::Server[parsoid-rt]/File[/etc/testreduce/parsoid-rt.settings.js]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Rt_server/Testreduce::Server[parsoid-rt]/Service[parsoid-rt]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Rt_server/Testreduce::Server[parsoid-rt]/Service[parsoid-rt]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Rt_client/Testreduce::Client[parsoid-rt-client]/File[/etc/testreduce/parsoid-rt-client.config.js]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Rt_client/Testreduce::Client[parsoid-rt-client]/File[/etc/testreduce/parsoid-rt-client.config.js]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Rt_client/Testreduce::Client[parsoid-rt-client]/Service[parsoid-rt-client]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Rt_client/Testreduce::Client[parsoid-rt-client]/Service[parsoid-rt-client]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Vd_server/Testreduce::Server[parsoid-vd]/File[/etc/testreduce/parsoid-vd.settings.js]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Vd_server/Testreduce::Server[parsoid-vd]/File[/etc/testreduce/parsoid-vd.settings.js]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Vd_server/Testreduce::Server[parsoid-vd]/Service[parsoid-vd]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Vd_server/Testreduce::Server[parsoid-vd]/Service[parsoid-vd]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Vd_client/Testreduce::Client[parsoid-vd-client]/File[/etc/testreduce/parsoid-vd-client.config.js]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Vd_client/Testreduce::Client[parsoid-vd-client]/File[/etc/testreduce/parsoid-vd-client.config.js]: Skipping because of failed dependencies
Notice: /Stage[main]/Profile::Parsoid::Vd_client/Testreduce::Client[parsoid-vd-client]/Service[parsoid-vd-client]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Profile::Parsoid::Vd_client/Testreduce::Client[parsoid-vd-client]/Service[parsoid-vd-client]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/Git::Clone[integration/visualdiff]/File[/srv/visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/Git::Clone[integration/visualdiff]/File[/srv/visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/File[/srv/visualdiff/pngs]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/File[/srv/visualdiff/pngs]: Skipping because of failed dependencies
Notice: /Stage[main]/Visualdiff/Git::Clone[integration/visualdiff]/Exec[git_clone_integration/visualdiff]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Visualdiff/Git::Clone[integration/visualdiff]/Exec[git_clone_integration/visualdiff]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/Git::Clone[mediawiki/services/parsoid/testreduce]/File[/srv/testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/Git::Clone[mediawiki/services/parsoid/testreduce]/File[/srv/testreduce]: Skipping because of failed dependencies
Notice: /Stage[main]/Testreduce/Git::Clone[mediawiki/services/parsoid/testreduce]/Exec[git_clone_mediawiki/services/parsoid/testreduce]: Dependency Package[npm] has failures: true
Warning: /Stage[main]/Testreduce/Git::Clone[mediawiki/services/parsoid/testreduce]/Exec[git_clone_mediawiki/services/parsoid/testreduce]: Skipping because of failed dependencies
Error: Cannot create /srv/deployment/parsoid/deploy; parent directory /srv/deployment/parsoid does not exist
Error: /Stage[main]/Parsoid/Service::Node[parsoid]/Service::Deploy::Gitclone[parsoid]/Git::Clone[parsoid/deploy]/File[/srv/deployment/parsoid/deploy]/ensure: change from absent to directory failed: Cannot create /srv/deployment/parsoid/deploy; parent directory /srv/deployment/parsoid does not exist
Notice: /Stage[main]/Parsoid/Service::Node[parsoid]/Service::Deploy::Gitclone[parsoid]/Git::Clone[parsoid/deploy]/Exec[git_clone_parsoid/deploy]: Dependency File[/srv/deployment/parsoid/deploy] has failures: true
Warning: /Stage[main]/Parsoid/Service::Node[parsoid]/Service::Deploy::Gitclone[parsoid]/Git::Clone[parsoid/deploy]/Exec[git_clone_parsoid/deploy]: Skipping because of failed dependencies
Notice: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/File[/lib/systemd/system/parsoid.service]: Dependency File[/srv/deployment/parsoid/deploy] has failures: true
Warning: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/File[/lib/systemd/system/parsoid.service]: Skipping because of failed dependencies
Notice: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/Exec[systemd reload for parsoid]: Dependency File[/srv/deployment/parsoid/deploy] has failures: true
Warning: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/Exec[systemd reload for parsoid]: Skipping because of failed dependencies
Notice: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/Service[parsoid]: Dependency File[/srv/deployment/parsoid/deploy] has failures: true
Warning: /Stage[main]/Parsoid/Service::Node[parsoid]/Base::Service_unit[parsoid]/Service[parsoid]: Skipping because of failed dependencies
Notice: Applied catalog in 11.01 seconds
root@scandium:/etc/apt/preferences.d#
---
root@scandium:/etc/apt/preferences.d# apt-get install -t stretch-backports npm
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
npm : Depends: node-cacache (>= 10.0.4~) but it is not going to be installed
Depends: node-move-concurrently (>= 1.0.1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Dzahn created this paste.Fri, Jan 11, 10:52 PM