Page MenuHomePhabricator
Paste P8215

puppet run with broken apt due to openstack packages
ActivePublic

Authored by hashar on Mar 18 2019, 11:24 AM.
Info: Using configured environment 'production'
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Caching catalog for integration-slave-docker-1051.integration.eqiad.wmflabs
Notice: /Stage[main]/Base::Environment/Tidy[/var/tmp/core]: Tidying 0 files
Info: Applying configuration version '1552908238'
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-novaclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-novaclient : Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-novaclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-novaclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-novaclient : Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-glanceclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-glanceclient : Depends: python-keystoneclient (>= 1:1.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.6) but 0.8.2-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-glanceclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-glanceclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-glanceclient : Depends: python-keystoneclient (>= 1:1.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.6) but 0.8.2-1 is to be installed
E: Unable to correct problems, you have held broken packages.
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-keystoneclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-keystoneclient : Depends: python-debtcollector but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.config (>= 1:3.7.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-positional but it is not going to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-keystoneclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-keystoneclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-keystoneclient : Depends: python-debtcollector but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.config (>= 1:3.7.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-positional but it is not going to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-openstackclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-openstackclient : Depends: python-cinderclient (>= 1:1.3.1) but it is not going to be installed
Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-glanceclient (>= 1:2.0.0) but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-keystoneclient (>= 1:1.6.0) but it is not going to be installed
Depends: python-neutronclient (>= 1:2.6.0) but it is not going to be installed
Depends: python-novaclient (>= 2:2.30.0) but it is not going to be installed
Depends: python-openstacksdk (>= 0.8.1) but it is not going to be installed
Depends: python-os-client-config (>= 1.13.1) but it is not going to be installed
Depends: python-oslo.config (>= 1:3.7.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.2.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-openstackclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-openstackclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-openstackclient : Depends: python-cinderclient (>= 1:1.3.1) but it is not going to be installed
Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-glanceclient (>= 1:2.0.0) but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-keystoneclient (>= 1:1.6.0) but it is not going to be installed
Depends: python-neutronclient (>= 1:2.6.0) but it is not going to be installed
Depends: python-novaclient (>= 2:2.30.0) but it is not going to be installed
Depends: python-openstacksdk (>= 0.8.1) but it is not going to be installed
Depends: python-os-client-config (>= 1.13.1) but it is not going to be installed
Depends: python-oslo.config (>= 1:3.7.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.2.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-designateclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-designateclient : Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-debtcollector (>= 1.2.0) but it is not going to be installed
Depends: python-keystoneclient (>= 1:0.11.1) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-designateclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-designateclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-designateclient : Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-debtcollector (>= 1.2.0) but it is not going to be installed
Depends: python-keystoneclient (>= 1:0.11.1) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-pbr (>= 1.8) but 0.8.2-1 is to be installed
Depends: python-stevedore (>= 1.5.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-neutronclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-neutronclient : Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-debtcollector (>= 1.2.0) but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-os-client-config but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Error: /Stage[main]/Openstack::Clientpackages::Common/Package[python-neutronclient]/ensure: change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install python-neutronclient' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
python-neutronclient : Depends: python-cliff (>= 1.15.0) but it is not going to be installed
Depends: python-debtcollector (>= 1.2.0) but it is not going to be installed
Depends: python-keystoneauth1 (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.i18n (>= 2.1.0) but it is not going to be installed
Depends: python-oslo.serialization (>= 1.10.0) but it is not going to be installed
Depends: python-oslo.utils (>= 3.5.0) but it is not going to be installed
Depends: python-os-client-config but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Notice: Applied catalog in 8.64 seconds