Page MenuHomePhabricator
Paste P9025

pip problems on SWAP
ActivePublic

Authored by Neil_P._Quinn_WMF on Mon, Sep 2, 3:39 PM.
# Trying to install nbdime on notebook1003 (third attempt)
neilpquinn-wmf@notebook1003:~$ pip install nbdime
Collecting nbdime
Using cached https://files.pythonhosted.org/packages/0f/3f/668922f04fa6848437d8486c495ceea2fbe2b011e1084cb49a792c4bec31/nbdime-1.1.0-py2.py3-none-any.whl
Requirement already satisfied: nbformat in ./venv/lib/python3.5/site-packages (from nbdime) (4.4.0)
Collecting GitPython!=2.1.4,!=2.1.5,!=2.1.6 (from nbdime)
Using cached https://files.pythonhosted.org/packages/8e/c7/70bd352e8a561a9b6d1cde9aa313b9d7c871b0c94c3821f44c01f3187e1d/GitPython-3.0.2-py3-none-any.whl
Requirement already satisfied: six in ./venv/lib/python3.5/site-packages (from nbdime) (1.11.0)
Collecting colorama (from nbdime)
Using cached https://files.pythonhosted.org/packages/4f/a6/728666f39bfff1719fc94c481890b2106837da9318031f71a8424b662e12/colorama-0.4.1-py2.py3-none-any.whl
Requirement already satisfied: notebook in ./venv/lib/python3.5/site-packages (from nbdime) (5.7.8)
Requirement already satisfied: requests in ./venv/lib/python3.5/site-packages (from nbdime) (2.19.1)
Requirement already satisfied: jinja2>=2.9 in ./venv/lib/python3.5/site-packages (from nbdime) (2.10)
Requirement already satisfied: tornado in ./venv/lib/python3.5/site-packages (from nbdime) (6.0.3)
WARNING: No metadata found in ./venv/lib/python3.5/site-packages
ERROR: Could not install packages due to an EnvironmentError: [Errno 2] No such file or directory: '/srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/tornado-6.0.3.dist-info/METADATA'
# Trying to install wmfdata on notebook1004 after successfully installing nbdime
neilpquinn-wmf@notebook1004:~/proj$ pip install git+https://github.com/neilpquinn/wmfdata.git
Collecting git+https://github.com/neilpquinn/wmfdata.git
Cloning https://github.com/neilpquinn/wmfdata.git to /tmp/pip-wch3cu17-build
Requirement already satisfied: impyla in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from wmfdata==0.1)
Requirement already satisfied: matplotlib>=2.1 in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from wmfdata==0.1)
Requirement already satisfied: mysql-connector-python in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from wmfdata==0.1)
Requirement already satisfied: pandas in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from wmfdata==0.1)
Collecting thrift-sasl==0.2.1 (from wmfdata==0.1)
Requirement already satisfied: six in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from impyla->wmfdata==0.1)
Requirement already satisfied: thriftpy>=0.3.5 in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from impyla->wmfdata==0.1)
Requirement already satisfied: bitarray in /srv/home/neilpquinn-wmf/venv/lib/python3.5/site-packages (from impyla->wmfdata==0.1)
Exception:
Traceback (most recent call last):
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/basecommand.py", line 215, in main
status = self.run(options, args)
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/commands/install.py", line 353, in run
wb.build(autobuilding=True)
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/wheel.py", line 749, in build
self.requirement_set.prepare_files(self.finder)
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/req/req_set.py", line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/req/req_set.py", line 666, in _prepare_file
check_dist_requires_python(dist)
File "/home/neilpquinn-wmf/venv/lib/python3.5/site-packages/pip/utils/packaging.py", line 48, in check_dist_requires_python
feed_parser.feed(metadata)
File "/usr/lib/python3.5/email/feedparser.py", line 178, in feed
self._input.push(data)
File "/usr/lib/python3.5/email/feedparser.py", line 104, in push
self._partial.write(data)
TypeError: string argument expected, got 'NoneType'

Event Timeline

Neil_P._Quinn_WMF edited the content of this paste. (Show Details)Mon, Sep 2, 7:32 PM
Neil_P._Quinn_WMF changed the title of this paste from Trying to install nbdime to pip problems on SWAP.
Neil_P._Quinn_WMF updated the paste's language from autodetect to shell.