Page MenuHomePhabricator

show the title of the translated page in the <title> of Special:ContentTranslation
Closed, DeclinedPublic

Description

Special:ContentTranslation shows "Translate page" in the window title. When there are several translation tabs open, it's impossible to know which one is which, so the window title should include the article title.


See also: Documentation where this is supposed to be documented: https://www.mediawiki.org/wiki/Manual:Special_pages#The_localisation_file , https://www.mediawiki.org/wiki/Manual:Special_pages#Setting_an_Extension_Title

Event Timeline

Amire80 created this task.Jun 4 2015, 9:14 AM
Amire80 raised the priority of this task from to Low.
Amire80 updated the task description. (Show Details)
Amire80 added a project: ContentTranslation.
Amire80 added a subscriber: Amire80.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2015, 9:14 AM
Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Jun 25 2015, 11:12 PM
Amire80 set Security to None.
Pginer-WMF moved this task from CX6 to CX7 on the ContentTranslation board.Jul 21 2015, 4:18 PM

Cool, will like to work on it :)

Cool, will like to work on it :)

Go for it!

Ok, i will and if i have any issues, i will ping you :D

node Server.js

npm ERR! weird error 1
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian

npm ERR! not ok code 0

I have this error while setting up npm. Any help?

You probably have an incorrect version of Node.js installed.

Which operating system are you using and which version of Node.js?

I am using Ubuntu 14.04 LTS, is there anything wrong?

And which version of Node.js?

My version of is: v0.10.25

  1. Make sure that all modules are installed by running npm install
  2. Try using npm start instead of node Server.js (Shouldn't change anything, but try :))

I did that already, but i still have a problem

@D3r1ck01 Ubuntu ships with an outdated version of Node. Try following the "How To Install Using a PPA" section of this article.

Amire80 moved this task from CX9 candidates to Bugs on the ContentTranslation board.
Nemo_bis updated the task description. (Show Details)Oct 3 2016, 12:59 PM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 3 2016, 12:59 PM

I would like to work on this bug and I'll would be really happy if somebody can provide me with some pointers to begin with. (I am a noobie)

Arrbee moved this task from Bugs to Check & Move on the ContentTranslation board.Mon, Nov 11, 8:24 AM
Pginer-WMF closed this task as Declined.Mon, Nov 11, 8:40 AM
Pginer-WMF added a subscriber: Pginer-WMF.

We have not observed this causing issues in practice. If we observe that often users work on multiple translations at the same time, we can consider reopening.