Mentions are not recognized when more than one section is involved
Closed, ResolvedPublic

Description

Currently, mention notifications are only sent if a change was add-comment (added a comment to an existing section) or new-section-with-comment (added a section)
When someone adds multiple sections, or comments on an existing sections and starts a new section below it, no mention notification will be generated.
E.g. https://he.wikipedia.org/w/index.php?title=%D7%A9%D7%99%D7%97%D7%94:%D7%98%D7%A7%D7%A1_%D7%A1%D7%92%D7%99%D7%A8%D7%AA_%D7%94%D7%92%D7%91%D7%95%D7%9C_%D7%91%D7%99%D7%9F_%D7%94%D7%95%D7%93%D7%95_%D7%9C%D7%A4%D7%A7%D7%99%D7%A1%D7%98%D7%9F&diff=17037835&oldid=17037675

matthiasmullie updated the task description. (Show Details)
matthiasmullie raised the priority of this task from to Needs Triage.
matthiasmullie added a subscriber: matthiasmullie.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2015, 11:50 AM

Change 215885 had a related patch set uploaded (by Matthias Mullie):
Generate mention notifications in more cases

https://gerrit.wikimedia.org/r/215885

Above patch only adds a test to show the failure. Also added a todo in there on how/where to fix it.

Matanya added a subscriber: Matanya.Jun 4 2015, 2:26 PM
Legoktm moved this task from Backlog to Needs plan on the Notifications board.Jul 6 2015, 7:23 AM
He7d3r added a subscriber: He7d3r.Jul 6 2015, 12:34 PM
Mattflaschen-WMF triaged this task as Normal priority.Jul 8 2015, 11:57 PM
Mattflaschen-WMF added a subscriber: Mattflaschen-WMF.
Mattflaschen-WMF renamed this task from Mentions are only recognized in limited cases to Mentions are not recognized when more than one section is involved.Oct 30 2015, 9:40 PM
Mattflaschen-WMF set Security to None.
Mattflaschen-WMF added subscribers: Catrope, XXN.

Change 215885 abandoned by Matthias Mullie:
WIP: Generate mention notifications in more cases

https://gerrit.wikimedia.org/r/215885

Restricted Application added a project: TCB-Team. · View Herald TranscriptJan 5 2017, 1:20 PM
Restricted Application added a subscriber: TerraCodes. · View Herald Transcript

It looks like this was reported a rather long time ago and since lots of work has happened on mention notifications since then!

Addshore closed this task as Resolved.Jan 10 2017, 5:13 PM
Addshore claimed this task.

I am going to mark this as resolved due to the work that has been carried out.
I have confirmed a few cases as working

If more cases are missing / not working it might make sense to file new tickets! :)

Restricted Application added a project: User-Addshore. · View Herald TranscriptJan 10 2017, 5:13 PM