In Firefox, tabbing in the template dialog skips parameter actions
Closed, ResolvedPublic1 Story Points

Description

Follow on from the work done in T97323.

Tabbing in the template dialog now works as intended in Chrome and Safari, where you can tab to the parameter actions (info and delete) and interact with them using the spacebar and the enter key.

However, in Firefox, tabbing goes straight from one parameter field to the next, skipping the parameter actions entirely. Fixing this is low priority because it's still an improvement on the behavior before the fix in T97323 (tabbing to the parameter actions but being unable to use the keyboard to do anything useful once you were there), but it would still be good for accessibility and cross-browser standardization.

Neil_P._Quinn_WMF updated the task description. (Show Details)
Neil_P._Quinn_WMF raised the priority of this task from to Low.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 4 2015, 11:37 PM

I can't reproduce using Firefox 38.0.5 on Windows 7. Tabbing highlights the icons and they work as expected. Shift-tabbing, however, skips the icons (but this is consistent in all browsers and probably reasonable).

Neil_P._Quinn_WMF closed this task as Resolved.Sep 8 2017, 12:58 AM
Neil_P._Quinn_WMF claimed this task.

Yes, this definitely looks fixed now.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 8 2017, 12:58 AM
Jdforrester-WMF set the point value for this task to 1.Sep 8 2017, 5:30 PM