Page MenuHomePhabricator

Main view of a new MOOC breaks due to insufficient MOOC-Index
Closed, DeclinedPublic

Description

when creating a new MOOC on wikiversity Using the MOOC-Interface (e.g. on this page: https://en.wikiversity.org/wiki/Category:MOOC) a new MOOC will be created on the page with the respective title but the MoocIndex file is empty. Because of this the overview lua script breaks and thus there is no chance that the overvew template will be rendered. That is why one cannot add a new lesson.
I think this problem is reproducable and can be fixed by looking at the lua based part of the code only.

example:
I created:

Have a look at creation times and version history to see how hand crafted work (which new users to the Mooc-Interface are not aware of) helped doing a quickfix.

Related Objects

Event Timeline

Renepick created this task.Jun 8 2015, 12:52 PM
Renepick assigned this task to Sebschlicht.
Renepick raised the priority of this task from to Normal.
Renepick updated the task description. (Show Details)
Renepick added a project: MOOC-Interface.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 8 2015, 12:52 PM

Closing as declined because of archival per T202803.

Zoranzoki21 closed this task as Declined.Dec 31 2018, 7:10 AM