Page MenuHomePhabricator

MobileDiff appears strangely empty if previous revision is hidden
Closed, ResolvedPublic5 Story Points

Description

Background

original report and steps to reproduce

Revision 666058325 on en.wikipedia.org was hidden.

As such, the diff for it cannot be viewed. Both Vector and Minerva show a relevant message to reflect this fact:
https://en.m.wikipedia.org/wiki/Special:MobileDiff/666058325
https://en.wikipedia.org/wiki/Special:Diff/666058325

However the edit before and after it can also not be viewed. On desktop, it shows the same message
https://en.wikipedia.org/wiki/Special:Diff/666058337

But MobileDiff shows an empty page:
https://en.m.wikipedia.org/wiki/Special:MobileDiff/666058337

Developer notes

The behaviour between https://en.m.wikipedia.org/wiki/Special:MobileDiff/666058337 and https://en.wikipedia.org/w/index.php?title=Wikipedia&diff=prev&oldid=666057460 is different. With a little investigation it should be clear why (they share the same code)

Specifically the text "You cannot view this diff because one or both of the revisions have been removed from the public archives. Details can be found in the deletion log for this page. " should be shown

Acceptance criteria

  • MobileDiff should appear as usual

Testing criteria

Visit http://reading-web-staging.wmflabs.org/wiki/Special:MobileDiff/44 as anon - you should be informed it is not possible to view the revision.

Related Objects

StatusAssignedTask
Declineddchen
OpenNone
OpenNone
DuplicateNone
OpenNone
ResolvedAbit
OpenNone
OpenNone
OpenNone
OpenNone
DuplicateNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
Resolvedppelberg
ResolvedKrinkle
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
StalledNone
ResolvedPetrb
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
Resolvedovasileva

Event Timeline

Krinkle created this task.Jun 9 2015, 12:22 AM
Krinkle updated the task description. (Show Details)
Krinkle raised the priority of this task from to Needs Triage.
Krinkle added a project: MobileFrontend.
Krinkle added a subscriber: Krinkle.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptJun 9 2015, 12:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdlrobson moved this task from Backlog to Bugs on the MobileFrontend board.Aug 4 2015, 6:38 PM
Jhernandez triaged this task as Normal priority.Aug 17 2015, 11:19 AM
Jhernandez lowered the priority of this task from Normal to Low.Jul 27 2016, 4:42 PM
Jhernandez moved this task from To Triage to Triaged but Future on the Readers-Web-Backlog board.
Jdlrobson raised the priority of this task from Low to Normal.Aug 1 2017, 9:18 PM
Jdlrobson added a subscriber: Jdlrobson.

Reproducable bug.

Krinkle removed a subscriber: Krinkle.Aug 16 2017, 12:21 AM
Jdlrobson moved this task from Inbox to Next up on the User-Jdlrobson board.Dec 1 2017, 7:50 PM
ovasileva updated the task description. (Show Details)Dec 4 2017, 3:33 PM
ovasileva set the point value for this task to 3.Dec 12 2017, 5:56 PM
ovasileva changed the point value for this task from 3 to 5.
ovasileva removed the point value for this task.

This is what I see when I visit the mobile page (https://en.m.wikipedia.org/wiki/Special:MobileDiff/666058337):

Is this not what we want?

Per Baha's comment, is this task to add a message like on desktop? "You cannot view this diff because one or both of the revisions have been removed from the public archives. Details can be found in the deletion log for this page."

ovasileva updated the task description. (Show Details)Jan 9 2018, 5:42 PM

The behaviour between https://en.m.wikipedia.org/wiki/Special:MobileDiff/666058337 and https://en.wikipedia.org/w/index.php?title=Wikipedia&diff=prev&oldid=666057460 is different. With a little investigation it should be clear why (they share the same code)

Specifically the text "You cannot view this diff because one or both of the revisions have been removed from the public archives. Details can be found in the deletion log for this page. " should be shown

Jdlrobson updated the task description. (Show Details)Jan 9 2018, 5:48 PM
Jdlrobson set the point value for this task to 5.

Change 405346 had a related patch set uploaded (by Niedzielski; owner: Sniedzielski):
[mediawiki/extensions/MobileFrontend@master] Fix: check old revision for deletion when diffing

https://gerrit.wikimedia.org/r/405346

Niedzielski removed Niedzielski as the assignee of this task.

Some repro steps:

  1. Create a new page. On my instance, this is rev 7. (Rev 8 is a File page for an image upload.)
  2. Edit the page. On my instance, this is rev 9.
  3. Delete the page (requires permission). On my instance, this is rev 10.
  4. Undelete the page (requires permission). On my instance, this is rev 11.
  5. Visit the two revisions in each state:
  6. Check more "normal" diffs like the creation diff have no regressions: http://localhost:8080/wiki/Special:MobileDiff/7.

Change 405346 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix: check old revision for deletion when diffing

https://gerrit.wikimedia.org/r/405346

ABorbaWMF added subscribers: Nirzar, ABorbaWMF.

This is working for me on the target URL in the description. Here some shots. I did notice the message has some weird text wrapping on phone width devices (@Nirzar).






Olga are you able to sign this off?

ovasileva closed this task as Resolved.Feb 1 2018, 8:11 PM

looks good to me! I think we might have to file a separate bug for the wrapping issue. @Jdlrobson - any idea if there's anything we can do about this?

Yes,the word wrapping needs to be present for diffs which may have lines, but it shouldn't break the word for warning messages. I'm guessing a css fix for this should be trivial.