Page MenuHomePhabricator

[Deepcat] adjust error message if the category can't be found
Closed, ResolvedPublic1 Estimated Story Points

Description

Adjust the error message if the category can't be found to “Die Kategorie konnte nicht gefunden werden" (en: The category couldn't be found") Right now it says "CatGraph konnte die Kategorie nicht finden" which seems misleading or cloudy for users as they might not know what CatGraph is.

Event Timeline

KasiaWMDE raised the priority of this task from to Medium.
KasiaWMDE updated the task description. (Show Details)
KasiaWMDE set Security to None.
KasiaWMDE edited a custom field.
KasiaWMDE moved this task from Incoming to Sprint ready on the German-Community-Wishlist board.
KasiaWMDE renamed this task from [Deepcat] Adjust error message if the category can't be found to [Deepcat] adjust error message if the category can't be found.Jun 10 2015, 2:35 PM

"CatGraph could not find the category" is precisely what happened if that message is displayed. I see no problem here. If you think users need more information about Catgraph, https://wikitech.wikimedia.org/wiki/Nova_Resource:Catgraph/Documentation would be the link to use. If you think our users are too stupid to click a link, you could change the message to "Something Be Wrong" instead.

I think "Die Kategorie <xyz> konnte nicht gefunden werden" is a nice compromise. "Something went wrong" doesn't tell that something about the category was wrong (which can be solved by the user himself) while having "CatGraph" inside the message could be indeed confusing.
Resolved together with @WMDE-Fisch in https://github.com/wmde/DeepCat-Gadget/commit/7ebf9656d393a3ce8cc367e7c938fa20c765f01b

would you mind fixing it for the English translation as well? ;-)

@Tobi_WMDE_SW, you realize I was being sarcastic? The 'fix' you just committed makes the error message *less* informative. The original one was more accurate. If you know how error messages should be phrased in the context of the code better than the person who wrote the code, Christoph in this case, maybe you should have written the code instead (and that was, again, not a serious suggestion). Please don't disimprove things.