Page MenuHomePhabricator

Admin could not set "confirmed users"
Closed, InvalidPublic

Description

In [[m:Meta:Confirmed_users]] and elsewhere (en.wp for example) it is said that 'confirmed users' status can be given by admin (of a local project). Recently I tried to grant some users (on id.wp) confirmed status because their autoconfirmed status was removed by a faulty filter. But I found out that I can't do it (I'm an admin and checkuser, but not bureaucrat). A bureaucrat friend who I asked for help also confirmed that it was greyed out for him also. Is this a bug?

(cross posting from https://meta.wikimedia.org/wiki/Meta_talk:Confirmed_users)

Apologize before I couldn't find a proper "Projects" tag for this. I tried "user", "group", "admin", "rights", "MediaWiki" (too much sub projects) etc. to no avail.

Event Timeline

Bennylin created this task.Jun 10 2015, 1:39 PM
Bennylin raised the priority of this task from to Needs Triage.
Bennylin updated the task description. (Show Details)
Bennylin added a subscriber: Bennylin.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 10 2015, 1:39 PM
Krenair closed this task as Invalid.EditedJun 10 2015, 1:47 PM
Krenair claimed this task.
Krenair added a subscriber: Krenair.

The meta page is misleading - this is only available for local users to add on some wikis, not all. Users with userrights-interwiki (i.e. sysadmins, meta local stewards) are able to grant it anywhere.

I made an edit to the page although now I'm not sure - is this page supposed to be specific to metawiki itself?

So this is only true for en.wp then? https://en.wikipedia.org/wiki/Wikipedia:User_access_levels#User_access_level_changes

A related question regarding someone who lost their ability to upload and move files (which I suspect is because they lost their autoconfirmed status, and I confirmed that through UserRights special page):

  1. is there a log somewhere that logs when and why a user lost their autoconfirmed (and if not should there be one)? Because I looked again at my faulty filter, and one particular user was not losing her right because of that filter, so I can't answer her as to why she lost her status (since it cannot be done manually by an admin either right?)
  2. if indeed the 'confirmed user' is not available in all wikis, is there a way to re-grant (auto)confirmed status to my local wiki (id.wp)?

@Krenair: the stewards bit is not true, though. I'm a steward, and that option was still greyed out for me (on id.wp), but I have that option on meta, though (where I'm not an admin, so it's must be my steward flag)

[1] https://meta.wikimedia.org/w/index.php?title=Meta:Confirmed_users&diff=12413025&oldid=12146692

Krenair added a comment.EditedJun 10 2015, 2:13 PM

@Krenair: the stewards bit is not true, though. I'm a steward, and that option was still greyed out for me (on id.wp), but I have that option on meta, though (where I'm not an admin, so it's must be my steward flag)

No, you're not a steward on idwiki: https://id.wikipedia.org/w/index.php?title=Istimewa:Daftar_pengguna&group=steward
You're a global steward. You can use interwiki-userrights from meta because you are in the local steward group on meta. (obviously, you can use this to assign yourself steward on any wiki from meta. This is currently required for performing certain changes) Perhaps this difference seems silly to you but it matters from a technical point of view.

No.

A related question regarding someone who lost their ability to upload and move files (which I suspect is because they lost their autoconfirmed status, and I confirmed that through UserRights special page):

  1. is there a log somewhere that logs when and why a user lost their autoconfirmed (and if not should there be one)? Because I looked again at my faulty filter, and one particular user was not losing her right because of that filter, so I can't answer her as to why she lost her status (since it cannot be done manually by an admin either right?)

Presumably Special:AbuseLog? As far as I know, admins can't revoke it manually.

  1. if indeed the 'confirmed user' is not available in all wikis, is there a way to re-grant (auto)confirmed status to my local wiki (id.wp)?

Community consensus could give legitimacy to a Wikimedia-Site-requests task allowing local idwiki admins to grant the 'confirmed' group to users.

Thanks for the confirmation and T101983, I'll wait for it to be resolved instead.

Does reverting the actions by the abusefilter through [[Special:AbuseFilter/revert/$id]] work?

Krenair added a comment.EditedJun 11 2015, 2:41 PM

Does reverting the actions by the abusefilter through [[Special:AbuseFilter/revert/$id]] work?

Yep, works for me.

Edit: Works because of https://github.com/wikimedia/mediawiki-extensions-AbuseFilter/blob/master/Views/AbuseFilterViewRevert.php#L213 (grep does not necessarily reveal this because of the case of that P)