Page MenuHomePhabricator

Update 'viewsuppressed' permission to allow users holding the right view previous block logs after 'hideuser'
Closed, ResolvedPublic

Description

Not providing here any links due to public bug. However try this scenario.

  • Account A is blocked.
  • Oversighter reblocks later with 'hideuser'
  • All previous blocks on the account dissapear from logs (user block log and special:block snippet).

Best regards.

Event Timeline

MarcoAurelio raised the priority of this task from to Needs Triage.
MarcoAurelio updated the task description. (Show Details)
MarcoAurelio added a subscriber: MarcoAurelio.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 10 2015, 1:45 PM

Update: I set myself oversight rights in the wiki in question. With that flag I can now view those logs. I think we should then figure out which right does allow viewing those blocks and assign them to the steward group, as a view-only right, in line with the current level of permissions we have. It is annoying to be unable to see previous blocks after hidding...

Update 2: Stewards currently have in their global group the "viewsuppressed" permission, which in theory should allow to view suppressed edits and logs, but not to suppress content or logs w/o assigning OS permissions locally. The capacity to see previous block logs before user suppression should be added to this "viewsuppressed" right IMHO.

MarcoAurelio renamed this task from Users blocked with 'hideuser' - Previous block logs lost after hidding to Update 'viewsuppressed' permission to allow users holding the right view previous block logs after 'hideuser'.Jun 10 2015, 1:57 PM
MarcoAurelio set Security to None.

From what I can see, you just need deletedhistory and viewsuppressed to view suppressed logs of previous blocks. Both these rights are assigned to stewards globally so stewards should actually be able to view suppressed logs through Special:Log. In addition, you also need suppressionlog right to view the previous block entries (in addition to hideuser block log entries) when viewing a blocked user through Special:Block.

I was not able to reproduce the issue reported in this bug locally but I did discover another bug which prevents users with viewsuppressed right from seeing the log extract of previous block entries from Special:Block. It's currently coded to just look for suppressrevision (probably an oversight from the split of it to two separate rights).

Could you check again whether you can view the block log entries of normal blocks for suppressed-blocked users through Special:Log without being a local oversighter? If you are not able to see it, then I am probably missing something.

Change 217499 had a related patch set uploaded (by Glaisher):
Allow users with 'viewsuppressed' to view when limitTitle()d

https://gerrit.wikimedia.org/r/217499

Change 217499 merged by jenkins-bot:
Allow users with 'viewsuppressed' to view when limitTitle()d

https://gerrit.wikimedia.org/r/217499

Glaisher closed this task as Resolved.Jun 11 2015, 4:07 PM
Glaisher claimed this task.

I believe you specified a target when checking the logs and this would call LogPager::limitTitle(). As limitTitle() just looked for suppressrevison until the above patch, it wouldn't show the logs of previous blocks when the target is specified. I didn't specify a target when I checked so I wasn't able to reproduce this bug before.

Per above, closing this. Please reopen if you believe the issue is not fixed.

Thank you. Is this change already live? I went ahead to check without local oversight rights and still fail to be able to see:

  • on Special:Block, the previous block log entries (in spite of the system saying "changed block settings")
  • Ídem on the personal block log of the user.

Thanks.

No, it will be live next week. It'll reach Meta-Wiki on next Wednesday. See https://www.mediawiki.org/wiki/MediaWiki_1.26/Roadmap (1.26wmf10)

Krenair added a comment.EditedJun 11 2015, 6:34 PM

Well, it's live on some people's development wikis if they have an up-to-date copy of master, but it won't go to WMF's production wikis until 1.26wmf10: https://www.mediawiki.org/wiki/MediaWiki_1.26/Roadmap

Remember that this is a MediaWiki core-or-extension task, which means it will be resolved and only then will your system administrator(s) eventually get the patch to your wiki, at their own pace.

Restricted Application added a subscriber: Mjbmr. · View Herald TranscriptJun 13 2015, 12:17 AM
Restricted Application edited subscribers, added: StudiesWorld; removed: Mjbmr. · View Herald TranscriptDec 16 2015, 1:21 AM