I'm on IRC with a developer who's seeing wfPHPVersionError():
MediaWiki 1.25 internal error
MediaWiki 1.25 requires at least PHP version 5.3.3, you are using PHP 5.5.21. Installing some external dependencies (e.g. via composer) is also required.
Supported PHP versions
Please consider upgrading your copy of PHP. PHP versions less than 5.3.0 are no longer supported by the PHP Group and will not receive security or bugfix updates.
If for some reason you are unable to upgrade your PHP version, you will need to download an older version of MediaWiki from our website. See our compatibility page for details of which versions are compatible with prior versions of PHP.
MediaWiki now also has some external dependencies that need to be installed via composer or from a separate git repo. Please see mediawiki.org for help on installing the required components.
To reproduce, move vendor/autoload.php out of the way, then browse a wiki page or run php maintenance/eval.php.
- leading with a PHP incompatibility that isn't a problem for most developers is hella confusing.
- if you're running HHVM the PHP download link is irrelevant
- if you downloaded the tarball for 1.25.1, AIUI you *don't* have to run composer, it already has the modules you need and autoloader.php
- the "see mediawiki.org" link is only for people who installed from git; if you downloaded the tarball and don't notice that it puts you halfway down Download_from_Git you'll do the wrong thing.
- Tell the user what specifically went wrong and leave out the other errors.
- Don't point HHVM users to php downloads.
- Detect "You appear to be running from git" before linking to Download_from_git instructions.
The wfEntryPointCheck() in includes/PHPVersionCheck.php should pass an errorcode of the actual problem to wfPHPVersionError() which indexes ASCII and HTML error messages.