Page MenuHomePhabricator

Two x buttons are shown on the search bar in MobileFrontend
Closed, ResolvedPublic

Description

Hi when searching in the search bar in MobileFrontend it shows two x buttons that do the same thing I think we need to keep the x button that has a circle grey background instead of a plain x button. We only need one x button to erase text.

This happends in IE.

Event Timeline

Paladox created this task.Jun 13 2015, 10:22 AM
Paladox raised the priority of this task from to Needs Triage.
Paladox updated the task description. (Show Details)
Paladox added a project: MobileFrontend.
Paladox added subscribers: Paladox, Florian, Jdlrobson.
Restricted Application added a project: Readers-Web-Backlog. · View Herald TranscriptJun 13 2015, 10:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@Paladox: You have been asked many times to follow https://www.mediawiki.org/wiki/How_to_report_a_bug so please do that. Clearly structure any tasks that you create. Avoid any vagueness and ambiguity like in this task again, as no clear steps to reproduce the problem were given, no system information was provided, and no screenshot was given.

Sorry. I try to describe it. but this is not a bug because it isent broken it just shows two buttons that do the same thing.

Hi if you go here https://en.m.wikipedia.org/w/index.php?title=Main_Page&mobileaction=toggle_view_mobile and then in search bar type anything like ma then the search bar searches but to the right you see two buttons they do the same thing we only need one.

Florian closed this task as Invalid.Jun 13 2015, 1:31 PM
Florian claimed this task.

That's intentional: The left button closes the search overlay, while the right button (which only appears, if the search inout has some text) clears the input field without closing the search overlay.

Oh but they do the same thing. and the button doesent close searchoverlay if you mean by search closes. but both clear text and that's all it does..

That's what i see:

If you have a different output, please take a screenshot and upload it here :)

Hi but what about IE. Since IE forces the x button on it. Edge and other browser seem to not do this.

Change 218134 had a related patch set uploaded (by Paladox):
Remove duplicate x button in search bar

https://gerrit.wikimedia.org/r/218134

Paladox updated the task description. (Show Details)Jun 14 2015, 5:31 PM
Paladox set Security to None.

@Paladox a screenshot and exact browser you are encountering this on would help remove all the ambiguity in this bug report.

if you look to the right you see two x buttons ones black the one we doint need and one a light grey. They both do the same thing. so we only need one x button. This problem accures on Internet Explorer 11 not sure about Internet explorer 10.

Florian reopened this task as Open.Jun 14 2015, 6:26 PM

Ok, that's something we can work with ;)

I'm not sure, but we normaly don't support desktop browsers yet, and i have no windows phoen device to test it, maybe someone else can check if that happens for mobile IE, too?

Sorry, but this site only uses a different user agent (maybe) and resizes an iframe, it doesn't emulate a real device. The important question for me (maybe just personally) is, if it makes sense to support a desktop browser in a mobile optimised skin (and that's really a minor thing and a special case on IE (again)).

Jdlrobson moved this task from Backlog to Discussing on the MobileFrontend board.Jun 15 2015, 5:19 PM

Change 218134 merged by jenkins-bot:
Remove duplicate x button in search bar on Microsoft browsers

https://gerrit.wikimedia.org/r/218134

Florian closed this task as Resolved.Jun 19 2015, 5:34 AM
Florian reassigned this task from Florian to Paladox.