Page MenuHomePhabricator

Search and replace button does not work on first click after closing the dialog with Esc or close button.
Open, LowPublic

Description

Steps to reproduce:

  • Load a page with enabled CodeEditor.
  • Click on the Search and replace button. --> The dialog appears.
  • Press Esc on keyboard or click on the close button. --> The dialog disappears.
  • Click on the Search and Replace button again. --> Nothing happens.
  • Click on the Search and Replace button again. --> The dialog appears again.

Expected result:
The dialog should appear on the first click on the button.

Event Timeline

Fomafix raised the priority of this task from to Needs Triage.
Fomafix updated the task description. (Show Details)
Fomafix added a project: CodeEditor.
Fomafix added a subscriber: Fomafix.

Change 218385 had a related patch set uploaded (by Gerrit Patch Uploader):
Repair search button

https://gerrit.wikimedia.org/r/218385

Fomafix triaged this task as Low priority.
Fomafix renamed this task from Search and replace button does not work on first click after closing the dialog with esc. to Search and replace button does not work on first click after closing the dialog with Esc or close button..Sep 15 2017, 5:26 AM
Fomafix updated the task description. (Show Details)

Change 674164 had a related patch set uploaded (by Gerrit Patch Uploader; owner: Nardog):
[mediawiki/extensions/CodeEditor@master] Let search and replace button actually toggle the box

https://gerrit.wikimedia.org/r/674164

This comment was removed by Nardog.

Test wiki on Patch Demo by Nardog using patch(es) linked to this task was deleted:

https://patchdemo.wmflabs.org/wikis/18e359c978/w/

The above link was throwing errors, so I deleted the wiki and tried reinstalling it, but I can't recreate the demo for some reason...

Could someone please review the patch? I have patches for T146393 and T261118 but they kind of rely on this.