Setting non-array attributes in extension.json results in unhelpful error messages
Closed, ResolvedPublic

Description

If you have non-array attributes set, you'll end up with an error like:

[15-Jun-2015 19:18:02] PHP Warning: array_merge_recursive() [<a href='function.array-merge-recursive'>function.array-merge-recursive</a>]: Argument #1 is not an array in D:\\xampp\\htdocs\\shoutwiki\\trunk\\includes\\registration\\ExtensionProcessor.php on line 294

That sucks and is terrible for debugging. We can provide a better error message.

Legoktm created this task.Jun 15 2015, 5:42 PM
Legoktm claimed this task.
Legoktm added subscribers: ashley, Legoktm, Aklapper.
lcawte added a subscriber: lcawte.Jun 15 2015, 9:30 PM
Tgr added a subscriber: Tgr.Jun 16 2015, 10:12 PM

Duplicate of T101978?

Change 218784 had a related patch set uploaded (by Legoktm):
registration: Improve error message if a non-array attribute is set

https://gerrit.wikimedia.org/r/218784

Change 218784 merged by jenkins-bot:
registration: Improve error message if a non-array attribute is set

https://gerrit.wikimedia.org/r/218784

Legoktm closed this task as "Resolved".Jun 25 2015, 8:25 PM