Page MenuHomePhabricator

WARNING: API query (tokens): action=tokens has been deprecated. Please use action=query&meta=tokens instead
Closed, ResolvedPublic

Description


I take this warning when I mark good edit.

Event Timeline

Mavrikant raised the priority of this task from to Needs Triage.
Mavrikant updated the task description. (Show Details)
Mavrikant added a project: Huggle.
Mavrikant added a subscriber: Mavrikant.

Which huggle version is that

Version: 3.1.12 build: 2563 3.1.12-1-ga0be145
without python support, compiled using QT 5.4.1 Running on QT 5.4.1

Petrb claimed this task.

Try in 3.1.13, thanks

Version: 3.1.13 build: 2589 3.1.13 without python support, compiled using QT 5.4.1 Running on QT 5.4.1 (64 bit)
Windows 8.1 64 bit, Trwiki, Turkish

There is no warning message anymore and auto thanks works but not reviewing.


Processes window after marking good edit.


Page history after marking good edit.

Is it normal?

this is wrong, I changed the config https://tr.wikipedia.org/w/index.php?title=Vikipedi:Huggle/Config&diff=15689088&oldid=15644814

However I never had a chance to properly test this feature so maybe it doesn't work in which case reopen this task


New Processes window, still not reviewing contribution.


By the way I realize I can thank same change with both Huggle and browser. This sent 2 notifications.

You are a patroller now. Can you check.

If you start huggle with parameter --qd it will create a file that contain traffic exchanged with servers. In this file you can see the results of API's, could you check this file or send it to me? thanks

I am not sure if I am qualified to do patrolling on your wiki as I don't understand the language very much.


I think you wanna see responses of "api.php?action=review" They are --code="badtoken" info="Invalid token"--.

https://tr.wikipedia.org/wiki/Mavrikant
You can use this page for testing. I'm a technician at trwiki. Sysops wont delete it until I said.

Mavrikant set Security to None.

All works with Version: 3.1.14 build: 2597 3.1.14 without python support, compiled using QT 5.4.1 Running on QT 5.4.1

I am closing this task. Thanks Petrb.