Page MenuHomePhabricator

Decom old multiple-subdomain wikis in wikipedia.org
Closed, ResolvedPublic

Description

In T33335 it looks like these domains in our DNS config were moved to single-sub names:

; Old double-subdomain aliases (bug 31335)
arbcom.de               600     IN DYNA         geoip!text-addrs
arbcom.en               600     IN DYNA         geoip!text-addrs
arbcom.fi               600     IN DYNA         geoip!text-addrs
arbcom.nl               600     IN DYNA         geoip!text-addrs
wg.en                   600     IN DYNA         geoip!text-addrs

It looks to me like wgCanonicalServer for these moved back in Apr 2014 in https://gerrit.wikimedia.org/r/#/c/121709/ , and the DNS updates were of course even earlier than that. Can we now decom the actual legacy hostnames out of DNS and the apache redirects? I'm trying to audit insecure redirects that we don't have matching certs for at this point, and these seem like easy candidates for removal.

Event Timeline

BBlack created this task.Jun 17 2015, 2:46 PM
BBlack raised the priority of this task from to Needs Triage.
BBlack updated the task description. (Show Details)
BBlack added projects: HTTPS, Traffic, acl*sre-team.
BBlack added subscribers: BBlack, Reedy.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 17 2015, 2:46 PM
BBlack renamed this task from Decom old multiple-subdomain wikis to Decom old multiple-subdomain wikis in wikipedia.org.Jun 17 2015, 3:19 PM
BBlack set Security to None.
Reedy added a comment.Jun 29 2015, 8:47 PM

Do we have any DNS or varnish/apache stats of hits to these URLs?

Presumably they're still not needed, but I honestly couldn't tell you the amount of people still using the old redirects.

Due to the nature of the wikis, at worst, we could just email all the users of them to inform them that the old urls are going to stop working, so if they still have any bookmarks (the 90s called), to update them...

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJun 29 2015, 8:47 PM
faidon added a subscriber: faidon.Jul 6 2015, 5:45 PM
faidon@oxygen:~$ egrep '(arbcom|wg.en)' per-domain-count 
    134 "arbcom-de.wikipedia.org"
    100 "arbcom-nl.wikipedia.org"
     74 "arbcom-en.wikipedia.org"
     10 "wg-en.wikipedia.org"
      5 "arbcom-fi.wikipedia.org"
      5 "arbcom.en.wikipedia.org"
      1 "wg.en.wikipedia.org"
      1 "arbcom.fi.wikipedia.org"
      1 "arbcom.de.wikipedia.org"
Reedy added a comment.Jul 6 2015, 6:48 PM
faidon@oxygen:~$ egrep '(arbcom|wg.en)' per-domain-count 
    134 "arbcom-de.wikipedia.org"
    100 "arbcom-nl.wikipedia.org"
     74 "arbcom-en.wikipedia.org"
     10 "wg-en.wikipedia.org"
      5 "arbcom-fi.wikipedia.org"
      5 "arbcom.en.wikipedia.org"
      1 "wg.en.wikipedia.org"
      1 "arbcom.fi.wikipedia.org"
      1 "arbcom.de.wikipedia.org"

Thanks @faidon. Is there a time period as to when those hits were made? It would seem arbcom-(de|nl|en) are the main ones to worry about notifying...

It would seem arbcom-(de|nl|en) are the main ones to worry about notifying...

No need to worry about these. arbcom-(de|nl|en).wikipedia.org can be covered by the certificate (*.wikipedia.org). Probably the 5 hits for arbcom.en.wikipedia.org is worrisome, since about 6.8% arbcom-en requests were made to arbcom.en first. Notifying English Arbitration Committee is easy anyway, maybe by emailing their mailing list: https://lists.wikimedia.org/mailman/listinfo/arbcom-l.

Right, there's no real cert issue for any of these, it's just a matter of notifications.

Change 224309 had a related patch set uploaded (by Chmarkine):
Remove old double-subdomain aliases

https://gerrit.wikimedia.org/r/224309

Might be worth looping in @Philippe-WMF and/or @Jalexander as they should have contacts within those communities

And then we need a patch to the apache config to remove the old redirects/rewrites :)

BBlack triaged this task as Normal priority.Jul 13 2015, 6:43 PM
BBlack moved this task from Triage to Up Next on the Traffic board.Jul 13 2015, 7:04 PM

Have these communities been notified yet?

no; will do tonight.

They're notified. :)

Confirmed. Arbcom-en has been notified.

Reedy added a comment.Jul 25 2015, 2:19 AM

They're notified. :)

Woo, thanks!

Out of interest, what exactly did you tell them? Just wondering so we can plan to remove these domains in X time etc

We told them we'd remove it soon :) specifically no time frame. I would wait until Monday or Tuesday to ensure they've had a chance to see it but no real reason to wait much longer.

Reedy added a comment.Jul 25 2015, 5:12 PM

We told them we'd remove it soon :) specifically no time frame. I would wait until Monday or Tuesday to ensure they've had a chance to see it but no real reason to wait much longer.

Sounds like a plan. Wait a few days, get ops to check again for requests for it, and then proceeed to cleanup. Yay

The English Wikipedia Arbitration Committee moved from arbcom.en.wikipedia.org to arbcom-en.wikipedia.org (see T33335). As long as the new hostname continues to work (the one that isn't a subdomain of en.wikipedia.org), we're fine with the move.

Jalexander added a comment.EditedJul 26 2015, 12:14 AM

The English Wikipedia Arbitration Committee moved from arbcom.en.wikipedia.org to arbcom-en.wikipedia.org (see T33335). As long as the new hostname continues to work (the one that isn't a subdomain of en.wikipedia.org), we're fine with the move.

Yeah, these are just redirects from the old names that would cost quite a lot of money to actually support fully because of the ssl certs etc.

Change 227172 had a related patch set uploaded (by Reedy):
Remove multiple subdomain wiki rewrites

https://gerrit.wikimedia.org/r/227172

# renamed chapter wiki - T40763
rewrite pa.us.wikimedia.org     //pa-us.wikimedia.org

# arbcom
rewrite arbcom.de.wikipedia.org https://arbcom-de.wikipedia.org
rewrite arbcom.en.wikipedia.org https://arbcom-en.wikipedia.org
rewrite arbcom.fi.wikipedia.org https://arbcom-fi.wikipedia.org
rewrite arbcom.nl.wikipedia.org https://arbcom-nl.wikipedia.org

rewrite noboard.chapters.wikimedia.org  //noboard-chapters.wikimedia.org

rewrite wg.en.wikipedia.org     //wg-en.wikipedia.org

noboards.chapters.wikimedia.org is already NXDOMAIN so removed in the apache patch above

pa.us.wikimedia.org needs to die also... @faidon can you check traffic/hits for that domain too?

Change 227173 had a related patch set uploaded (by Reedy):
Kill pa.us.wikimedia.org from dns

https://gerrit.wikimedia.org/r/227173

Just noting at https://meta.wikimedia.org/wiki/Wikimedia_Pennsylvania has
the pa.wikimedia address listed...I'l reach out, but it appears the chapter
has gone dormant.


Philippe Beaudette
Director, Community Advocacy
Wikimedia Foundation, Inc.

415-839-6885, x 6643

philippe@wikimedia.org

The pa.us issue is in wikiMedia.org, which has a separate ticket here: T102826
This ticket is just tracking wikiPedia.org, which just has the 5x records listed at the top of this thread (the 4x arbcoms + wg.en)

Change 227214 had a related patch set uploaded (by BBlack):
Remove multi-level subdomains from wikipedia.org

https://gerrit.wikimedia.org/r/227214

^ will merge the above tomorrow (Tues).

Change 224309 abandoned by Chmarkine:
Remove old double-subdomain aliases

Reason:
Done in I539c46cb.

https://gerrit.wikimedia.org/r/224309

@Chmarkine - Sorry! I thought I looked here before uploading that new patch, or else I would've just used yours. I forgot it was out there pending already.

Change 227214 merged by BBlack:
Remove multi-level subdomains from wikipedia.org

https://gerrit.wikimedia.org/r/227214

BBlack closed this task as Resolved.Jul 28 2015, 2:55 PM
BBlack claimed this task.
BBlack moved this task from In Progress to Done on the Traffic board.
Reedy added a comment.Jul 29 2015, 3:49 AM

https://gerrit.wikimedia.org/r/#/c/227172/ wants updating to not remove the the pa.us rewrites, but then needs merging and deploying, otherwise we're keeping cruft around :)

Change 227172 merged by BBlack:
Remove multiple subdomain wiki rewrites from wikipedia.org

https://gerrit.wikimedia.org/r/227172

Change 228025 had a related patch set uploaded (by BBlack):
update iswiki for wg-en

https://gerrit.wikimedia.org/r/228025

Change 228025 merged by jenkins-bot:
update iswiki for wg-en

https://gerrit.wikimedia.org/r/228025

Change 227173 abandoned by BBlack:
Kill pa.us.wikimedia.org from dns

Reason:
already gone!

https://gerrit.wikimedia.org/r/227173