Page MenuHomePhabricator

Disable patrolling on de.wikipedia
Closed, DeclinedPublic

Description

As a follow-up of T100682, a solution if the de. local community doesn't use the patrol features at all is to set $wgUseNPPatrol, $wgUseFilePatrol and $wgUseRCPatrol to false to disable patrolling.

Could you discuss the idea?

Event Timeline

Dereckson raised the priority of this task from to Low.
Dereckson updated the task description. (Show Details)
Dereckson moved this task to Backlog on the Wikimedia-Site-requests board.
Dereckson added a subscriber: Dereckson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 17 2015, 3:06 PM
Glaisher closed this task as Invalid.Jun 17 2015, 4:01 PM
Glaisher claimed this task.
Glaisher added a subscriber: Glaisher.

Please create new tasks once it's discussed by the community. Feel free to reopen if needed in the future.

MGChecker reopened this task as Open.Jun 17 2015, 7:15 PM

I don't see anyting here that has to be discussed by community, because patrolluing in dewiki is s bug, and not a feature, because we don't use patrol at all. But sometimes pages and revisions are patroled by reviewing, although nobosy wants sthis, because it's only spamming into the log.

Because this request is only tehniccally, ther shouldn't be a community consensus needed. By the way, I thought if a task needs community consensus, it is marked as stalled instead of being closed?

MGChecker renamed this task from Disable new pages patrolling on de.wikipedia to Disable patrolling on de.wikipedia.Jun 17 2015, 8:24 PM
MGChecker set Security to None.
Luke081515 added a comment.EditedJun 18 2015, 11:38 AM

The partolling on dewiki is not possible for users, the patrolllink is disabled by the common.css since years. So the only thing you see on dewiki is autopatrol, which just floods the logs.

Wondering why a feature which isn't used needs consensus to be removed...

That'ts true, but it seems that autopatrol is included in autoreview, because there are also automatic patrolled revisions from users, who haven't got autopatrol: https://de.wikipedia.org/w/index.php?title=Spezial:Logbuch&type=patrol

Ah, makes sense to do this then. Thanks for the explanation. I didn't realize that this wasn't used on German Wikipedia.

MGChecker updated the task description. (Show Details)Jun 18 2015, 11:55 AM

I remember something, but I'm not sure if it's correct: Was there any bug that after disabling patrolling completely, that patrol log entries can't be hidden anymore?

I think the main question behind this is: Does the right patrolmarks still work after disabling patrolling?

Stryn added a subscriber: Stryn.Jun 18 2015, 3:13 PM
Glaisher removed Glaisher as the assignee of this task.Jul 1 2015, 5:52 AM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptJul 1 2015, 5:52 AM

I remember something, but I'm not sure if it's correct: Was there any bug that after disabling patrolling completely, that patrol log entries can't be hidden anymore?
I think the main question behind this is: Does the right patrolmarks still work after disabling patrolling?

@Cenarium: Do you know?

The problem isn't the community consensus, because the request is only technically and doesn't really change anything for the users.

I remember something, but I'm not sure if it's correct: Was there any bug that after disabling patrolling completely, that patrol log entries can't be hidden anymore?
I think the main question behind this is: Does the right patrolmarks still work after disabling patrolling?

@Cenarium: Do you know?

It's T44246.

Note that file patrol is now possible. FlaggedRevs is also enabled for files, I see. So I suppose you would also like $wgUseFilePatrol set to false.

The flood problem remains though.

Restricted Application added a subscriber: JEumerus. · View Herald TranscriptJan 24 2016, 9:26 PM
Dereckson updated the task description. (Show Details)Jan 26 2016, 4:55 AM

Is this still wanted/required? An update would be good. Thanks.

Urbanecm closed this task as Declined.Apr 23 2018, 11:55 AM
Urbanecm added a subscriber: Urbanecm.

Mass-declining of all old "Blocked on community consensus" site request tasks. If this is still wanted, please make sure community consensus was reached and if so, please re-open this task and link to the discussion.