Page MenuHomePhabricator

"Mark as resolved" browser tests
Closed, ResolvedPublic

Description

  • remove lock/unlock browser tests
  • add "mark as resolved"/reopen browser tests

Event Timeline

SBisson created this task.Jun 17 2015, 4:26 PM
SBisson claimed this task.
SBisson raised the priority of this task from to Normal.
SBisson updated the task description. (Show Details)
SBisson added a subscriber: SBisson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 17 2015, 4:26 PM

Change 219466 had a related patch set uploaded (by Sbisson):
Browser tests for "mark as resolved" and "reopen"

https://gerrit.wikimedia.org/r/219466

Change 219466 merged by jenkins-bot:
Browser tests for "mark as resolved" and "reopen"

https://gerrit.wikimedia.org/r/219466

  1. I see failures on e.g. https://integration.wikimedia.org/ci/view/BrowserTests/view/Echo+Flow/job/browsertests-Flow-en.wikipedia.beta.wmflabs.org-linux-chrome-sauce/681/console with reference to the step
And I summarize as "the answer is 42"                            # features/step_definitions/resolve_reopen_steps.rb:88
20:46:29       undefined method `clear'

I did some local re-run with commenting out the problematic method:
47 # page.edit_summary_element.when_present.clear in features/step_definitions/resolve_reopen_steps.rb

The test is passing:

etonkovidova@AdminisrsAir115:~/Documents/gerrit/Flow/tests/browser$ bundle exec cucumber features/mark_topic_as_resolved.feature:16

Feature: Mark topic as resolved

  Background:                       # features/mark_topic_as_resolved.feature:6
    Given I am logged in            # mediawiki_selenium-0.4.2/lib/mediawiki_selenium/step_definitions/login_steps.rb:12
    And I am on Flow page           # features/step_definitions/flow_steps.rb:5
    And I have created a Flow topic # features/step_definitions/flow_steps.rb:12

  Scenario: Resolving a topic and adding a summary                   # features/mark_topic_as_resolved.feature:16
    When I mark the first topic as resolved                          # features/step_definitions/resolve_reopen_steps.rb:2
    And I summarize as "the answer is 42"                            # features/step_definitions/resolve_reopen_steps.rb:89
    Then the first topic is resolved with summary "the answer is 42" # features/step_definitions/resolve_reopen_steps.rb:78

1 scenario (1 passed)
6 steps (6 passed)
1m11.636s
  1. The second problematic test that complains about "undefined method `clear'" in features/step_definitions/resolve_reopen_steps.rb
Scenario: Resolving a topic and updating the summary                     # features/mark_topic_as_resolved.feature:27
    Given I summarize the first topic as "this answer should be changed"   # features/step_definitions/resolve_reopen_steps.rb:83
      undefined method `clear' ...

goes farther with commented out

47 #    page.edit_summary_element.when_present.clear 

still failing though:

Scenario: Resolving a topic and updating the summary # features/mark_topic_as_resolved.feature:27

Given I summarize the first topic as "this answer should be changed"   # features/step_definitions/resolve_reopen_steps.rb:83
  timed out after 5 seconds, waiting for {:index=>0, :tag_name=>"textarea"} to become present

#clear was implemented for VE here: https://gerrit.wikimedia.org/r/#/c/220820/
It's just waiting to be merged.

For the timeout error, VE just takes forever to load. Other than increasing the timeout (which is a slippery slope) I don't know what can be done.

To summarize:

remove lock/unlock browser tests

Checked-Done.

add "mark as resolved"/reopen browser tests

I looked at some stats at https://integration.wikimedia.org/ci/view/BrowserTests/view/Echo+Flow/ - there are five projects for Flow browser testing. I listed the results for the most recent builds. for feature tests "Mark topic as resolved".

ProjectName of testResults
browsertests-Flow-en.wikipedia.beta.wmflabs.org-windows_8-internet_explorer-10-sauceMark topic as resolved. Resolving a topic and adding a summary Build #100 (Jul 14, 2015 9:46:01 PM)fails -but there is no succesfull build since build #69
browsertests-Flow-en.wikipedia.beta.wmflabs.org-linux-firefox-sauceMark topic as resolved. Resolving a topic and keeping the summary Build #734 (Jul 14, 2015 10:11:01 PM)fails - Regression
browsertests-Flow-en.wikipedia.beta.wmflabs.org-linux-chrome-sauceRegression Mark topic as resolved.Resolving a topic and keeping the summary Build #700 (Jul 14, 2015 8:26:01 PM)fails- Regression
browsertests-Flow-en.wikipedia.beta.wmflabs.org-linux-chrome-monobook-sauceBuild #497 (Jul 15, 2015 9:21:01 AM) - Feature: Mark topic as resolved passedpassed
browsertests-Flow-en.wikipedia.beta.wmflabs.org-linux-firefox-monobook-sauceBuild #505 (Jul 15, 2015 6:25:01 AM) - Feature: Mark topic as resolved passedpassed

Should we close this ticket and treat the current fails as a separate issue, e.g. a part of general workflow for browser testing?

DannyH closed this task as Resolved.Jul 15 2015, 10:40 PM
DannyH added a subscriber: DannyH.