Page MenuHomePhabricator

Add Discovery team members (employees) to #wmf-nda
Closed, ResolvedPublic

Description

Please add the following foundation employees in the Discovery department to the WMF-NDA project (and apologies if any are already in):

@ksmith
@Deskana
@EBernhardson
@MSyed
@Jdouglas
@Wwes

Per an IRC conversation, it seems reasonable to do this bulk request, rather than waiting until we are in an emergency situation and have to wait/rush the process to get added.

Event Timeline

ksmith updated the task description. (Show Details)
ksmith raised the priority of this task from to Needs Triage.
ksmith added a project: WMF-NDA-Requests.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2015, 4:20 PM

@EBernhardson, @Westonnh and @Jdouglas are not linked to (WMF) accounts (and @Westonnh is not activated?)

I think was Krenair is trying to say is go to https://phabricator.wikimedia.org/settings/panel/external/ and setup the external 'MediaWiki' account

and setup the external 'MediaWiki' account

Done.

I think was Krenair is trying to say is go to https://phabricator.wikimedia.org/settings/panel/external/ and setup the external 'MediaWiki' account

Yep. Or change an existing non-WMF account link to a (WMF)/-WMF one. So that just leaves @Westonnh?

Qgil added subscribers: Jalexander, Qgil.EditedJun 21 2015, 8:27 PM

@Jalexander, do you mind checking whether @Westonnh has a WMF SUL account, please?

@Jalexander, do you mind checking whether @Westonnh has a WMF SUL account, please?

Yeah, I can confirm that's Wes with a work account of WMoran (WMF). It looks like he created it himself rather then OIT but both accounts are registered and confirmed to his work email and I know that he has signed an NDA in the process of employment.

Qgil added a comment.Jun 22 2015, 10:30 AM

@ksmith, can you ask Wes to confirm his Phabricator account and link it to his Wikimedia SUL profile?

The rest of users listed in the description look good to me (and imho someone with the permissions could add them already to WMF-NDA).

Wwes updated the task description. (Show Details)Jun 22 2015, 4:00 PM
Wwes set Security to None.
Wwes added a subscriber: Wwes.

So is @Wwes going into WMF-NDA instead of @Westonnh ? Not sure it makes sense to have both unless you also happen to have signed the volunteer NDA, which I doubt.

@Wwes is the official one.

Wwes updated the task description. (Show Details)Jun 22 2015, 5:19 PM
Wwes removed a subscriber: Westonnh.
Qgil added a comment.Jun 22 2015, 6:28 PM

@Wwes looks good to me, and imho the six users listed in the description are good to go.

@Krenair? Can you (or someone) go ahead and make this change? We had a meeting this morning were the lack of access caused us some problems. Thanks!

ksmith added a subscriber: Joe.Jul 2 2015, 10:26 PM

@Joe: Can you take care of this for us?

Qgil triaged this task as Normal priority.Jul 3 2015, 9:49 AM
Qgil assigned this task to Aklapper.Jul 3 2015, 9:56 AM
Aklapper closed this task as Resolved.Jul 6 2015, 11:47 AM

As per last comments I have added those six accounts.

(On a general note, I'd welcome documented requirements to perform account verification properly to avoid bottlenecks here - currently there is only documentation for users requesting access but not for people granting access.)