Page MenuHomePhabricator

Scripts in mediawiki/tools/grabbers are not compatible with new API continuation mode
Closed, ResolvedPublic

Description

There are several occurrences of "query-continue" throughout the repo, but none of "rawcontinue".
This probably means that the scripts will be broken soon.

Event Timeline

Ricordisamoa raised the priority of this task from to Needs Triage.
Ricordisamoa updated the task description. (Show Details)
Ricordisamoa added a subscriber: Ricordisamoa.

Even though the target wikis are less likely to be up-to-date (a common reason for needing to jump hosts in such a drastic manner in the first place) than most, we should still actually fix this at some point. Yes. Kind of important.

Aklapper lowered the priority of this task from High to Medium.Sep 29 2015, 10:26 AM

...I like how we still haven't bothered to fix this because the maintainers have yet to actually have to deal with a wiki above 1.21. >.>

Um.