Page MenuHomePhabricator

[Bug] Dates with “month” precision are offset by one month on Wikipedia
Closed, ResolvedPublic

Description

For example, compare South Pole Telescope (Q1513315) with South Pole Telescope (enwiki).
On Wikidata, the construction time (qualifiers of statement “significant event: construction”) is November 2006–February 2007; in the Wikipedia template, which gets its data from Wikidata, it is instead October 2006–January 2007.
In general, the date on Wikipedia appears to always be one month before the date on Wikidata; it even rolls over the turn of the year correctly (January 2007 → December 2006).
You can also reproduce this on the Sandbox (Q4115189 / Wikipedia:Wikidata/Wikidata Sandbox) by adding a statement “significant event (P​793): construction (Q385378)” with start time (P​580) and/or end time (P​582) qualifiers to the sandbox item, and adding {{Infobox telescope}} to the sandbox article.
This only happens for times with precision “month”; both date and year work fine.

I think this issue is part of T87764, but I’m probably not allowed to set that.

See also T107870: Illegal dates in date type

PS: What’s the usual way to prevent autolinking of Wikidata property numbers P​123 to Phabricator pastes? I put a zero-width space between the P and the number, but that’s not very convenient :)

Event Timeline

DSGalaktos raised the priority of this task from to Needs Triage.
DSGalaktos updated the task description. (Show Details)
DSGalaktos added a project: Wikidata.
DSGalaktos added a subscriber: DSGalaktos.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 22 2015, 4:40 PM
daniel added a subscriber: daniel.EditedSep 10 2015, 1:21 PM

The cause for this is the fact that we store month precision dates using the form 2015-09-00 (and year precision as 2015-00-00). We should strip any 00 month or days from the date string before exposing it to Lua.

We should also re-think how we store dates internally. But for now, it's important to fix this for use with the standard date formatting functions in Lua.

daniel triaged this task as High priority.Sep 10 2015, 1:25 PM

Bumping to high prio: this causes wrong dates to be shown on client wikis.

daniel updated the task description. (Show Details)Sep 10 2015, 1:30 PM
daniel set Security to None.
Jonas renamed this task from Dates with “month” precision are offset by one month on Wikipedia to [Bug] Dates with “month” precision are offset by one month on Wikipedia.Nov 2 2015, 11:45 AM
thiemowmde closed this task as Resolved.Apr 4 2016, 10:43 AM
thiemowmde claimed this task.
thiemowmde added a subscriber: thiemowmde.

This was a bug in https://en.wikipedia.org/wiki/Module:Wikidata which seems to be fixed now.

Note that https://en.wikipedia.org/wiki/Template:Infobox_telescope currently uses https://en.wikipedia.org/wiki/Template:Start_date in an odd, actually wrong way.