Page MenuHomePhabricator

Support fragments in getUrl() of mw.Title
Closed, ResolvedPublic

Description

Currently getUrl() of mw.Title does not support fragments.

new mw.Title( 'Title Ä#Fragment Ä' ).getUrl( { useskin: 'vector' } )

evaluates to /wiki/Title_%C3%84?useskin=vector.

Expected result: /wiki/Title_%C3%84?useskin=vector#Fragment_.C3.A4

Event Timeline

Fomafix created this task.Jun 24 2015, 5:21 PM
Fomafix raised the priority of this task from to Needs Triage.
Fomafix updated the task description. (Show Details)
Fomafix added a subscriber: Fomafix.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 24 2015, 5:21 PM

I am new to mediawiki. Can you tell me how can I test this bug?

Can you tell me how can I test this bug?

Hi @Saptak013, thanks for your interest in contributing! The task description describes steps to reproduce and expectations.
For general information how to test, please see How to become a MediaWiki hacker.
If you have specific questions about this task, please don't hesitate to ask in this task! Thanks!

matmarex added a subscriber: matmarex.

I'm going to propose (and mentor) this as a task for Google-Code-In-2015.

matmarex triaged this task as Normal priority.Oct 27 2015, 9:51 PM

Since the blocking task was completed, could this task get published @Aklapper? Thanks.

Claimed this on GCI.

Change 261171 had a related patch set uploaded (by Unicornisaurous):
Support fragments in getUrl() of mw.Title

https://gerrit.wikimedia.org/r/261171

matmarex closed this task as Resolved.Dec 28 2015, 6:06 PM
matmarex removed a project: Patch-For-Review.
matmarex set Security to None.

Change 261171 merged by jenkins-bot:
Support fragments in getUrl() of mw.Title

https://gerrit.wikimedia.org/r/261171