Page MenuHomePhabricator

Category widget wrongly claims category has no description page
Closed, ResolvedPublic1 Story Points

Description

User-Agent: Google Chrome on Mac.

  1. Edit page on www.mediawiki.org
  2. Page options -> Categories.
  3. Paste "Category:WMF Projects" in input field.
  4. Select "WMF Projects"

Expected:
Blue link.

Actual:
Red link with caption "This category lacks a description page."

Event Timeline

Krinkle created this task.Jun 25 2015, 2:14 AM
Krinkle updated the task description. (Show Details)
Krinkle raised the priority of this task from to Needs Triage.
Krinkle added a subscriber: Krinkle.
Restricted Application added a project: VisualEditor. · View Herald TranscriptJun 25 2015, 2:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Krinkle updated the task description. (Show Details)Jun 25 2015, 2:16 AM
Krinkle set Security to None.

Note that the input field takes values both with and without a "Category:" prefix. Both work produce the expected result in the edit, but when omitting the prefix and typing the category manually, it does work as expected and the bug does not occur.

It seems we consistently normalise it in the data model, but forget it in the UI.

Change 220935 had a related patch set uploaded (by Alex Monk):
Get rid of Category: prefix when looking up categories from the API

https://gerrit.wikimedia.org/r/220935

Jdforrester-WMF closed this task as Resolved.Jun 26 2015, 3:33 PM
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF assigned this task to Krenair.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from Nominated to Done on the VisualEditor 2014/15 Q4 blockers board.

Change 220935 merged by jenkins-bot:
Get rid of Category: prefix when looking up categories from the API

https://gerrit.wikimedia.org/r/220935