Page MenuHomePhabricator

Remove "select all" and "web search" buttons from CAB when highlighting text.
Closed, ResolvedPublic

Description

The "select all" and "web search" buttons are confusing and/or unnecessary. We should remove them from the CAB when highlighting text in the WebView.

old description:

The "web search" option presented after highlight text is confusing. I'm in the Wikipedia app, is web search internal? Here are some alternative ideas for discussion:

  1. In-app Google search of some kind?
  2. Move under share and possibly rename share?
  3. Remove?

Event Timeline

Niedzielski raised the priority of this task from to Needs Triage.
Niedzielski updated the task description. (Show Details)
Niedzielski added a subscriber: Niedzielski.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2015, 2:33 AM
Dbrant added a subscriber: Dbrant.Jun 26 2015, 2:40 AM

This feels like the perfect interaction for presenting a Wiktionary definition of the word inside a "preview" card, much like the Kindle app does. Once we implement something like that, we can safely remove the "web search" option.

Until then, perhaps another possibility might be to rename it to just "Search", and pass the highlighted text into our own Search field.

Dbrant triaged this task as High priority.Jul 1 2015, 3:34 PM
MBinder_WMF edited a custom field.Jul 31 2015, 5:45 PM
Dbrant renamed this task from Web search option in contextual toolbar is confusing to Remove "select all" and "web search" buttons from CAB when highlighting text..Jul 31 2015, 5:48 PM
Dbrant updated the task description. (Show Details)
Dbrant edited a custom field.
Mholloway claimed this task.Aug 3 2015, 2:06 PM

Change 228857 had a related patch set uploaded (by Mholloway):
Hide "select all" and "web search" contextual action bar items

https://gerrit.wikimedia.org/r/228857

For the record, I actually find the web search feature useful in principle, but the patch removes both items as specified.

bearND added a subscriber: bearND.Aug 3 2015, 6:00 PM

I vote for keeping the search since I use it occasionally. I don't mind it going to the browser. But removing "Select all" sounds good.

How about making search paste the highlighted text in the Wikipedia app search bar?

The use cases that I can see justifying web search as is are when I want current events-type information about a given term, or want to see what other kinds of content are out there on the web about that term. Say, for instance, I'm reading the article on Donald Trump and see the former name of his firm, Elizabeth Trump & Son, and want to see what Google turns up for it. This can currently be done from the CAB, but after this patch becomes much more difficult. Or maybe I just want to see the latest headlines on the Donald -- the same applies. In both cases, I'm after distinctly different kinds of content than what I would get from running the equivalent search in Wikipedia.

There's an argument (that I'm less than comfortable with) for taking out web search for the sake of encouraging continued engagement with the app itself, but I think that's a different issue.

Change 228857 merged by jenkins-bot:
Hide the "select all" and "web search" CAB menu items

https://gerrit.wikimedia.org/r/228857

Kindly add a screenshot, can't see any change in latest alpha

@Vibhabamba here's a screenshot. Check again with the latest alpha build?

Vibhabamba added a comment.EditedAug 13 2015, 11:12 PM

In the left to right order - do you think Share can appear before Copy?
Any issues with saying

Share > Copy > Overflow Menu

Rationale: Most important actions appear first in the LTR order

Vibhabamba added a comment.EditedAug 14 2015, 9:41 PM

Dbrant said that the switch will be complex since these are system actions. Signed off by design in its current state.

Checked with 2.0.108-alpha-2015-08-19 on Nexus5(Android 5.1)

Notice that in landscape position, Copy and Share icons are displayed with their titles.

Dbrant closed this task as Resolved.Sep 2 2015, 4:38 PM