Page MenuHomePhabricator

Login-needed text isn't displayed for all newsletter-pages
Closed, ResolvedPublic

Description

The referenced warning that login is needed doesn't show up for me for Special:NewsletterCreate and Special:NewsletterManage

Although for Special:Newsletters a (different) notice is displayed:

Probably also shouldn't be 2 different messages where requiredlogintext (defined by newsletter extension) basically duplicates the other.

Event Timeline

Se4598 created this task.Jun 28 2015, 10:34 AM
Se4598 raised the priority of this task from to Needs Triage.
Se4598 updated the task description. (Show Details)
Se4598 added subscribers: Se4598, Tinaj1234.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 28 2015, 10:34 AM

That's strange. For the first two SpecialPage code, we have ( https://github.com/wikimedia/mediawiki-extensions-Newsletter/blob/master/includes/SpecialNewsletterCreate.php#L14 )

$this->requireLogin( 'requiredlogintext' );

which never shows up in labs, and for the Special:Newsletter which showed up a message, the message-param was not given ( https://github.com/wikimedia/mediawiki-extensions-Newsletter/blob/master/includes/SpecialNewsletters.php#L13 )

$this->requireLogin();

Change 221441 had a related patch set uploaded (by Tinaj1234):
Remove unnecessary parameter passed to requireLogin()

https://gerrit.wikimedia.org/r/221441

Change 221441 merged by jenkins-bot:
Remove unnecessary parameter passed to requireLogin()

https://gerrit.wikimedia.org/r/221441

Se4598 closed this task as Resolved.Jun 28 2015, 12:10 PM