Page MenuHomePhabricator

Fix "PHP Warning: array_merge_recursive(): Argument #1 is not an array in ExtensionProcessor.php:294"
Closed, DuplicatePublic

Description

Seems related to a1368a3d9bb not being in REL1_25.

<b>Warning</b>: array_merge_recursive(): Argument #1 is not an array in <b>mw/includes/registration/ExtensionProcessor.php</b> on line <b>294</b><br />

Seems related to the fact that some extension.json files (e.g. HitCounters and others) have a manifest_version property that is new in 1.26alpha and not part of the 1.25 release.

Event Timeline

Krinkle created this task.Jun 29 2015, 8:50 AM
Krinkle raised the priority of this task from to Needs Triage.
Krinkle updated the task description. (Show Details)
Krinkle added subscribers: Krinkle, Legoktm, MarkAHershberger.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 29 2015, 8:50 AM
Vedmaka added a subscriber: Vedmaka.