Page MenuHomePhabricator

Goal: Define Wikimedia Developer Summit 2016
Closed, ResolvedPublic

Description

Things to think about:

  • What will be different about the WMDS in 2016?
  • Who will be invited? Who will not?
  • Will it be optional for WMF Engineering?
  • How many and which 3rd party developers?
  • How many and which engineering community members?
  • New tracks?

ECT and EMGT will need to work together figure out event focus and how to make the event useful, worthwhile and impactful.

How do we ensure people who attend have a plan to contribute and add value back into the event. Many people at last years event did not run sessions or contribute to discussions but instead were head down on laptops throughout the entire event. Is this OK? Could those people join remotely instead?

We also need to define and contract social events, meals and transportation plans.

What event support is needed?

External keynotes?

Widen or narrow focus of event?

IMPORTANT: this is a draft. Topics and dates may change.

Schedule

  • 14 Sep 2015: Announcement, main themes, open registration, call for participation.
  • 2 Oct 2015: Application deadline for keynotes, RFCs, main room sessions, and tracks.
  • 6 Nov 2015: Initial agenda.
  • 4 Dec 2015: RFCs and main room schedule freeze. Schedule for breakout rooms remains open and self-managed.
  • 4-6 Jan 2015: Wikimedia Developer Summit in San Francisco.

Event Timeline

Rfarrand created this task.Jun 30 2015, 3:59 PM
Rfarrand claimed this task.
Rfarrand raised the priority of this task from to Normal.
Rfarrand updated the task description. (Show Details)
Rfarrand added a subscriber: Rfarrand.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 30 2015, 3:59 PM
Rfarrand updated the task description. (Show Details)Jul 1 2015, 11:14 AM
Rfarrand set Security to None.
Rfarrand added a subscriber: Qgil.
Qgil renamed this task from Define Mediawiki Developers Summit 2016 to Goal: Define Mediawiki Developers Summit 2016.Jul 1 2015, 2:34 PM
Qgil added a comment.Jul 1 2015, 2:37 PM

First of all, I want to propose a change of name to "Wikimedia Developer Summit". The reason being that the scope are all Wikimedia technologies, and "MediaWiki" is too restrictive. Besides, even if the popular brand is "Wikipedia", I think "Wikimedia" will help us better than "MediaWiki" promoting this event among third party developers.

I'm not sure whether it is enough to discuss this here o in a specific subtask.

Qgil renamed this task from Goal: Define Mediawiki Developers Summit 2016 to Goal: Define Wikimedia Developer Summit 2016.Aug 19 2015, 6:06 PM
Rfarrand moved this task from Backlog to Doing on the ECT-August-2015 board.Sep 1 2015, 4:03 PM
Rfarrand moved this task from Backlog to Need Discussion on the DevRel-September-2015 board.
Rfarrand raised the priority of this task from Normal to High.Sep 1 2015, 10:31 PM
Krenair added a subscriber: Krenair.

First of all, I want to propose a change of name to "Wikimedia Developer Summit". The reason being that the scope are all Wikimedia technologies, and "MediaWiki" is too restrictive. Besides, even if the popular brand is "Wikipedia", I think "Wikimedia" will help us better than "MediaWiki" promoting this event among third party developers.
I'm not sure whether it is enough to discuss this here o in a specific subtask.

T111308: Truly rename MediaWiki Developer Summit to Wikimedia Developer Summit was created for this.

@Krenair, thanks! Yup, I also filed T111306: Recruit event scout for November IETF meeting in preparation for #WikiDev16, because I think we can learn a thing or two about how to structure our meetings from how the IETF structures theirs. I'll comment more in T109612: Define main themes of the Wikimedia Developer Summit 2016 later.

Qgil updated the task description. (Show Details)Sep 3 2015, 7:59 AM
Qgil added a comment.Sep 3 2015, 8:02 AM

I think our starting point for structure and deadlines should be to model this using Architecture Summit 2014.

I have taken the deadlines we had for the Architecture Summit 2014 and I have translated them to current dates in the description. I think hard deadlines should apply for keynotes, RFCs, main room sessions, and tracks, but still leave unconference setup for the rest.

Qgil added a comment.Sep 3 2015, 9:06 AM

About the questions asked in the description. We can move to the description what is clear and uncontroversial. If a topic deserves deep discussion / work, let's create subtasks for it.

What will be different about the WMDS in 2016?

  • Addition of a 3rd day focusing on hacking / hands on.
  • Back to RFC/proposal driven program. Last year we ended up being more top-down than needed.
  • Specific tracks proposed for Community Tech (reaching out to community developers of bots / gadgets / templates / tools) and Web APIs (3rd party developers)

Who will be invited? Who will not?

Last year we moved from invitation-only to open registration. I'm for keeping open registration.

Will it be optional for WMF Engineering?

This has been confirmed. Attendance is optional for WMF employees, and teams have to cover the extra expenses from their travel budget. This might mean a lower participation, but a higher sintony of interest of each participant with the event program.

How many and which 3rd party developers?

I think we should work with WMF Strategic Partnerships, Mobile Apps, and our API developers (and Wikipedia Zero?) to create a track dedicated to Web APIs, from intro to "Talk to the developers" sessions, targeting developers interesting in bringing Wikimedia content to their applications. We should reach out to companies and communities in the Bay Area, and invite remarkable contributors and projects from other locations.

Not "3rd party", but another type of new developers that we should reach out specifically are the ones working with gadgets, templates, bots, and tools in our community, plus our developers developing the frameworks and infrastructure for them. The Community Tech team and label could be the catalysts for this. This audience wasn't properly addressed in previous summits and they don't quite fit in the MediaWiki core + extensions RFCs and discussions.

Then there is the MediaWiki Stakeholders Group, but so far there hasn't been a critical mass of developers / participants capable to bootstrap their own track. I think we should open to their proposals through the regular call for participation.

How many and which engineering community members?

It will depend from the proposals we receive and out travel sponsoring budget.

New tracks?

Community Tech and Web APIs.

ECT and EMGT will need to work together figure out event focus and how to make the event useful, worthwhile and impactful.
How do we ensure people who attend have a plan to contribute and add value back into the event. Many people at last years event did not run sessions or contribute to discussions but instead were head down on laptops throughout the entire event. Is this OK? Could those people join remotely instead?

I think we are addressing this problem.

We also need to define and contract social events, meals and transportation plans.
What event support is needed?

Logistics are mostly uncontroversial work that needs to be well addressed, but can be left out of scope for this task/goal.

External keynotes?

Why not. I would not force us to have one, but if we have a good speaker with a good topic, sure. Should we open a call for proposals for external speakers wen we announce the general call for participation? Something simpler, as in send an email with your proposal to...

Widen or narrow focus of event?

Widen. RFC process and open call for participation + Community Tech + WebAPIs should widen the scope as much as the Wikimedia tech community wants to.

Qgil added a comment.Sep 4 2015, 9:27 AM

There are two Developer-Advocacy quarterly goals related to the Wikimedia Developer Summit being proposed at T109829: Developer Relations quarterly goals for October-December 2015. One generic about the event (we need to define which goal specifically and which measurements of success) and another one about a Web APIs track. Your feedback is welcome there or here.

Qgil added a comment.Sep 4 2015, 2:27 PM

Many people at the WMF are wondering whether they should make travel arrangements for the Summit or not. I think the reply is actually quite simple from a user point of view.

Are you planning to be involved in a RfC seeking agreement at the Summit? Are you thinking of organizing a BoF or a training session with other people interested? If the answer is clearly Yes, then that's it.

If you are involved or interested in any of the main themes (to be) defined at T109612, then the answer is also pretty clear. Your help defining these themes is welcome. Which big topics shouldn't be missed at the Summit?

If you don't have a clear plan, don't think your topics will fit this time, or don't feel it's worth pushing for a specific agenda, then you can sit and wait, with the probability that you can skip this edition safely.

Are video recordings possible?

Hangouts on Air may be a way to live steam, but require sufficient dedicated bandwidth.

I had this idea of a track "Know the Wikimedia Stack" to help developers ground themselves in the fundamental technologies at different tiers. Not sure if something like this is planned.

brion added a subscriber: brion.Sep 4 2015, 6:36 PM

I've put some of some of my thoughts about meeting planning on mediawiki.org, and I'd like to use E61: RFC Meeting on #wikimedia-office IRC channel on September 9 (UTC) as an opportunity to discuss this in a lot more depth. I ran out of the time I allotted for myself to put all of my main ideas on that wiki page (as of this writing), but I think there's enough there to talk through.

Qgil added a comment.Sep 8 2015, 2:50 PM

@dr0ptp4kt, let's discuss @RobLa-WMF 's ideas first, specifically

I think we need to have a mix of clearly identified “opportunity” and “action” conversations, and try to encourage the conversations for “education” and “possibility” for before the Developer Summit. Conversations for education and possibility are the easiest to do online rather than in-person, as they are more easily handled asynchronously.

Rob, your proposal and this point specifically about opportunity/action sessions makes sense, and I'm happy to follow your advice of demoting tutorial-like sessions. Some thoughts in no specific order:

  • we need to explain the Life of a Successful Session Proposal, from its inception as a task in Phabricator, its online phase of discussion and preparation work, what happens when it's confirmed and scheduled, during the session, and outcome expected
  • if we follow the ame room structure than last year, we will have five rooms suitable for opportunity / action meetings. We need to find a good use for the main room, though
  • this framework allows anybody to push for any topic as long as it's on-topic, but are we going to push any specific theme or topic beforehand, as in "we organizers must assure that topic X is well covered because it is really important"?
  • apart from the opening and the closure, are we aiming for other keynotes / plenary sessions?

Also, this format would be used for the first two days, but we have a third at the WMF offices where the main theme so far is 'hacking'. I'm fine leaving this third day explicitly unstructured, allowing for hads-on work, continuation of small meetings, conversations, etc.

Qgil added a comment.Sep 9 2015, 9:20 AM

After a couple of conversations with RobLa and Rachel today, I have updated https://www.mediawiki.org/wiki/Wikimedia_Developer_Summit_2016 with what is the best of our knowledge right now about registration, travel sponsorship, call for participation, and selection process. All work in progress draft welcoming your feedback and edits.

daniel added a subscriber: daniel.Sep 9 2015, 9:29 PM
Elitre added a subscriber: Elitre.Sep 10 2015, 5:56 AM
Qgil added a comment.Sep 14 2015, 10:46 AM

@Rfarrand plans to go ahead with T111800: Create registration for Wikimedia Developers Summit and the Call for participation today.

We are still missing T109612: Define main themes of the Wikimedia Developer Summit 2016, but these can be added to the wiki page as soon as they are defined. With the main theme defined and a process focusing on open discussions, this is enough to start the call for participation.

Qgil added a comment.Sep 24 2015, 10:00 AM

I think we are done here.

Rfarrand closed this task as Resolved.Sep 29 2015, 6:11 PM