Page MenuHomePhabricator

Check if links on load are 'known' rather than 'exist' locally
Closed, ResolvedPublic1 Estimated Story Points

Description

Steps to reproduce:

  1. Open a page that has [[:File:Apple2.svg|Text]] on it. The file name must be an image that exists at Commons but not on the local wiki.
  1. Look at the color of the link.

This should display as an external/blue link instead of a red link.

Event Timeline

Whatamidoing-WMF raised the priority of this task from to Medium.
Whatamidoing-WMF updated the task description. (Show Details)
Restricted Application added a subscriber: Steinsplitter. · View Herald TranscriptJul 2 2015, 6:24 PM

Change 222589 had a related patch set uploaded (by Esanders):
Check if links are 'known' rather than 'exist' locally

https://gerrit.wikimedia.org/r/222589

Krenair added a subscriber: Krenair.Jul 3 2015, 3:30 PM

Sounds like this is part of T72123

Change 222589 merged by jenkins-bot:
Check if links are 'known' rather than 'exist' locally

https://gerrit.wikimedia.org/r/222589

Jdforrester-WMF renamed this task from Check if links are 'known' rather than 'exist' locally to Check if links on load are 'known' rather than 'exist' locally.Jul 8 2015, 7:34 PM
Jdforrester-WMF closed this task as Resolved.
Jdforrester-WMF claimed this task.

Fixed for "existing" links (there when you open the page). Using parent for "newly created" ones.

Legoktm added a subscriber: Legoktm.Aug 3 2016, 7:14 AM

I don't think this works - or it has regressed since. Visiting https://www.mediawiki.org/wiki/Extension:TemplateData?veaction=edit I see that the action=visualeditor API call returns links.known as 1, which should mean "treat all non-missing pages as known". But I then immediately see another APi call (presumably from ve.init.mw.LinkCache) checking the existence of every link on the page, and since T72123 is still broken, it turns the links red again.