Page MenuHomePhabricator

<strong> used in a published ContentTranslation page instead of ''' in IE
Closed, InvalidPublic

Description

I'm not sure how to reproduce it, but <strong> tags were used instead of ''' in this article: https://he.wikipedia.org/w/index.php?title=%D7%90%D7%9C%D7%99%D7%96%D7%91%D7%AA_%D7%92%D7%90%D7%A8%D7%95%D7%95%D7%99&action=edit&oldid=17169693

This is translation of https://en.wikipedia.org/wiki/Elizabeth_Garvie to Hebrew.

This is probably a Parsoid failure, but how can Parsoid fail with that? Isn't <strong> one of the simpler things to convert?

Related Objects

StatusAssignedTask
InvalidNone
ResolvedNone
ResolvedAmire80
InvalidNone
OpenAmire80
DeclinedNone
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPginer-WMF
OpenNone
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPetar.petkovic
ResolvedPginer-WMF
Resolvedsanthosh
Resolveddchan
Resolvedsanthosh
Resolvedsanthosh
ResolvedNikerabbit
Opensanthosh
Resolvedsanthosh
ResolvedPginer-WMF
OpenNone
ResolvedPginer-WMF
InvalidNone
ResolvedPetar.petkovic
Resolvedsanthosh
Resolvedsanthosh

Event Timeline

Amire80 created this task.Jul 2 2015, 9:34 PM
Amire80 raised the priority of this task from to Medium.
Amire80 updated the task description. (Show Details)
Amire80 added subscribers: Amire80, ssastry, santhosh.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 2 2015, 9:34 PM
Arlolra added a subscriber: Arlolra.Jul 2 2015, 9:51 PM

''' parses as bold <b>. What leads you to believe these tags weren't user inserted?

This revision was created by ContentTranslation, which is contenteditable. I can't imagine any way in which the user could explicitly write HTML or wiki syntax there. Most likely she pressed Ctrl-B to make it bold or used the B button in ContentTranslation's formatting toolbar.

Arlolra added a comment.EditedJul 2 2015, 10:14 PM

The tags were introduced in a subsequent revision to the initial translation. See,
https://he.wikipedia.org/w/index.php?title=%D7%90%D7%9C%D7%99%D7%96%D7%91%D7%AA_%D7%92%D7%90%D7%A8%D7%95%D7%95%D7%99&type=revision&diff=17169730&oldid=17169699

Once you've published the translation, can you continue making revisions in ContentTranslation? Forgive my ignorance there.

However, I do see a <font>-tag in the initial revision. Is it possible for html tags present in the original wikitext get copied over?

I linked to the oldest revision, and it has <strong>. You may be confusing left and right :)

ContentTranslation can create revisions that are not the first, although it is not built for it, and in any case, this is not happening here.

Arlolra added a comment.EditedJul 2 2015, 11:06 PM

Whoops, yeah, you're right that it was present in the original revision.

Most likely she pressed Ctrl-B to make it bold

That makes sense.

https://developer.mozilla.org/en-US/docs/Web/API/Document/execCommand

bold
Toggles bold on/off for the selection or at the insertion point. (Internet Explorer uses the STRONG tag instead of B.)

I assume VE prevents the default here, if possible.

I asked the editor which browser did she use, and Indeed, it's Microsoft Internet Explorer 11.

This raises three questions:

  1. Can we auto-replace <strong> with <b> before publishing
  2. What other tags should we replace with IE?
  3. When are we switching from contenteditable to VE? :)
Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Jul 3 2015, 1:44 PM
Pginer-WMF moved this task from CX6 to CX7 on the ContentTranslation board.Jul 21 2015, 4:39 PM
Amire80 moved this task from CX7 to CX6 on the ContentTranslation board.Jul 29 2015, 10:42 PM
Amire80 moved this task from CX6 to CX7 on the ContentTranslation board.Oct 2 2015, 2:57 PM
Amire80 moved this task from CX7 to Bugs on the ContentTranslation board.Oct 16 2015, 8:17 AM
Amire80 moved this task from Bugs to CX8 candidates on the ContentTranslation board.
santhosh renamed this task from <strong> used in a published ContentTranslation page instead of ''' to <strong> used in a published ContentTranslation page instead of ''' in IE.Dec 16 2015, 5:12 AM

@Amire80, can you check if the issue is still relevant for CX2. With the new editing surface this may be fixed.

Arrbee moved this task from Bugs to Check & Move on the ContentTranslation board.Apr 29 2019, 12:22 PM
Pginer-WMF closed this task as Invalid.May 13 2019, 2:16 PM

Please, reopen if the issues appears again. The original ticket was affecting the old version and it is expected to be solved with the new one.