Page MenuHomePhabricator

article selector appears every time the user enters Special:ContentTranslation
Closed, ResolvedPublic1 Story Points

Description

Every time a user enters Special:CX, the article selector automatically appears. This is an exaggeration. Often the user wants to continue a previous translation and closing this window is an unnecessary step. I've seen users trying to click "Create a new translation" and getting nothing because the article selector is a modal dialog.

@Pginer-WMF, can you please remind whether there is any need to auto-display the article selector? I have a vague recollection that it was needed for the license, but I'm not sure that even that is needed any longer.

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterDo not show the article selector unless all params passed in URL

Event Timeline

Amire80 created this task.Jul 3 2015, 1:40 PM
Amire80 raised the priority of this task from to Medium.
Amire80 updated the task description. (Show Details)
Amire80 added subscribers: Amire80, Pginer-WMF.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 3 2015, 1:40 PM
Amire80 moved this task from Needs Triage to CX6 on the ContentTranslation board.Jul 3 2015, 1:44 PM

@Pginer-WMF, can you please remind whether there is any need to auto-display the article selector?

No there is not. It should not open automatically when accessing the dashboard.

I have a vague recollection that it was needed for the license, but I'm not sure that even that is needed any longer.

The requirement is that before landing in the Translation editor, the legal text is shown, which will happen anyways if the user opens the "new translation" dialog.

The only special case is when the user tries to access the translation view using the URL (to start a new translation). In that case we are preventing the user to reach the translation view and showing the new translation dialog with the parameters prefilled. This is the only case where we should show the new translation dialog open.

Pginer-WMF moved this task from CX6 to CX7 on the ContentTranslation board.Jul 21 2015, 5:44 PM
Pginer-WMF moved this task from CX7 to CX6 on the ContentTranslation board.
Pginer-WMF moved this task from CX6 to CX7 on the ContentTranslation board.

This seems to be the source of confusion making a use think the work was lost as explained here.

Every time a user enters Special:CX, the article selector automatically appears. This is an exaggeration

We open it automatically when any of the following params are set in URL. If you just got to Special:CX, the selector does not open

// If any of the values are already present,
// show the dialog and initiate a validation.
if ( this.options.sourceLanguage || this.options.targetLanguage ||
	this.options.sourceTitle || this.options.targetTitle
) {
	this.show();
	this.check();
}

We open it automatically when any of the following params are set in URL.

The problem is that clicking on the contributions hover menu sets the target language parameter which results in the dialog to be open. Maybe the dialog should only be opened when source or target title are given, or the hover menu should not set that parameter...

Change 227643 had a related patch set uploaded (by Santhosh):
Do not show the article selector unless all params passed in URL

https://gerrit.wikimedia.org/r/227643

I made the conditions strict - We open it only when all params are filled as per the above patch. Hope that helps.

This comment was removed by santhosh.

I made the conditions strict - We open it only when all params are filled as per the above patch. Hope that helps.

We need to be careful with "target title". We assume that if it is lacking it defaults to the source title. I'm not sure if it is a problem with the current entry points but I can imagine expressing the intent of creating a new translation without setting the target title.

santhosh claimed this task.Jul 29 2015, 6:44 AM
santhosh moved this task from Backlog to In Review on the LE-CX6-Sprint 1 board.

Ok, I excluded targettile from the check

santhosh edited a custom field.Jul 29 2015, 6:47 AM
Amire80 moved this task from CX7 to CX6 on the ContentTranslation board.Jul 29 2015, 12:20 PM

Change 227643 merged by jenkins-bot:
Do not show the article selector unless all params passed in URL

https://gerrit.wikimedia.org/r/227643

santhosh closed this task as Resolved.Jul 31 2015, 3:29 AM
Arrbee moved this task from In Review to Done on the LE-CX6-Sprint 1 board.Jul 31 2015, 7:02 AM