Page MenuHomePhabricator

extensions/Flow - file permissions trigger debian lintian warnings
Closed, ResolvedPublic

Description

0. Context

DEB packages of mediawiki and many of its extensions, are prepared as part of the WP-MIRROR project.
See https://www.mediawiki.org/wiki/Wp-mirror.

  1. Lintian

During the build process, lintian performs a great number of sanity checks, including seeing if each file has file permissions appropriate to its file type.

When lintian sees a non-executable file with 755 permissions, rather than 644, lintian will throw a warning like:

W: wp-mirror-mediawiki-extensions: executable-not-elf-or-script usr/share/wp-mirror-mediawiki/extensions/Flow/scripts/generatecss.php

  1. Files which should have permissions set to 644

Flow/scripts/generatecss.php

  1. Technical details

DEB standards version: 3.9.6
GIT branch: master

Details

Related Gerrit Patches:

Event Timeline

wpmirrordev assigned this task to werdna.
wpmirrordev raised the priority of this task from to Normal.
wpmirrordev updated the task description. (Show Details)
wpmirrordev added a subscriber: wpmirrordev.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJul 3 2015, 6:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 222912 had a related patch set uploaded (by MidPhoto):
remove lintian errors by correcting permission script

https://gerrit.wikimedia.org/r/222912

Change 222912 merged by jenkins-bot:
remove lintian errors by correcting permission script

https://gerrit.wikimedia.org/r/222912

Catrope closed this task as Resolved.Jul 6 2015, 6:42 PM
Catrope added a subscriber: Catrope.

I confirm that the above mentioned debian lintian warning is cured.
Thanks.