Page MenuHomePhabricator

Mails from tools are being marked as 'spam' by gmail
Closed, ResolvedPublic

Description

18:15 <liangent> hmm found the bounces
18:15 <liangent> but they're in Spams
18:15 <liangent> it says "Why is this message in Spam? We've found that lots of messages from mail.tools.wmflabs.org are spam."
18:15 <liangent> in Gmail

Related Objects

StatusAssignedTask
ResolvedNone
InvalidNone
ResolvedLegoktm
OpenNone
Resolved01tonythomas
Resolved01tonythomas
Resolved01tonythomas
Resolvedcsteipp
Resolved01tonythomas
Resolved01tonythomas
InvalidNone
ResolvedNone
Resolved01tonythomas
Resolvedaaron
Resolved01tonythomas
ResolvedNone
Declined01tonythomas
Resolved01tonythomas
OpenNone
ResolvedNone
OpenNone
Resolvedherron

Event Timeline

valhallasw raised the priority of this task from to High.
valhallasw updated the task description. (Show Details)
valhallasw added a project: Toolforge.
valhallasw added subscribers: valhallasw, liangent.
Restricted Application added a project: Cloud-Services. · View Herald TranscriptJul 6 2015, 4:35 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Delivered-To: liangent@gmail.com
Received: by 10.194.122.129 with SMTP id ls1csp815676wjb;
        Mon, 6 Jul 2015 08:30:13 -0700 (PDT)
X-Received: by 10.140.217.147 with SMTP id n141mr59509712qhb.43.1436196611716;
        Mon, 06 Jul 2015 08:30:11 -0700 (PDT)
Return-Path: <>
Received: from mail.tools.wmflabs.org (mail.tools.wmflabs.org. [208.80.155.162])
        by mx.google.com with ESMTPS id 91si21187163qgo.20.2015.07.06.08.30.11
        for <liangent@gmail.com>
        (version=TLSv1 cipher=RC4-SHA bits=128/128);
        Mon, 06 Jul 2015 08:30:11 -0700 (PDT)
Received-SPF: pass (google.com: best guess record for domain of mail.tools.wmflabs.org designates 208.80.155.162 as permitted sender) client-ip=208.80.155.162;
Authentication-Results: mx.google.com;
       spf=pass (google.com: best guess record for domain of mail.tools.wmflabs.org designates 208.80.155.162 as permitted sender) smtp.mail=
Received: from Debian-exim by mail.tools.wmflabs.org with local (Exim 4.76)
	id 1ZC8LT-00058W-3m
	for liangent@tools.wmflabs.org; Mon, 06 Jul 2015 15:30:11 +0000
X-Failed-Recipients: -s@tools.wmflabs.org,
  and@tools.wmflabs.org,
  by@tools.wmflabs.org,
  date@tools.wmflabs.org,
  edits@tools.wmflabs.org,
  from@tools.wmflabs.org,
  Template-Dyk@tools.wmflabs.org,
  User-Liangent@tools.wmflabs.org,
  User-Liangent-adminbot@tools.wmflabs.org
Auto-Submitted: auto-replied
From: Mail Delivery System <Mailer-Daemon@tools.wmflabs.org>
To: liangent@tools.wmflabs.org
Subject: Mail delivery failed: returning message to sender
Message-Id: <E1ZC8LT-00058W-3m@mail.tools.wmflabs.org>
Date: Mon, 06 Jul 2015 15:30:11 +0000
scfc added a subscriber: scfc.Jul 23 2015, 3:11 PM

Are there other Gmail users whose mails from Tools get sorted into the spam folder?

One reason would be lot of failed deliveries arising from the labs domain making gmail consider *.wmflabs.org as spam.

valhallasw moved this task from Triage to Backlog on the Toolforge board.Oct 4 2015, 11:02 AM
Elitre added a subscriber: Elitre.Oct 14 2015, 12:13 PM
coren added a subscriber: coren.Oct 14 2015, 1:11 PM

The headers are okay - and passed SPF so that's not it.

Gmail uses strange heuristics to decide what to think of as spam, at least part of which includes how many people have junked email from the domain, and spamassassin-like tests. I've noticed in the past that email containing IP addresses, in particular, tend to be disliked by spam filter.

I'll try to see if we have a contact at Google we can poke about this.

herron closed this task as Resolved.Nov 9 2018, 10:11 PM
herron claimed this task.
herron added a subscriber: herron.

Transitioning this to closed as there has been no report of recurrence for several years. If the problem is still occurring please don't hesitate to re-open.

Peachey88 updated the task description. (Show Details)
Peachey88 edited projects, added Cloud-Services; removed Toolforge.
Framawiki removed herron as the assignee of this task.Nov 11 2018, 9:12 AM