Page MenuHomePhabricator

Using OAuth should not require a login for new users
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. register a new account on enwiki
  2. go to https://tools.wmflabs.org/oauth-hello-world/
  3. click "Authorize this application"

Expected result: you get the OAuth dialog

Actual result: you need to log in first

This is because users are globally logged in when they log in, but not when they register. This is apparently somewhat intentional to avoid account creation spam (T18864). The OAuth central wiki will be spammed anyway due to the autocreation job that was put in place because of T74469, so there is no reason not to autologin there, and it would make the OAuth workflow smoother.


See also T94885

Event Timeline

Tgr created this task.Jul 7 2015, 1:00 AM
Tgr raised the priority of this task from to Needs Triage.
Tgr updated the task description. (Show Details)
Tgr added a subscriber: Tgr.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 7 2015, 1:00 AM
Sitic added a subscriber: Sitic.Jul 7 2015, 1:17 AM
Tgr added a comment.Jul 18 2015, 9:38 PM

Another approach is that Special:OAuth should start a global login procedure if the user is not logged in locally.

Tgr closed this task as Resolved.Sep 7 2016, 7:07 AM
Tgr claimed this task.

This was fixed by AuthManager. New users are immediately globally logged in now.