Page MenuHomePhabricator

"TypeError: str is undefined" when attempting to save and edit with VisualEditor
Closed, ResolvedPublic1 Story Points

Description

I was trying to submit a change to
https://pt.wikipedia.org/wiki/Uni%C3%A3o_%28matem%C3%A1tica%29?veaction=edit
but the edito got stuck and this error appeared:

{
	"errorMessage": "TypeError: str is undefined",
	"url": "https://pt.wikipedia.org/w/load.php?debug=false&lang=pt&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=J%2FhCC8P1 line 4 > eval",
	"lineNumber": 40,
	"columnNumber": 1146,
	"errorObject": {}
}

Event Timeline

He7d3r created this task.Jul 9 2015, 7:03 PM
He7d3r raised the priority of this task from to Needs Triage.
He7d3r updated the task description. (Show Details)
He7d3r added projects: VisualEditor, JavaScript.
He7d3r added a subscriber: He7d3r.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2015, 7:03 PM
Jdforrester-WMF triaged this task as Unbreak Now! priority.Jul 9 2015, 7:09 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Looks to be in ve.ce.FocusableNode#calculateHighlights on line 437:

surfaceOffset = this.focusableSurface.getSurface().getBoundingClientRect();

(For me it threw 'Uncaught TypeError: Cannot read property 'getSurface' of null'. – this.focusableSurface is null for me on save.)

Works for me...

Has anybody been able to reproduce?
Does somebody plan to work on this ("assignee" field)?
Should this task still be "Unbreak now" priority?

Jdforrester-WMF closed this task as Resolved.Aug 3 2015, 2:26 AM
Jdforrester-WMF claimed this task.

Seems to now work. Odd. Possibly an odd deployment/caching issue?