Page MenuHomePhabricator

Save dialog hang
Closed, ResolvedPublic8 Estimated Story Points

Description

I opened my laptop, decided I should save the doc I was working on in VE in case something got flaky, and then ironically/sadly the save dialog hung :/

Only thing relevant in the console is this:

https://office.wikimedia.org/wiki/User:LuisV_(WMF)/Innovation_survey Failed to load resource: the server responded with a status of 404 (Not Found)

Hung again later on a separate page, but with nothing interesting on the error console - page was https://office.wikimedia.org/w/index.php?title=User:LuisV_(WMF)/Innovation_survey-take2

Looks like that one, somehow, I got logged out, because when I went to the page in a new window to copy/paste the text that was otherwise going to be lost, it forced me to log in again, so perhaps this is related to the spurious logout?

Maybe worth a separate bug:

  • hitting "esc" got me back to the text so I could copy/paste, but "resume editing" was a no-op; if the keyboard shortcut can work, the UI's button should as well.
  • in the few times I've had this problem, after I hit esc, and then hit save again, the save dialog reopens with the "saving animation" in the title bar going on already. Needless to say, hitting "save" a second/third/nth time does not save at this point.

Event Timeline

LuisVilla raised the priority of this task from to High.
LuisVilla updated the task description. (Show Details)
LuisVilla added a project: VisualEditor.
LuisVilla added a subscriber: LuisVilla.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 11 2015, 8:52 PM

Happened two more times this afternoon, again with the weird logouts, again both on office wiki.

Jdforrester-WMF set Security to None.
Jdforrester-WMF edited a custom field.

I don't think the 404 is related. Has the issue been seen since mid July?

Krenair renamed this task from Save dialog hang (related to 404 in error console?) to Save dialog hang.Sep 1 2015, 10:45 PM
Jdforrester-WMF closed this task as Resolved.Dec 3 2015, 1:41 AM
Jdforrester-WMF claimed this task.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

I'm going to provisionally close this. I don't like so to do, but no reproduction steps and no reports of the same happening in six months.