Page MenuHomePhabricator

Horizontal Centering for first tip in share a fact onboarding
Closed, ResolvedPublic

Description

@Niedzielski mentioned that the library used does not provide centering.
The offset looks strange and we should fix this.

Event Timeline

Vibhabamba assigned this task to Niedzielski.
Vibhabamba raised the priority of this task from to Needs Triage.
Vibhabamba updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 14 2015, 6:49 PM

Change 224793 had a related patch set uploaded (by Dbrant):
Tweak appearance of tooltips.

https://gerrit.wikimedia.org/r/224793

Change 224793 merged by jenkins-bot:
Tweak appearance of tooltips.

https://gerrit.wikimedia.org/r/224793

centering is fixed. Signed off by design.

Copy recommendations:

Option 1:
English: Press and hold to select text & share it!
German: Drücken und halten Sie, um Text auszuwählen und teilen Sie es!
Russian: Нажмите и удерживайте, чтобы выбрать текст и разделить его!
Filipino: Pindutin nang matagal upang piliin ang teksto at ibahagi ito!

Option 2:
English: Long Press to select interesting facts and share them!
German: Lange drücken, um interessante Fakten aus und teilen Sie sie!
Filipino: Long pindutin ang upang piliin ang mga kagiliw-giliw na mga katotohanan at ibahagi ang mga ito!

Option 3:
English: Find something interesting? Press and hold to select it for sharing!
German: Finden Sie etwas interessant? Drücken und halten Sie, um auszuwählen und zu teilen!
Russian: Найти что-то интересное? Нажмите и удерживайте, чтобы выбрать и поделиться!
Filipino: Maghanap ng isang bagay na interesante? Pindutin nang matagal upang pumili at ibahagi!

Option 4:**
English: See an interesting fact? Long Press to select and share!
German: Eine interessante Tatsache? Lange drücken, um auszuwählen und zu teilen!
Russian: См интересный факт? Длинные Нажмите, чтобы выбрать и поделиться!
Filipino: Tingnan ang isang kawili-wiling katotohanan? Long Pindutin ang upang piliin at i-share!

Any of these?
IMO it could be interesting to a/b test Options 1 and 4.
Option 1 is more technique based
Option 4 is more around motivation.

A few thoughts on this:

  • I don't really like the term "long press." I think that "press and hold" is much clearer.
  • "Share" is not the only thing you can do when highlighting text. I think that we should also mention the ability to Copy text, at least in passing.
  • I don't know if A/B testing two different verbiages is worth the effort... we probably shouldn't overthink it.

(For reference, the current verbiage in the Alpha app is: "Press and hold anywhere in the text to highlight it for copying and sharing")

p.s. What are those translations? It looks like they're automated (at least the Russian one)...

On 2.0.105-alpha-2015-07-21 "After highlighting an interesting fact, try sharing it on your favorite networks!"

highlighting an interesting fact

  • not necessarily only interesting facts get highlighted

try sharing

  • some implicit doubts about success of the share actions?

p.s. What are those translations? It looks like they're automated (at least the Russian one)...

I agree.

Signed off by design

Checked with 2.0.108-alpha-2015-08-06 on Nexus5(Android 5.1)

Dbrant closed this task as Resolved.Aug 17 2015, 1:45 PM