Page MenuHomePhabricator

Search fragment should be less eager to destroy history
Closed, ResolvedPublic

Description

Description

Steps to reproduce

  1. Tap the search bar.
  2. Observe the most prominent button in the app.

Expected results

Clearing previous search results should be possible, but this feature is so prominent I would mistakenly guess it to be the primary function of the app. As a comparison context, Google Inbox, an email application, uses this button to compose messages. We should come up with a better idea. Maybe a microphone button for speech to text searching? Or how about a filter results button that allows toggling featured, notable, or popular articles?

Actual results

Button is big and red and will likely guide users away from what they want to do (search!).

Event Timeline

Niedzielski updated the task description. (Show Details)
Niedzielski raised the priority of this task from to Needs Triage.
Niedzielski added a subscriber: Niedzielski.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 15 2015, 6:19 AM

Actually, that's Marsala, Pantone's 2015 Color of the Year. :)

@Niedzielski @Dbrant Since this is in Questions for Design, has Design been consulted yet? Just trying to get the task moving.

This is in fact inappropriate usage of the FAB Button according to Material Design guidelines.
It was done in the spirit of using more material design methods.

Kindly deprecate this style. I recommend using a flat button when the user has some content - https://www.google.com/design/spec/components/buttons.html#buttons-flat-raised-buttons

@Vibhabamba: Where should it be positioned? In the same place as the old trash can, even with the "recent searches:" heading?

Change 228427 had a related patch set uploaded (by Mholloway):
Remove FAB from recent searches fragment

https://gerrit.wikimedia.org/r/228427

Change 228427 merged by jenkins-bot:
Remove FAB from recent searches fragment

https://gerrit.wikimedia.org/r/228427

Checked on 2.0.108-alpha-2015-08-07 on Nexus5(Android 5.1)

Dbrant closed this task as Resolved.Aug 17 2015, 1:43 PM
Dbrant claimed this task.