Page MenuHomePhabricator

Invalid confirmation code. The code may have expired in email confirmation (Special:ConfirmEmail)
Closed, ResolvedPublic

Description

Hi!

I'm having an issue when I tried to confirm the "first" email address of a new user. When I click or copy the entire url this message appear
"Confirmar dirección de correo electrónico
Código de confirmación incorrecto. El código debe haber expirado."

"Invalid confirmation code. The code may have expired in email confirmation"
I set the timezone in the server and the php, following this information https://www.mediawiki.org/wiki/Extension_talk:ConfirmAccount/archive_2#Invalid_confirmation_code._The_code_may_have_expired.

but the issue persist.
When I logged in with the same user and I send the email again "preferences>confirm email address", I received a new email and that new url works fine.

I've installed mediawiki 1.25 in a aws ec2 ami instance.
My php version is 5.6.10

thanks!

Event Timeline

Kojinanjo updated the task description. (Show Details)
Kojinanjo raised the priority of this task from to Normal.
Kojinanjo added a subscriber: Kojinanjo.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 15 2015, 3:44 PM

Thanks for taking the time to report this!

Has this been brought up on https://www.mediawiki.org/wiki/Project:Support_desk already? If so, feel free to paste the link to that thread here. Thanks!

Aklapper raised the priority of this task from Normal to Needs Triage.Jul 15 2015, 11:03 PM
Aklapper set Security to None.
Paladox added a subscriber: aaron.Jul 21 2015, 9:46 AM
Zoglun added a subscriber: Zoglun.

It looks like caused by Timestamp. Engineer from huiji.wiki found that
in file User.php line 3672,
comment this line: //'user_touched' => $dbw->timestamp($oldTouched)

could solve this problem, as a temporary fix.

aaron added a comment.Aug 3 2015, 6:53 PM

How many databases are used? Just one master or is replication used?

Zoglun added a comment.Aug 3 2015, 9:41 PM

We (Moegirlpedia) use several different database. I am not sure how much huiji.wiki used.

We use 'zhmoegirl' 'jamoegirl' 'enmoegirl' for article, 'wikidata' for user tab share, and 'commonimage' for image share.

aaron added a comment.Aug 3 2015, 9:45 PM

But is it master/slave or just DB masters?

Change 229024 had a related patch set uploaded (by Aaron Schulz):
Made Special:ConfirmEmail load the user from the master

https://gerrit.wikimedia.org/r/229024

Change 229025 had a related patch set uploaded (by Aaron Schulz):
Made email confirmations load the user from the master

https://gerrit.wikimedia.org/r/229025

Change 229024 merged by jenkins-bot:
Make Special:ConfirmEmail load the user from the master

https://gerrit.wikimedia.org/r/229024

Change 229025 merged by jenkins-bot:
Made email confirmations load the user from the master

https://gerrit.wikimedia.org/r/229025

Aklapper renamed this task from Invalid confirmation code. The code may have expired in email confirmation to Invalid confirmation code. The code may have expired in email confirmation (Special:ConfirmEmail).Aug 11 2015, 10:07 AM
Aklapper triaged this task as High priority.

Patch merged; anything left to do here? @aaron?

Ciencia_Al_Poder added a subscriber: Ciencia_Al_Poder.

anything left to do here?

Backport to 1.25, I suppose (I don't see it in REL1_25)

Adding projects accordingly

Change 233109 had a related patch set uploaded (by Lewis Cawte):
Make Special:ConfirmEmail load the user from the master

https://gerrit.wikimedia.org/r/233109

Change 233109 merged by jenkins-bot:
Make Special:ConfirmEmail load the user from the master

https://gerrit.wikimedia.org/r/233109

Umherirrender closed this task as Resolved.Sep 27 2015, 7:06 PM
Umherirrender claimed this task.
Umherirrender removed Umherirrender as the assignee of this task.Sep 27 2015, 7:19 PM

Invalid email confirmation code on chewiki

@tvlinkfix98: Please comment in T157000 instead.