Page MenuHomePhabricator

On Wikimedia sites, the post-account-creation page (with 'welcomecreation-msg', etc.) is never shown
Closed, DeclinedPublic

Description

On Wikimedia sites, the post-account-creation page (with 'welcomecreation-msg', etc.) is never shown.

This is quite problematic, because many wikis override that message to provide all kinds of welcoming information. For example: https://pl.wikipedia.org/wiki/MediaWiki:Welcomecreation-msg The only welcome message the user gets is Echo's 'notification-new-user'. This can't possibly be a good thing with the editor decline and all that.

When this message was being changed a few years ago, there was a metric ton of announcements (http://www.gossamer-threads.com/lists/wiki/wikitech/317345). Now it just disappeared.

I have no idea what is causing this. Possibly CentralAuth or GuidedTours? Primary suspects are extensions using the UserLoginComplete and BeforeWelcomeCreation hooks.

Event Timeline

matmarex created this task.Jul 19 2015, 5:05 PM
matmarex raised the priority of this task from to High.
matmarex updated the task description. (Show Details)
matmarex added a subscriber: matmarex.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 19 2015, 5:05 PM

(Added User-notice because I think this should be included in some list of "known issues" sometime soon. I have no idea how long this has been a problem.)

Restricted Application added subscribers: Dereckson, Matanya. · View Herald TranscriptJul 19 2015, 5:12 PM

On IRC, @Legoktm suggested this was intentional. Does anyone know what change caused this, and why? Despite the task's description, if there's a good reason I'm minded to reject this, unless it's shown this is disruptive.

Looks like CentralAuth has its own message "centralauth-welcomecreation-msg" for doing this stuff and if it's disabled, it causes the message to not show up at all. (by default, the message is disabled: ""). Perhaps that could be set to reuse the core message? Maybe the fancy GettingStarted enabled on some wikis override this, I don't know.

This is probably a dupe of T54373: Display confirmation message after manual account creation on Wikimedia wikis (the orignal bug that introduced 'centralauth-welcomecreation-msg').

Yes, per Steven's message I believe this was intentional. The point is to send the user back where they were, give them an Echo welcome message, and give them a modal with suggestions on what to do (last only if GettingStarted is enabled).

General welcome messages can be left on user talk, either by users or bots (many wikis already do this). This is more useful, anyway, since you can (optionally bookmark) and return to it easily.

If people really want to re-open this, let's only consider that on wikis without GettingStarted (redirecting back and showing the modal is a key part of the GettingStarted experience)

Removing user-notice since this is not a recent change.

Jdforrester-WMF closed this task as Declined.Jul 23 2015, 10:18 PM
Jdforrester-WMF claimed this task.

Happy to leave it be.