Page MenuHomePhabricator

create labs project for barry the browser bot
Closed, ResolvedPublic

Description

Project Name: barry-the-browser-bot

Purpose: Testing the instructions from T104562

Wikitech Username of requestor: bmansurov

Event Timeline

bmansurov raised the priority of this task from to Needs Triage.
bmansurov updated the task description. (Show Details)
bmansurov added a project: Cloud-Services.
bmansurov added a subscriber: bmansurov.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2015, 9:45 PM

Hi! Do you just need an instance to test the instructions? Isn't there already a project that @rmoen used for the exact purpose? You can create multiple instances under one project.

I'm unclear on what the purpose of the project is. Can you explain?

bmansurov added a comment.EditedJul 21 2015, 9:54 PM

Thanks for the response, @yuvipanda. The purpose is to test the instructions listed at [1]. I want to make sure each step is reproducible. The project can be deleted once testing is done.

[1] https://www.mediawiki.org/wiki/Reading/Setting_up_a_browser_test_instance

I will say that point two there is wrong - you should only request a new project if there isn't an existing project that will fit this. Assuming this is being done for the mobile team, why not in the reading-web-staging project or the reading-smoketest project, which were created for the specific reading team to do tests like these? Since the instructions seem to be Reading specific, the name of the project to create instances in should be specified there too.

OK, thanks. I'll close this ticket as resolved. The instructions need to be updated to use an existing project.

bmansurov closed this task as Resolved.Jul 21 2015, 10:27 PM
bmansurov claimed this task.