Page MenuHomePhabricator

Upload new Zuul .deb package on apt.wikimedia.org for precise-wikimedia and trusty-wikimedia
Closed, ResolvedPublic

Description

I have refreshed the Zuul package for Precise and Trusty to catch up with upstream changes. The Zuul server (gallium) has been upgraded as well as the four Precise Jenkins slaves. Trusty slaves havent been upgraded as of 07/28 20:00 UTC

Can one update apt.wikimedia.org with the new Zuul package The related files can be fetched either via:

precise-wikimedia:

https://people.wikimedia.org/~hashar/debs/zuul_2.0.0-327-g3ebedde-wmf3precise1/
terbium.eqiad.wmnet:/home/hashar/public_html/debs/zuul_2.0.0-327-g3ebedde-wmf3precise1/*

trusty-wikimedia:

https://people.wikimedia.org/~hashar/debs/zuul_2.0.0-327-g3ebedde-wmf3trusty1
terbium.eqiad.wmnet:/home/hashar/public_html/debs/zuul_2.0.0-327-g3ebedde-wmf3trusty1/*

Related Gerrit changes:

Related debian/changelog entries from the Precise package are below. The trusty one is just a merge and is similar.

zuul (2.0.0-327-g3ebedde-wmf3precise1) precise-wikimedia; urgency=medium

  * 0008-Revert-Fix-passing-labels-to-Gerrit-when-they-are-no
    Makes Zuul to send code-review and verified label votes using the shortcuts
    --verified and --code-review since --label is case sensitive.
   See https://phabricator.wikimedia.org/T106596

 -- Antoine Musso <hashar@free.fr>  Thu, 23 Jul 2015 14:11:53 +0000

zuul (2.0.0-327-g3ebedde-wmf2precise1) precise-wikimedia; urgency=medium

  * 0007-Remove-lockfile-from-requirements.patch
  * python-daemon 2.x shipped via the venv

 -- Antoine Musso <hashar@free.fr>  Tue, 21 Jul 2015 21:27:42 +0200

zuul (2.0.0-327-g3ebedde-wmf1precise1) precise-wikimedia; urgency=low

  * Bump upstream 5984adc..3ebedde
  * python-daemon to >= 2.0.4

 -- Antoine Musso <hashar@free.fr>  Tue, 21 Jul 2015 16:29:03 +0200


zuul (2.0.0-306-g5984adc-wmf1precise1) precise-wikimedia; urgency=low

  * Bump GitPython from 0.3.2.RC1 to 0.3.2.1. Fetched by dh_virtualenv.

 -- Antoine Musso <hashar@free.fr>  Mon, 20 Jul 2015 16:10:02 +0200

zuul (2.0.0-304-g685ca22-wmf2precise1) precise-wikimedia; urgency=low

  * T97106 zuul-cloner should use hard links when fetching from cache-dir
    Incorporate patch https://review.openstack.org/#/c/117626/4 which makes
    zuul-cloner to use hardlinks from git cache.

 -- Antoine Musso <hashar@free.fr>  Wed, 29 Apr 2015 15:42:21 +0200

Event Timeline

hashar created this task.Jul 22 2015, 10:32 AM
hashar raised the priority of this task from to Needs Triage.
hashar updated the task description. (Show Details)
hashar added a subscriber: hashar.
Restricted Application added subscribers: Matanya, Aklapper. · View Herald TranscriptJul 22 2015, 10:32 AM
hashar changed the task status from Open to Stalled.Jul 22 2015, 9:09 PM

There is some nasty regression in it so marking T106531 as a blocker.

Will craft a new package with Revert "Fix passing labels to Gerrit when they are not defined in All-Projects" https://gerrit.wikimedia.org/r/226415

Meanwhile, I am stalling this task.

hashar changed the task status from Stalled to Open.Jul 28 2015, 3:28 PM
hashar updated the task description. (Show Details)
hashar set Security to None.
hashar added a subscriber: fgiunchedi.

Bumped the package to wmf3:

zuul (2.0.0-327-g3ebedde-wmf3precise1) precise-wikimedia; urgency=medium

  * 0008-Revert-Fix-passing-labels-to-Gerrit-when-they-are-no
    Makes Zuul to send code-review and verified label votes using the shortcuts
    --verified and --code-review since --label is case sensitive.
   See https://phabricator.wikimedia.org/T106596

 -- Antoine Musso <hashar@free.fr>  Thu, 23 Jul 2015 14:11:53 +0000

https://people.wikimedia.org/~hashar/debs/zuul_2.0.0-327-g3ebedde-wmf3precise1/

The Zuul scheduler on gallium.wikimedia.org is already running that version (manually upgraded). Once apt.wikimedia.org is updated I will upgrade the package on the Precise slaves.

Trusty will be deal with later on. I have some troubles building it :-/

hashar renamed this task from Upload new Zuul .deb package on apt.wikimedia.org for precise-wikimedia to Upload new Zuul .deb package on apt.wikimedia.org for precise-wikimedia and trusty-wikimedia.Jul 28 2015, 8:00 PM
hashar updated the task description. (Show Details)

Finally rebuild the package for Trusty as zuul_2.0.0-327-g3ebedde-wmf3trusty1 . I have updated the task detail.

fgiunchedi closed this task as Resolved.Jul 29 2015, 1:38 PM
fgiunchedi claimed this task.

{{done}}

root@carbon:~# reprepro -C main --ignore=wrongdistribution include trusty-wikimedia ~filippo/deb/zuul_2.0.0-327-g3ebedde-wmf3trusty1_amd64.changes 
Exporting indices...
Deleting files no longer referenced...
root@carbon:~# reprepro -C main --ignore=wrongdistribution include precise-wikimedia ~filippo/deb/zuul_2.0.0-327-g3ebedde-wmf3precise1_amd64.changes 
Exporting indices...
Deleting files no longer referenced...
root@carbon:~#

Upgraded on all CI slaves. Thank you very much!