Page MenuHomePhabricator

Make new tabs appear behind the current tab, not in front.
Closed, ResolvedPublic

Description

Currently, selecting "open in new tab" creates a new tab with the selected page, and brings it to the foreground.
A more intuitive behavior would be to create the new tab, and keep it in the background (behind the current tab).

(The animation that we currently have then opening a new tab can still be used here, I think)

Event Timeline

Dbrant created this task.Jul 23 2015, 4:32 PM
Dbrant updated the task description. (Show Details)
Dbrant raised the priority of this task from to Normal.
Dbrant moved this task to Needs Triage on the Wikipedia-Android-App-Backlog board.
Dbrant added a subscriber: Dbrant.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 23 2015, 4:32 PM

Change 226611 had a related patch set uploaded (by Dbrant):
Make new tabs appear behind the current tab.

https://gerrit.wikimedia.org/r/226611

Change 226611 merged by jenkins-bot:
Make new tabs appear behind the current tab.

https://gerrit.wikimedia.org/r/226611

Signed off by Design

@Dbrant I see what you are suggesting here, but this also this might be good to test.
Adding @pizzacat

Checked with 2.0.108-alpha-2015-08-07 on Nexus5(Android 5.1)

Dbrant closed this task as Resolved.Aug 17 2015, 1:44 PM