Page MenuHomePhabricator

Empty Special:Search should not become red
Closed, ResolvedPublic

Description

Since Special:Search got a new autocompletion thingy, the search bar got quite nasty. One specific behaviour, for instance, makes little sense.

  1. Reach Special:Search
  2. Click advanced search
  3. If the cursor is not in the search bar, click it.
  4. Click some checkbox

I. Observed: Search bar becomes red because it's empty. (Also happens in step 2 with monobook/Firefox 38 because the search bar is autofocused.)

  1. Type something.
  2. Delete the text to start typing from scratch.

II. Observed: Again the search bar becomes red.

I'm not sure if there is any case where Special:Search can correctly guess that I'm wrong in not typing something in the search bar. If the user didn't type anything, they probably have their reasons and will soon find out when they hit search anyway. Either the red alert is made much smarter, or it should be removed.

This is in 1.26wmf15 (fc35b2f).

Related Objects

StatusAssignedTask
ResolvedEsanders
OpenNone
OpenNone
OpenNone
ResolvedMarkTraceur
Resolvedmatmarex
Resolvedmatmarex
Resolvedmatmarex
OpenNone
OpenNone
OpenNone
ResolvedJdlrobson
Resolvedmatmarex
Resolvedmatmarex
OpenNone
OpenNone
ResolvedEsanders
DuplicateNone
ResolvedTTO
ResolvedJayprakash12345
Resolvedmatmarex
OpenNone
ResolvedFlorian
ResolvedFlorian

Event Timeline

Nemo_bis created this task.Jul 25 2015, 2:00 PM
Nemo_bis raised the priority of this task from to Needs Triage.
Nemo_bis updated the task description. (Show Details)
Nemo_bis added a project: MediaWiki-Search.
Nemo_bis added a subscriber: Nemo_bis.
Restricted Application added a project: Discovery. · View Herald TranscriptJul 25 2015, 2:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Since Special:Search got a new autocompletion thingy, the search bar got quite nasty. One specific behaviour, for instance, makes little sense.

That change was recently reverted for unrelated reasons (T106273), but I'll keep this open to bear in mind when we try again.

That said, I can't see under what circumstances not typing anything in the search field would not be a user error. Elaborate?

If i click a checkbox in the advanced search, the search input doesn't become red (in Chrome)? :)

That said, I can't see under what circumstances not typing anything in the search field would not be a user error. Elaborate?

It's conceivable to have some search backend where selecting a namespace without a search query lets you get a list of all pages matching that namespace, or where some filters/search queries are input in another way, But that's tangential.

The point is that the user doesn't need to be reminded that there is a search bar: that's very obvious. Scarying the user about something that does no harm and the user can fix on their own is only harmful.

If i click a checkbox in the advanced search, the search input doesn't become red (in Chrome)? :)

Confirmed, that's because the search bar is not autofocused; let me fix the steps to reproduce.

Nemo_bis updated the task description. (Show Details)Jul 25 2015, 4:58 PM
Nemo_bis set Security to None.
Ironholds moved this task from Needs triage to Search on the Discovery board.Aug 4 2015, 8:17 AM
Florian claimed this task.Nov 12 2015, 5:00 PM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptNov 12 2015, 5:00 PM
Florian triaged this task as Normal priority.Nov 12 2015, 5:00 PM

Change 252717 had a related patch set uploaded (by Florianschmidtwelzow):
Allow a TitleInputWidget user to decide, if an empty value should be marked as red

https://gerrit.wikimedia.org/r/252717

Change 252717 merged by jenkins-bot:
Allow a TitleInputWidget user to decide, if an empty value should be validated

https://gerrit.wikimedia.org/r/252717

Jdforrester-WMF closed this task as Resolved.Nov 16 2015, 6:42 PM
Jdforrester-WMF removed a project: Patch-For-Review.