Page MenuHomePhabricator

Icons are missing on fast closing and opening the tabs
Closed, ResolvedPublic

Description

Steps to reproduce:

  • A edit window is loaded and the Advanced tab is open.
  • Click fast twice on the Advanced tab.
  • The tab correctly closes and open again, but the icons are missing.

Event Timeline

Fomafix created this task.Jul 26 2015, 7:44 PM
Fomafix raised the priority of this task from to Low.
Fomafix updated the task description. (Show Details)
Fomafix added a project: WikiEditor.
Fomafix added a subscriber: Fomafix.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 26 2015, 7:44 PM
GOIII added a subscriber: GOIII.EditedJul 26 2015, 7:57 PM

Confirmed.-- Win8.1 & IE11

Was able to reproduce several times.

  • Leaving the Advanced tab open in the previous editing session had no bearing on the behavior.
  • Only the "speed" of opening & closing the tab causes the icons not to render.

And sometimes it took 2 tries +; otherwise happens after 1 try.

Fomafix added a comment.EditedJul 26 2015, 8:06 PM

https://gerrit.wikimedia.org/r/226676 changes the behavior but does not solve the problem.

GOIII added a comment.Jul 26 2015, 8:41 PM

Can we rule out the possibility this behavior was always present yet not revealed until now?

I mean is it possible this might be more about the use of a single sprited multi-image file for all the buttons or something than it is about deferred loading and spinner delay?

The reason for the strange behavior are unfinished animations. https://gerrit.wikimedia.org/r/226676 combines the animation of the height and the fading of the icons to one animation and removes the strange setTimeout(). I guess the problems with animations can solved by aborting any running animations before starting new animations.

Change 280685 had a related patch set uploaded (by Ferveo):
Stop any other tab animations when clicking on the tab button

https://gerrit.wikimedia.org/r/280685

Change 280685 merged by jenkins-bot:
Stop any other tab animations when clicking on the tab button

https://gerrit.wikimedia.org/r/280685

TheDJ closed this task as Resolved.Apr 1 2016, 10:42 AM
TheDJ assigned this task to ferveo.
GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:04 AM

Verified on dewiki.